[sip-comm-dev] Unrecognized option: 10000 when running ant rebuild


#1

Hi all,

I'm a newbie with using ant and SIP Communicator, and today, after the first
time I checked-out the trunk and tried building it with ant rebuild, this
error popped up when compiling.. (see attached file)
I added a bit of my system info at the top..
Could you give me any advice on how to solve this problem?

Thanks in advance,

sip-communicator-ant-error.txt (2.09 KB)

···

--
-- Ondrej Škopek


#2

Hi,

can you give more details about what java SDK do you use, as I'm also
using Linux and have no problem compiling the project and the error
you get is strange to me.

Regards
damencho

···

2010/9/5 Ondrej Škopek <skopekondrej@gmail.com>:

Hi all,

I'm a newbie with using ant and SIP Communicator, and today, after the first
time I checked-out the trunk and tried building it with ant rebuild, this
error popped up when compiling.. (see attached file)
I added a bit of my system info at the top..
Could you give me any advice on how to solve this problem?

Thanks in advance,

--
-- Ondrej Škopek

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#3

Hi Damian,

this is the output of java -version
java version "1.6.0_16"
Java(TM) SE Runtime Environment (build 1.6.0_16-b01)
Java HotSpot(TM) Client VM (build 14.2-b01, mixed mode, sharing)

I haven't had any problems regarding compiling any other projects since
today on this machine...

···

On Sun, Sep 5, 2010 at 9:10 PM, Damian Minkov <damencho@sip-communicator.org > wrote:

Hi,

can you give more details about what java SDK do you use, as I'm also
using Linux and have no problem compiling the project and the error
you get is strange to me.

Regards
damencho

2010/9/5 Ondrej Škopek <skopekondrej@gmail.com>:
> Hi all,
>
> I'm a newbie with using ant and SIP Communicator, and today, after the
first
> time I checked-out the trunk and tried building it with ant rebuild, this
> error popped up when compiling.. (see attached file)
> I added a bit of my system info at the top..
> Could you give me any advice on how to solve this problem?
>
> Thanks in advance,
>
>
> --
> -- Ondrej Škopek
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
> For additional commands, e-mail: dev-help@sip-communicator.dev.java.net
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

--
-- Ondrej Škopek


#4

Hi again,

strange, it seems your compiler doesn't recognize the maxwarns option,
you can try editing build xml in target compile, its on line 292, try
removing the following "-Xmaxwarns ${maxwarns}" and try rebuilding
again.

Cheers
damencho

···

2010/9/5 Ondrej Škopek <skopekondrej@gmail.com>:

Hi Damian,

this is the output of java -version
java version "1.6.0_16"
Java(TM) SE Runtime Environment (build 1.6.0_16-b01)
Java HotSpot(TM) Client VM (build 14.2-b01, mixed mode, sharing)

I haven't had any problems regarding compiling any other projects since
today on this machine...

On Sun, Sep 5, 2010 at 9:10 PM, Damian Minkov > <damencho@sip-communicator.org> wrote:

Hi,

can you give more details about what java SDK do you use, as I'm also
using Linux and have no problem compiling the project and the error
you get is strange to me.

Regards
damencho

2010/9/5 Ondrej Škopek <skopekondrej@gmail.com>:
> Hi all,
>
> I'm a newbie with using ant and SIP Communicator, and today, after the
> first
> time I checked-out the trunk and tried building it with ant rebuild,
> this
> error popped up when compiling.. (see attached file)
> I added a bit of my system info at the top..
> Could you give me any advice on how to solve this problem?
>
> Thanks in advance,
>
>
> --
> -- Ondrej Škopek
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
> For additional commands, e-mail: dev-help@sip-communicator.dev.java.net
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

--
-- Ondrej Škopek

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#5

Hi,

After looking at the error output It seems to me that the JDK is gcj (=> the "^^^^^^^^^^^^^^^^^^^^^^^^^^^" line). Can you show us the JAVA_HOME environment variable (echo $JAVA_HOME) ?

And also the javac -version (not java -version) ?

Regards,

···

--
Seb

Le 06/09/2010 07:50, Damian Minkov a écrit :

Hi again,

strange, it seems your compiler doesn't recognize the maxwarns option,
you can try editing build xml in target compile, its on line 292, try
removing the following "-Xmaxwarns ${maxwarns}" and try rebuilding
again.

Cheers
damencho

2010/9/5 Ondrej Škopek<skopekondrej@gmail.com>:
   

Hi Damian,

this is the output of java -version
java version "1.6.0_16"
Java(TM) SE Runtime Environment (build 1.6.0_16-b01)
Java HotSpot(TM) Client VM (build 14.2-b01, mixed mode, sharing)

I haven't had any problems regarding compiling any other projects since
today on this machine...

On Sun, Sep 5, 2010 at 9:10 PM, Damian Minkov >> <damencho@sip-communicator.org> wrote:
     

Hi,

can you give more details about what java SDK do you use, as I'm also
using Linux and have no problem compiling the project and the error
you get is strange to me.

Regards
damencho

2010/9/5 Ondrej Škopek<skopekondrej@gmail.com>:
       

Hi all,

I'm a newbie with using ant and SIP Communicator, and today, after the
first
time I checked-out the trunk and tried building it with ant rebuild,
this
error popped up when compiling.. (see attached file)
I added a bit of my system info at the top..
Could you give me any advice on how to solve this problem?

Thanks in advance,

--
-- Ondrej Škopek

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

--
-- Ondrej Škopek

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#6

Hi,

Sebastien:
javac -version:
javac 1.6.0_16

and $JAVA_HOME is not set..

Damian:
after I removed that parameter, it built successfully!

Thanks, both of you!

···

On Mon, Sep 6, 2010 at 8:40 AM, Sebastien Vincent <seb@sip-communicator.org>wrote:

Hi,

After looking at the error output It seems to me that the JDK is gcj (=>
the "^^^^^^^^^^^^^^^^^^^^^^^^^^^" line). Can you show us the JAVA_HOME
environment variable (echo $JAVA_HOME) ?

And also the javac -version (not java -version) ?

Regards,
--
Seb

Le 06/09/2010 07:50, Damian Minkov a écrit :

Hi again,

strange, it seems your compiler doesn't recognize the maxwarns option,
you can try editing build xml in target compile, its on line 292, try
removing the following "-Xmaxwarns ${maxwarns}" and try rebuilding
again.

Cheers
damencho

2010/9/5 Ondrej Škopek<skopekondrej@gmail.com>:

Hi Damian,

this is the output of java -version
java version "1.6.0_16"
Java(TM) SE Runtime Environment (build 1.6.0_16-b01)
Java HotSpot(TM) Client VM (build 14.2-b01, mixed mode, sharing)

I haven't had any problems regarding compiling any other projects since
today on this machine...

On Sun, Sep 5, 2010 at 9:10 PM, Damian Minkov >>> <damencho@sip-communicator.org> wrote:

Hi,

can you give more details about what java SDK do you use, as I'm also
using Linux and have no problem compiling the project and the error
you get is strange to me.

Regards
damencho

2010/9/5 Ondrej Škopek<skopekondrej@gmail.com>:

Hi all,

I'm a newbie with using ant and SIP Communicator, and today, after the
first
time I checked-out the trunk and tried building it with ant rebuild,
this
error popped up when compiling.. (see attached file)
I added a bit of my system info at the top..
Could you give me any advice on how to solve this problem?

Thanks in advance,

--
-- Ondrej Škopek

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail:
dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

--
-- Ondrej Škopek

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

--
-- Ondrej Škopek