[sip-comm-dev] Testing S-C SIP to BroadVoice Fails


#1

I have an account at Broadvoice that I have tested to work properly
with an Asterisk server that initiates calls to BroadVoice. But I tried
using S-C v1.0-alpha3-nightly.build.1260 (under an up-to-date Ubuntu
8.04/Hardy with the java-6-openjdk Java alternative), and I can't
connect S-C to my BroadVoice SIP account.

  I installed a fresh sip-communicator from the project's Debian
repository, then accepted its offer to upgrade to the latest, build
1260. I restarted the app. The "Sign In" protocols/accounts dialog at
startup let me enter my SIP username as <pstn-phone#>@sip.broadvoice.com
(with my actual pstn-phone#), and my password (known as "secret" in my
Asterisk SIP configuration). When I clicked that dialog's "Sign In"
button, after a few seconds, I got an "Error" dialog saying:

--------------------------------------------------------
Connection failed for the following account:
User name: <pstn-phone#>
Server name: sip.broadvoice.com.
Please check your network connection or contact your network
administrator for more information.

···

--------------------------------------------------------

I am running this workstation behind a few routers to the Internet, more
than one of which has a firewall and a NAT, so maybe the necessary
ports are closed. Is that the problem?

  I tried to enter my username as <pstn-phone#>@broadvoice.com (not
@sip.broadvoice.com), but that failed the same way. I tried the menu
"Tools" -> "Settings" for the "Configuration" dialog, the "Accounts"
tab, which showed my account (as <pstn-phone#>, without the @<server>);
I clicked the "Settings" button, for the "Account Registration Wizard"
dialog, which showed my full <pstn-phone#>@sip.broadvoice.com (or
<pstn-phone#>@broadvoice.com when I used that server name) and the
obscured password (and "remember password" checked). I clicked the
"Advanced" tab. I clicked "Override server default options", and changed
the "Proxy" field, because BroadVoice has several different proxy
servers at different IP#s, but all served in DNS round-robin as
sip.broadvoice.com . So I set the Proxy field to each of several
different proxy IP#s. It failed the same way as before, with the same
dialog. I tried to go to the main S-C window, its "Dial" tab, and dial a
phone#. It failed with "Could not access...".

  I don't see how to configure S-C to use my SIP account, and I don't see
how to get more diagnostic info. Please advise.
--

(C) Matthew Rubenstein

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#2

Hey Matthew,

What first drew my attention was the fact that you are using
java-6-openjdk. Personally, I've never tried SC with it and have only
been using sun-java6-jdk. I know for a fact that we have problems with
java-gcj so I thought that this may be the reason for your problems.

As I read through your mail however the problem seems to be on a
higher level. Would you mind sending a wireshark dump and a log
excerpt from your session to this list? That should tell us more aa to
what's happening.

Cheers
Emil

···

On Tue, Jul 29, 2008 at 9:11 PM, Matthew Rubenstein <email@mattruby.com> wrote:

       I have an account at Broadvoice that I have tested to work properly
with an Asterisk server that initiates calls to BroadVoice. But I tried
using S-C v1.0-alpha3-nightly.build.1260 (under an up-to-date Ubuntu
8.04/Hardy with the java-6-openjdk Java alternative), and I can't
connect S-C to my BroadVoice SIP account.

       I installed a fresh sip-communicator from the project's Debian
repository, then accepted its offer to upgrade to the latest, build
1260. I restarted the app. The "Sign In" protocols/accounts dialog at
startup let me enter my SIP username as <pstn-phone#>@sip.broadvoice.com
(with my actual pstn-phone#), and my password (known as "secret" in my
Asterisk SIP configuration). When I clicked that dialog's "Sign In"
button, after a few seconds, I got an "Error" dialog saying:

--------------------------------------------------------
Connection failed for the following account:
User name: <pstn-phone#>
Server name: sip.broadvoice.com.
Please check your network connection or contact your network
administrator for more information.
--------------------------------------------------------

I am running this workstation behind a few routers to the Internet, more
than one of which has a firewall and a NAT, so maybe the necessary
ports are closed. Is that the problem?

       I tried to enter my username as <pstn-phone#>@broadvoice.com (not
@sip.broadvoice.com), but that failed the same way. I tried the menu
"Tools" -> "Settings" for the "Configuration" dialog, the "Accounts"
tab, which showed my account (as <pstn-phone#>, without the @<server>);
I clicked the "Settings" button, for the "Account Registration Wizard"
dialog, which showed my full <pstn-phone#>@sip.broadvoice.com (or
<pstn-phone#>@broadvoice.com when I used that server name) and the
obscured password (and "remember password" checked). I clicked the
"Advanced" tab. I clicked "Override server default options", and changed
the "Proxy" field, because BroadVoice has several different proxy
servers at different IP#s, but all served in DNS round-robin as
sip.broadvoice.com . So I set the Proxy field to each of several
different proxy IP#s. It failed the same way as before, with the same
dialog. I tried to go to the main S-C window, its "Dial" tab, and dial a
phone#. It failed with "Could not access...".

       I don't see how to configure S-C to use my SIP account, and I don't see
how to get more diagnostic info. Please advise.
--

(C) Matthew Rubenstein

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#3

Attached, please find a segment of the sip-communicator.log that was
recorded during my failed startup attempt to login to my BroadVoice
account. I have anonymized the account username/phone# as PSTN_PHONEN ,
and my host's IP# has been changed.

  I'm setting up to run a wireshark dump of another rerun of failed
transaction. I will send it along when it's done, unless you let me know
you've figured it out without the wireshark dump.

  FWIW, I'm having some small GUI glitches during this process, but
they're workaroundable, and don't seem at all related to the SIP login
failing.

bv-login-fail.anon.log (14.5 KB)

···

On Thu, 2008-07-31 at 18:56 +0200, Emil Ivov wrote:

Hey Matthew,

What first drew my attention was the fact that you are using
java-6-openjdk. Personally, I've never tried SC with it and have only
been using sun-java6-jdk. I know for a fact that we have problems with
java-gcj so I thought that this may be the reason for your problems.

As I read through your mail however the problem seems to be on a
higher level. Would you mind sending a wireshark dump and a log
excerpt from your session to this list? That should tell us more aa to
what's happening.

Cheers
Emil

On Tue, Jul 29, 2008 at 9:11 PM, Matthew Rubenstein <email@mattruby.com> wrote:
> I have an account at Broadvoice that I have tested to work properly
> with an Asterisk server that initiates calls to BroadVoice. But I tried
> using S-C v1.0-alpha3-nightly.build.1260 (under an up-to-date Ubuntu
> 8.04/Hardy with the java-6-openjdk Java alternative), and I can't
> connect S-C to my BroadVoice SIP account.
>
> I installed a fresh sip-communicator from the project's Debian
> repository, then accepted its offer to upgrade to the latest, build
> 1260. I restarted the app. The "Sign In" protocols/accounts dialog at
> startup let me enter my SIP username as <pstn-phone#>@sip.broadvoice.com
> (with my actual pstn-phone#), and my password (known as "secret" in my
> Asterisk SIP configuration). When I clicked that dialog's "Sign In"
> button, after a few seconds, I got an "Error" dialog saying:
>
> --------------------------------------------------------
> Connection failed for the following account:
> User name: <pstn-phone#>
> Server name: sip.broadvoice.com.
> Please check your network connection or contact your network
> administrator for more information.
> --------------------------------------------------------
>
> I am running this workstation behind a few routers to the Internet, more
> than one of which has a firewall and a NAT, so maybe the necessary
> ports are closed. Is that the problem?
>
> I tried to enter my username as <pstn-phone#>@broadvoice.com (not
> @sip.broadvoice.com), but that failed the same way. I tried the menu
> "Tools" -> "Settings" for the "Configuration" dialog, the "Accounts"
> tab, which showed my account (as <pstn-phone#>, without the @<server>);
> I clicked the "Settings" button, for the "Account Registration Wizard"
> dialog, which showed my full <pstn-phone#>@sip.broadvoice.com (or
> <pstn-phone#>@broadvoice.com when I used that server name) and the
> obscured password (and "remember password" checked). I clicked the
> "Advanced" tab. I clicked "Override server default options", and changed
> the "Proxy" field, because BroadVoice has several different proxy
> servers at different IP#s, but all served in DNS round-robin as
> sip.broadvoice.com . So I set the Proxy field to each of several
> different proxy IP#s. It failed the same way as before, with the same
> dialog. I tried to go to the main S-C window, its "Dial" tab, and dial a
> phone#. It failed with "Could not access...".
>
> I don't see how to configure S-C to use my SIP account, and I don't see
> how to get more diagnostic info. Please advise.
> --
>
> (C) Matthew Rubenstein
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
> For additional commands, e-mail: dev-help@sip-communicator.dev.java.net
>
>

--

(C) Matthew Rubenstein


#4

Is anyone interested in helping me get past this bug?

···

On Thu, 2008-07-31 at 14:08 -0400, Matthew Rubenstein wrote:

  Attached, please find a segment of the sip-communicator.log that was
recorded during my failed startup attempt to login to my BroadVoice
account. I have anonymized the account username/phone# as PSTN_PHONEN ,
and my host's IP# has been changed.

  I'm setting up to run a wireshark dump of another rerun of failed
transaction. I will send it along when it's done, unless you let me know
you've figured it out without the wireshark dump.

  FWIW, I'm having some small GUI glitches during this process, but
they're workaroundable, and don't seem at all related to the SIP login
failing.

On Thu, 2008-07-31 at 18:56 +0200, Emil Ivov wrote:
> Hey Matthew,
>
> What first drew my attention was the fact that you are using
> java-6-openjdk. Personally, I've never tried SC with it and have only
> been using sun-java6-jdk. I know for a fact that we have problems with
> java-gcj so I thought that this may be the reason for your problems.
>
> As I read through your mail however the problem seems to be on a
> higher level. Would you mind sending a wireshark dump and a log
> excerpt from your session to this list? That should tell us more aa to
> what's happening.
>
> Cheers
> Emil
>
> On Tue, Jul 29, 2008 at 9:11 PM, Matthew Rubenstein <email@mattruby.com> wrote:
> > I have an account at Broadvoice that I have tested to work properly
> > with an Asterisk server that initiates calls to BroadVoice. But I tried
> > using S-C v1.0-alpha3-nightly.build.1260 (under an up-to-date Ubuntu
> > 8.04/Hardy with the java-6-openjdk Java alternative), and I can't
> > connect S-C to my BroadVoice SIP account.
> >
> > I installed a fresh sip-communicator from the project's Debian
> > repository, then accepted its offer to upgrade to the latest, build
> > 1260. I restarted the app. The "Sign In" protocols/accounts dialog at
> > startup let me enter my SIP username as <pstn-phone#>@sip.broadvoice.com
> > (with my actual pstn-phone#), and my password (known as "secret" in my
> > Asterisk SIP configuration). When I clicked that dialog's "Sign In"
> > button, after a few seconds, I got an "Error" dialog saying:
> >
> > --------------------------------------------------------
> > Connection failed for the following account:
> > User name: <pstn-phone#>
> > Server name: sip.broadvoice.com.
> > Please check your network connection or contact your network
> > administrator for more information.
> > --------------------------------------------------------
> >
> > I am running this workstation behind a few routers to the Internet, more
> > than one of which has a firewall and a NAT, so maybe the necessary
> > ports are closed. Is that the problem?
> >
> > I tried to enter my username as <pstn-phone#>@broadvoice.com (not
> > @sip.broadvoice.com), but that failed the same way. I tried the menu
> > "Tools" -> "Settings" for the "Configuration" dialog, the "Accounts"
> > tab, which showed my account (as <pstn-phone#>, without the @<server>);
> > I clicked the "Settings" button, for the "Account Registration Wizard"
> > dialog, which showed my full <pstn-phone#>@sip.broadvoice.com (or
> > <pstn-phone#>@broadvoice.com when I used that server name) and the
> > obscured password (and "remember password" checked). I clicked the
> > "Advanced" tab. I clicked "Override server default options", and changed
> > the "Proxy" field, because BroadVoice has several different proxy
> > servers at different IP#s, but all served in DNS round-robin as
> > sip.broadvoice.com . So I set the Proxy field to each of several
> > different proxy IP#s. It failed the same way as before, with the same
> > dialog. I tried to go to the main S-C window, its "Dial" tab, and dial a
> > phone#. It failed with "Could not access...".
> >
> > I don't see how to configure S-C to use my SIP account, and I don't see
> > how to get more diagnostic info. Please advise.
> > --
> >
> > (C) Matthew Rubenstein
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
> > For additional commands, e-mail: dev-help@sip-communicator.dev.java.net
> >
> >

--

(C) Matthew Rubenstein


#5

Hey Mathew,

It seems that you are getting a 409 error response from the server. This
is quite uncommon since 409 was defined in RFC 2543 and then deprecated
by 3261. Here's what 2543 says on the matter:

   The request could not be completed due to a conflict with the current
   state of the resource. This response is returned if the action
   parameter in a REGISTER request conflicts with existing
   registrations.

Could it be that you are having a second phone running with the same
credentials?

Emil

Matthew Rubenstein написа:

···

  Is anyone interested in helping me get past this bug?

On Thu, 2008-07-31 at 14:08 -0400, Matthew Rubenstein wrote:

  Attached, please find a segment of the sip-communicator.log that was
recorded during my failed startup attempt to login to my BroadVoice
account. I have anonymized the account username/phone# as PSTN_PHONEN ,
and my host's IP# has been changed.

  I'm setting up to run a wireshark dump of another rerun of failed
transaction. I will send it along when it's done, unless you let me know
you've figured it out without the wireshark dump.

  FWIW, I'm having some small GUI glitches during this process, but
they're workaroundable, and don't seem at all related to the SIP login
failing.

On Thu, 2008-07-31 at 18:56 +0200, Emil Ivov wrote:

Hey Matthew,

What first drew my attention was the fact that you are using
java-6-openjdk. Personally, I've never tried SC with it and have only
been using sun-java6-jdk. I know for a fact that we have problems with
java-gcj so I thought that this may be the reason for your problems.

As I read through your mail however the problem seems to be on a
higher level. Would you mind sending a wireshark dump and a log
excerpt from your session to this list? That should tell us more aa to
what's happening.

Cheers
Emil

On Tue, Jul 29, 2008 at 9:11 PM, Matthew Rubenstein <email@mattruby.com> wrote:

       I have an account at Broadvoice that I have tested to work properly
with an Asterisk server that initiates calls to BroadVoice. But I tried
using S-C v1.0-alpha3-nightly.build.1260 (under an up-to-date Ubuntu
8.04/Hardy with the java-6-openjdk Java alternative), and I can't
connect S-C to my BroadVoice SIP account.

       I installed a fresh sip-communicator from the project's Debian
repository, then accepted its offer to upgrade to the latest, build
1260. I restarted the app. The "Sign In" protocols/accounts dialog at
startup let me enter my SIP username as <pstn-phone#>@sip.broadvoice.com
(with my actual pstn-phone#), and my password (known as "secret" in my
Asterisk SIP configuration). When I clicked that dialog's "Sign In"
button, after a few seconds, I got an "Error" dialog saying:

--------------------------------------------------------
Connection failed for the following account:
User name: <pstn-phone#>
Server name: sip.broadvoice.com.
Please check your network connection or contact your network
administrator for more information.
--------------------------------------------------------

I am running this workstation behind a few routers to the Internet, more
than one of which has a firewall and a NAT, so maybe the necessary
ports are closed. Is that the problem?

       I tried to enter my username as <pstn-phone#>@broadvoice.com (not
@sip.broadvoice.com), but that failed the same way. I tried the menu
"Tools" -> "Settings" for the "Configuration" dialog, the "Accounts"
tab, which showed my account (as <pstn-phone#>, without the @<server>);
I clicked the "Settings" button, for the "Account Registration Wizard"
dialog, which showed my full <pstn-phone#>@sip.broadvoice.com (or
<pstn-phone#>@broadvoice.com when I used that server name) and the
obscured password (and "remember password" checked). I clicked the
"Advanced" tab. I clicked "Override server default options", and changed
the "Proxy" field, because BroadVoice has several different proxy
servers at different IP#s, but all served in DNS round-robin as
sip.broadvoice.com . So I set the Proxy field to each of several
different proxy IP#s. It failed the same way as before, with the same
dialog. I tried to go to the main S-C window, its "Dial" tab, and dial a
phone#. It failed with "Could not access...".

       I don't see how to configure S-C to use my SIP account, and I don't see
how to get more diagnostic info. Please advise.
--

(C) Matthew Rubenstein

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#6

Since I am using an account that I have tested OK with my other SIP
client, it was possible that the test client's registration was still
intact, coming from a different IP# (and client signature). So I waited
a day for it to expire, ran the test again, and it failed again (same
failure in the UI). I tested today with S-C version
1.0-alpha3-nightly.build.1274 . The log records from the failed
transaction are attached to this message. Thanks for helping.

sip-communicator0.log.bv-fail-connect (15.9 KB)

···

On Tue, 2008-08-05 at 23:40 +0200, Emil Ivov wrote:

Hey Mathew,

It seems that you are getting a 409 error response from the server. This
is quite uncommon since 409 was defined in RFC 2543 and then deprecated
by 3261. Here's what 2543 says on the matter:

> The request could not be completed due to a conflict with the current
> state of the resource. This response is returned if the action
> parameter in a REGISTER request conflicts with existing
> registrations.

Could it be that you are having a second phone running with the same
credentials?

Emil

Matthew Rubenstein написа:
> Is anyone interested in helping me get past this bug?
>
>
> On Thu, 2008-07-31 at 14:08 -0400, Matthew Rubenstein wrote:
>> Attached, please find a segment of the sip-communicator.log that was
>> recorded during my failed startup attempt to login to my BroadVoice
>> account. I have anonymized the account username/phone# as PSTN_PHONEN ,
>> and my host's IP# has been changed.
>>
>> I'm setting up to run a wireshark dump of another rerun of failed
>> transaction. I will send it along when it's done, unless you let me know
>> you've figured it out without the wireshark dump.
>>
>> FWIW, I'm having some small GUI glitches during this process, but
>> they're workaroundable, and don't seem at all related to the SIP login
>> failing.
>>
>>
>> On Thu, 2008-07-31 at 18:56 +0200, Emil Ivov wrote:
>>> Hey Matthew,
>>>
>>> What first drew my attention was the fact that you are using
>>> java-6-openjdk. Personally, I've never tried SC with it and have only
>>> been using sun-java6-jdk. I know for a fact that we have problems with
>>> java-gcj so I thought that this may be the reason for your problems.
>>>
>>> As I read through your mail however the problem seems to be on a
>>> higher level. Would you mind sending a wireshark dump and a log
>>> excerpt from your session to this list? That should tell us more aa to
>>> what's happening.
>>>
>>> Cheers
>>> Emil
>>>
>>> On Tue, Jul 29, 2008 at 9:11 PM, Matthew Rubenstein <email@mattruby.com> wrote:
>>>> I have an account at Broadvoice that I have tested to work properly
>>>> with an Asterisk server that initiates calls to BroadVoice. But I tried
>>>> using S-C v1.0-alpha3-nightly.build.1260 (under an up-to-date Ubuntu
>>>> 8.04/Hardy with the java-6-openjdk Java alternative), and I can't
>>>> connect S-C to my BroadVoice SIP account.
>>>>
>>>> I installed a fresh sip-communicator from the project's Debian
>>>> repository, then accepted its offer to upgrade to the latest, build
>>>> 1260. I restarted the app. The "Sign In" protocols/accounts dialog at
>>>> startup let me enter my SIP username as <pstn-phone#>@sip.broadvoice.com
>>>> (with my actual pstn-phone#), and my password (known as "secret" in my
>>>> Asterisk SIP configuration). When I clicked that dialog's "Sign In"
>>>> button, after a few seconds, I got an "Error" dialog saying:
>>>>
>>>> --------------------------------------------------------
>>>> Connection failed for the following account:
>>>> User name: <pstn-phone#>
>>>> Server name: sip.broadvoice.com.
>>>> Please check your network connection or contact your network
>>>> administrator for more information.
>>>> --------------------------------------------------------
>>>>
>>>> I am running this workstation behind a few routers to the Internet, more
>>>> than one of which has a firewall and a NAT, so maybe the necessary
>>>> ports are closed. Is that the problem?
>>>>
>>>> I tried to enter my username as <pstn-phone#>@broadvoice.com (not
>>>> @sip.broadvoice.com), but that failed the same way. I tried the menu
>>>> "Tools" -> "Settings" for the "Configuration" dialog, the "Accounts"
>>>> tab, which showed my account (as <pstn-phone#>, without the @<server>);
>>>> I clicked the "Settings" button, for the "Account Registration Wizard"
>>>> dialog, which showed my full <pstn-phone#>@sip.broadvoice.com (or
>>>> <pstn-phone#>@broadvoice.com when I used that server name) and the
>>>> obscured password (and "remember password" checked). I clicked the
>>>> "Advanced" tab. I clicked "Override server default options", and changed
>>>> the "Proxy" field, because BroadVoice has several different proxy
>>>> servers at different IP#s, but all served in DNS round-robin as
>>>> sip.broadvoice.com . So I set the Proxy field to each of several
>>>> different proxy IP#s. It failed the same way as before, with the same
>>>> dialog. I tried to go to the main S-C window, its "Dial" tab, and dial a
>>>> phone#. It failed with "Could not access...".
>>>>
>>>> I don't see how to configure S-C to use my SIP account, and I don't see
>>>> how to get more diagnostic info. Please advise.
>>>> --
>>>>
>>>> (C) Matthew Rubenstein
>>>>
>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
>>>> For additional commands, e-mail: dev-help@sip-communicator.dev.java.net
>>>>
>>>>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

--

(C) Matthew Rubenstein


#7

Hey Matthew,

The situation seems to be the same. You keep getting the 409 Response.
I've just had a look at broadvoice with the intention to do some
testing and it appears that they only have paid subscritpions so
there's not much we can do.

If you already have an account then you might want to send the SIP
message exchange to their support team and ask them if there's any
reason why their servers would not accept our REGISTER requests.

Good luck
Emil

···

On Wed, Aug 6, 2008 at 7:56 PM, Matthew Rubenstein <email@mattruby.com> wrote:

       Since I am using an account that I have tested OK with my other SIP
client, it was possible that the test client's registration was still
intact, coming from a different IP# (and client signature). So I waited
a day for it to expire, ran the test again, and it failed again (same
failure in the UI). I tested today with S-C version
1.0-alpha3-nightly.build.1274 . The log records from the failed
transaction are attached to this message. Thanks for helping.

On Tue, 2008-08-05 at 23:40 +0200, Emil Ivov wrote:

Hey Mathew,

It seems that you are getting a 409 error response from the server. This
is quite uncommon since 409 was defined in RFC 2543 and then deprecated
by 3261. Here's what 2543 says on the matter:

> The request could not be completed due to a conflict with the current
> state of the resource. This response is returned if the action
> parameter in a REGISTER request conflicts with existing
> registrations.

Could it be that you are having a second phone running with the same
credentials?

Emil

Matthew Rubenstein написа:
> Is anyone interested in helping me get past this bug?
>
>
> On Thu, 2008-07-31 at 14:08 -0400, Matthew Rubenstein wrote:
>> Attached, please find a segment of the sip-communicator.log that was
>> recorded during my failed startup attempt to login to my BroadVoice
>> account. I have anonymized the account username/phone# as PSTN_PHONEN ,
>> and my host's IP# has been changed.
>>
>> I'm setting up to run a wireshark dump of another rerun of failed
>> transaction. I will send it along when it's done, unless you let me know
>> you've figured it out without the wireshark dump.
>>
>> FWIW, I'm having some small GUI glitches during this process, but
>> they're workaroundable, and don't seem at all related to the SIP login
>> failing.
>>
>>
>> On Thu, 2008-07-31 at 18:56 +0200, Emil Ivov wrote:
>>> Hey Matthew,
>>>
>>> What first drew my attention was the fact that you are using
>>> java-6-openjdk. Personally, I've never tried SC with it and have only
>>> been using sun-java6-jdk. I know for a fact that we have problems with
>>> java-gcj so I thought that this may be the reason for your problems.
>>>
>>> As I read through your mail however the problem seems to be on a
>>> higher level. Would you mind sending a wireshark dump and a log
>>> excerpt from your session to this list? That should tell us more aa to
>>> what's happening.
>>>
>>> Cheers
>>> Emil
>>>
>>> On Tue, Jul 29, 2008 at 9:11 PM, Matthew Rubenstein <email@mattruby.com> wrote:
>>>> I have an account at Broadvoice that I have tested to work properly
>>>> with an Asterisk server that initiates calls to BroadVoice. But I tried
>>>> using S-C v1.0-alpha3-nightly.build.1260 (under an up-to-date Ubuntu
>>>> 8.04/Hardy with the java-6-openjdk Java alternative), and I can't
>>>> connect S-C to my BroadVoice SIP account.
>>>>
>>>> I installed a fresh sip-communicator from the project's Debian
>>>> repository, then accepted its offer to upgrade to the latest, build
>>>> 1260. I restarted the app. The "Sign In" protocols/accounts dialog at
>>>> startup let me enter my SIP username as <pstn-phone#>@sip.broadvoice.com
>>>> (with my actual pstn-phone#), and my password (known as "secret" in my
>>>> Asterisk SIP configuration). When I clicked that dialog's "Sign In"
>>>> button, after a few seconds, I got an "Error" dialog saying:
>>>>
>>>> --------------------------------------------------------
>>>> Connection failed for the following account:
>>>> User name: <pstn-phone#>
>>>> Server name: sip.broadvoice.com.
>>>> Please check your network connection or contact your network
>>>> administrator for more information.
>>>> --------------------------------------------------------
>>>>
>>>> I am running this workstation behind a few routers to the Internet, more
>>>> than one of which has a firewall and a NAT, so maybe the necessary
>>>> ports are closed. Is that the problem?
>>>>
>>>> I tried to enter my username as <pstn-phone#>@broadvoice.com (not
>>>> @sip.broadvoice.com), but that failed the same way. I tried the menu
>>>> "Tools" -> "Settings" for the "Configuration" dialog, the "Accounts"
>>>> tab, which showed my account (as <pstn-phone#>, without the @<server>);
>>>> I clicked the "Settings" button, for the "Account Registration Wizard"
>>>> dialog, which showed my full <pstn-phone#>@sip.broadvoice.com (or
>>>> <pstn-phone#>@broadvoice.com when I used that server name) and the
>>>> obscured password (and "remember password" checked). I clicked the
>>>> "Advanced" tab. I clicked "Override server default options", and changed
>>>> the "Proxy" field, because BroadVoice has several different proxy
>>>> servers at different IP#s, but all served in DNS round-robin as
>>>> sip.broadvoice.com . So I set the Proxy field to each of several
>>>> different proxy IP#s. It failed the same way as before, with the same
>>>> dialog. I tried to go to the main S-C window, its "Dial" tab, and dial a
>>>> phone#. It failed with "Could not access...".
>>>>
>>>> I don't see how to configure S-C to use my SIP account, and I don't see
>>>> how to get more diagnostic info. Please advise.
>>>> --
>>>>
>>>> (C) Matthew Rubenstein
>>>>
>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
>>>> For additional commands, e-mail: dev-help@sip-communicator.dev.java.net
>>>>
>>>>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

--

(C) Matthew Rubenstein

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net