[sip-comm-dev] systray plug-in error


#1

The systray plug-in doesn't start on my AMD 64. Here is the error :
[java] java.lang.UnsatisfiedLinkError:
/home/nykos/workspace/sc-filetransfer/lib/native/linux/libtray.so:
Can't load IA 32-bit .so on a AMD 64-bit platform

I'm running sip-com on a Linux compiled in 64 bits.

···

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#2

Hi Nicolas,

Good catch!

I've searched the JDIC mailing list archive and I found this one:

https://jdic.dev.java.net/servlets/SearchList?list=jdic&searchText=64+bits&defaultField=subject&Search=Search

One of the guys suggests a solution of the problem, you could check if it works for you. Otherwise the best thing to do is to join the discussion on the JDIC mailing list.

Yana

Nicolas Riegel wrote:

···

The systray plug-in doesn't start on my AMD 64. Here is the error :
[java] java.lang.UnsatisfiedLinkError: /home/nykos/workspace/sc-filetransfer/lib/native/linux/libtray.so: Can't load IA 32-bit .so on a AMD 64-bit platform

I'm running sip-com on a Linux compiled in 64 bits.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net