[sip-comm-dev] Some problem when configure eclipse


#1

Hello all:

  There were two problems in my installation and configuration of eclipse:
    1) eclipse can not import org.jdesktop.jdic.misc.* (I think lib do not contain jdic-misc.jar); but, in the downloaded source, I didn’t find the jar.
    2) The language of the sip-communicator display incorrect. My OS is WINDOWS XP sp2 Simple Chinese. But the sip-communicator can not display Chinese in the GUI, only some codes look like "rectangles" in the GUI.

Best

Wishes
         
bright
brightchen7@gmail.com
2008-04-22


#2

Hi bright,

I'll answer your first question for now.

There is a problem with Eclipse updating the .classpath file (that we'll fix
later on) which makes that jdic-misc.jar is indicated as a missing library.
To solve this, right click *sip-communicator* project in Eclipse and go to
the project *Properties.* In the *Java Build Path* section select *Libraries
* tab, click *Add Jars* and browse for the jdic jar in *
sip-communicator/lib/installer-exclude/jdic_misc.jar*
That'll do it.

Cheers
Cristina

···

2008/4/22 bright <brightchen7@gmail.com>:

Hello all:

       There were two problems in my installation and configuration of
eclipse:
   1) eclipse can not import org.jdesktop.jdic.misc.* (I think lib do not
contain jdic-misc.jar); but, in the downloaded source, I didn't find the
jar.
   2) The language of the sip-communicator display incorrect. My OS is
WINDOWS XP sp2 Simple Chinese. But the sip-communicator can not display
Chinese in the GUI, only some codes look like "rectangles" in the GUI.

Best
Wishes

bright
brightchen7@gmail.com
2008-04-22