[sip-comm-dev] SIP - Different registrar than domain in username


#1

Hello

Is there any specific reason why SIP Communicator enforces the equality of the registrar and the domain-part of the username in SIP accounts (e.g. user@example.com and registrar sip.example.com is currently impossible)? The account properties and the code in general seem to me that it was once possible to differentiate.

I need this specific functionality for my setup and enabled it using the attached patch. Could someone look into that and apply it if the functionality was not intentionally disabled?

Regards,
Ingo

sip_allow_registrar_different_than_userid.patch (3.54 KB)


#2

Hi,

when you create a sip account and enter advance options you can fill
registrar and/or proxy. I'm not sure but isn't this what you are
looking for. Fill in as "SIP id" - user@example.com and fill in as
"Registrar" sip.example.com.

Regards
damencho

···

On Tue, Dec 14, 2010 at 9:21 PM, Bauersachs Ingo <ingo.bauersachs@fhnw.ch> wrote:

Hello

Is there any specific reason why SIP Communicator enforces the equality of the registrar and the domain-part of the username in SIP accounts (e.g. user@example.com and registrar sip.example.com is currently impossible)? The account properties and the code in general seem to me that it was once possible to differentiate.

I need this specific functionality for my setup and enabled it using the attached patch. Could someone look into that and apply it if the functionality was not intentionally disabled?

Regards,
Ingo

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#3

Good morning,

Yep, that's exactly what I tried. But if I save the account in this way, the user id becomes user@sip.example.com.

Regards,
Ingo

···

-----Original Message-----
From: Damian Minkov [mailto:damencho@sip-communicator.org]
Sent: Mittwoch, 15. Dezember 2010 09:49
To: dev@sip-communicator.dev.java.net
Subject: Re: [sip-comm-dev] SIP - Different registrar than domain in
username

Hi,

when you create a sip account and enter advance options you can fill
registrar and/or proxy. I'm not sure but isn't this what you are
looking for. Fill in as "SIP id" - user@example.com and fill in as
"Registrar" sip.example.com.

Regards
damencho

On Tue, Dec 14, 2010 at 9:21 PM, Bauersachs Ingo > <ingo.bauersachs@fhnw.ch> wrote:
> Hello
>
> Is there any specific reason why SIP Communicator enforces the equality
of the registrar and the domain-part of the username in SIP accounts (e.g.
user@example.com and registrar sip.example.com is currently impossible)?
The account properties and the code in general seem to me that it was once
possible to differentiate.
>
> I need this specific functionality for my setup and enabled it using the
attached patch. Could someone look into that and apply it if the
functionality was not intentionally disabled?
>
> Regards,
> Ingo
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
> For additional commands, e-mail: dev-help@sip-communicator.dev.java.net
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#4

Hi again,

I don't see any problem in the sip messages. And in the config file I
see the correct value under USER_ID for account properties, the only
problem I see is that when you go to edit the account you see the
wrong value as you describe in the field "SIP Id" which you cannot
edit. Is this what you mean?

Cheers
damencho

···

On Wed, Dec 15, 2010 at 11:21 AM, Bauersachs Ingo <ingo.bauersachs@fhnw.ch> wrote:

Good morning,

Yep, that's exactly what I tried. But if I save the account in this way, the user id becomes user@sip.example.com.

Regards,
Ingo

-----Original Message-----
From: Damian Minkov [mailto:damencho@sip-communicator.org]
Sent: Mittwoch, 15. Dezember 2010 09:49
To: dev@sip-communicator.dev.java.net
Subject: Re: [sip-comm-dev] SIP - Different registrar than domain in
username

Hi,

when you create a sip account and enter advance options you can fill
registrar and/or proxy. I'm not sure but isn't this what you are
looking for. Fill in as "SIP id" - user@example.com and fill in as
"Registrar" sip.example.com.

Regards
damencho

On Tue, Dec 14, 2010 at 9:21 PM, Bauersachs Ingo >> <ingo.bauersachs@fhnw.ch> wrote:
> Hello
>
> Is there any specific reason why SIP Communicator enforces the equality
of the registrar and the domain-part of the username in SIP accounts (e.g.
user@example.com and registrar sip.example.com is currently impossible)?
The account properties and the code in general seem to me that it was once
possible to differentiate.
>
> I need this specific functionality for my setup and enabled it using the
attached patch. Could someone look into that and apply it if the
functionality was not intentionally disabled?
>
> Regards,
> Ingo
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
> For additional commands, e-mail: dev-help@sip-communicator.dev.java.net
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#5

Hey,

You're right as far as the USER_ID property goes, this is written correct when the account is saved for the first time. If you edit the account (e.g. for changing the proxy) the wrong displayed value is saved, so USER_ID becomes user@sip.example.com. But even when the account is not edited the Request URI contains the domain of the User ID instead of the registrar.

The SIP Messages I see in Wireshark are as follows (I stripped irrelevant lines):
REGISTER sip:example.com SIP/2.0

From: "alice" <sip:alice@example.com>;tag=b03f6a4b

Contact: "alice" <sip:alice@10.212.136.129:5060;transport=udp;registering_acc=example_com>;expires=600
Via: SIP/2.0/UDP 10.212.136.129:5060;branch=z9hG4bK-383133-56da8f38350b85e73c563c4a80d8c02f
Content-Length: 0

I expected the request URI to be sip:sip.example.com instead of sip:example.com.

The account properties were as follows when this request was sent:
ACCOUNT_UID=SIP\:alice@sip.example.com
SERVER_ADDRESS=sip.example.com
SERVER_ADDRESS_VALIDATED=true
USER_ID=alice@example.com

Regards,
Ingo

···

To: "alice" <sip:alice@example.com>

-----Original Message-----
From: Damian Minkov [mailto:damencho@sip-communicator.org]
Sent: Mittwoch, 15. Dezember 2010 10:48
To: dev@sip-communicator.dev.java.net
Subject: Re: [sip-comm-dev] SIP - Different registrar than domain in
username

Hi again,

I don't see any problem in the sip messages. And in the config file I
see the correct value under USER_ID for account properties, the only
problem I see is that when you go to edit the account you see the
wrong value as you describe in the field "SIP Id" which you cannot
edit. Is this what you mean?

Cheers
damencho

On Wed, Dec 15, 2010 at 11:21 AM, Bauersachs Ingo > <ingo.bauersachs@fhnw.ch> wrote:
> Good morning,
>
> Yep, that's exactly what I tried. But if I save the account in this way,
the user id becomes user@sip.example.com.
>
> Regards,
> Ingo
>
>> -----Original Message-----
>> From: Damian Minkov [mailto:damencho@sip-communicator.org]
>> Sent: Mittwoch, 15. Dezember 2010 09:49
>> To: dev@sip-communicator.dev.java.net
>> Subject: Re: [sip-comm-dev] SIP - Different registrar than domain in
>> username
>>
>> Hi,
>>
>> when you create a sip account and enter advance options you can fill
>> registrar and/or proxy. I'm not sure but isn't this what you are
>> looking for. Fill in as "SIP id" - user@example.com and fill in as
>> "Registrar" sip.example.com.
>>
>> Regards
>> damencho
>>
>> On Tue, Dec 14, 2010 at 9:21 PM, Bauersachs Ingo > >> <ingo.bauersachs@fhnw.ch> wrote:
>> > Hello
>> >
>> > Is there any specific reason why SIP Communicator enforces the
equality
>> of the registrar and the domain-part of the username in SIP accounts
(e.g.
>> user@example.com and registrar sip.example.com is currently
impossible)?
>> The account properties and the code in general seem to me that it was
once
>> possible to differentiate.
>> >
>> > I need this specific functionality for my setup and enabled it using
the
>> attached patch. Could someone look into that and apply it if the
>> functionality was not intentionally disabled?
>> >
>> > Regards,
>> > Ingo
>> >
>> > ---------------------------------------------------------------------
>> > To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
>> > For additional commands, e-mail: dev-help@sip-
communicator.dev.java.net
>> >
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
>> For additional commands, e-mail: dev-help@sip-communicator.dev.java.net
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
> For additional commands, e-mail: dev-help@sip-communicator.dev.java.net
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#6

Hey Ingo,

OK got it. We'll take a look during the following days and will keep you
posted. Thanks for the reports!

Emil

На 15.12.10 15:57, Bauersachs Ingo написа:

···

Hey,

You're right as far as the USER_ID property goes, this is written correct when the account is saved for the first time. If you edit the account (e.g. for changing the proxy) the wrong displayed value is saved, so USER_ID becomes user@sip.example.com. But even when the account is not edited the Request URI contains the domain of the User ID instead of the registrar.

The SIP Messages I see in Wireshark are as follows (I stripped irrelevant lines):
REGISTER sip:example.com SIP/2.0
From: "alice" <sip:alice@example.com>;tag=b03f6a4b
To: "alice" <sip:alice@example.com>
Contact: "alice" <sip:alice@10.212.136.129:5060;transport=udp;registering_acc=example_com>;expires=600
Via: SIP/2.0/UDP 10.212.136.129:5060;branch=z9hG4bK-383133-56da8f38350b85e73c563c4a80d8c02f
Content-Length: 0

I expected the request URI to be sip:sip.example.com instead of sip:example.com.

The account properties were as follows when this request was sent:
ACCOUNT_UID=SIP\:alice@sip.example.com
SERVER_ADDRESS=sip.example.com
SERVER_ADDRESS_VALIDATED=true
USER_ID=alice@example.com

Regards,
Ingo

-----Original Message-----
From: Damian Minkov [mailto:damencho@sip-communicator.org]
Sent: Mittwoch, 15. Dezember 2010 10:48
To: dev@sip-communicator.dev.java.net
Subject: Re: [sip-comm-dev] SIP - Different registrar than domain in
username

Hi again,

I don't see any problem in the sip messages. And in the config file I
see the correct value under USER_ID for account properties, the only
problem I see is that when you go to edit the account you see the
wrong value as you describe in the field "SIP Id" which you cannot
edit. Is this what you mean?

Cheers
damencho

On Wed, Dec 15, 2010 at 11:21 AM, Bauersachs Ingo >> <ingo.bauersachs@fhnw.ch> wrote:

Good morning,

Yep, that's exactly what I tried. But if I save the account in this way,

the user id becomes user@sip.example.com.

Regards,
Ingo

-----Original Message-----
From: Damian Minkov [mailto:damencho@sip-communicator.org]
Sent: Mittwoch, 15. Dezember 2010 09:49
To: dev@sip-communicator.dev.java.net
Subject: Re: [sip-comm-dev] SIP - Different registrar than domain in
username

Hi,

when you create a sip account and enter advance options you can fill
registrar and/or proxy. I'm not sure but isn't this what you are
looking for. Fill in as "SIP id" - user@example.com and fill in as
"Registrar" sip.example.com.

Regards
damencho

On Tue, Dec 14, 2010 at 9:21 PM, Bauersachs Ingo >>>> <ingo.bauersachs@fhnw.ch> wrote:

Hello

Is there any specific reason why SIP Communicator enforces the

equality

of the registrar and the domain-part of the username in SIP accounts

(e.g.

user@example.com and registrar sip.example.com is currently

impossible)?

The account properties and the code in general seem to me that it was

once

possible to differentiate.

I need this specific functionality for my setup and enabled it using

the

attached patch. Could someone look into that and apply it if the
functionality was not intentionally disabled?

Regards,
Ingo

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-

communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
SIP Communicator
emcho@sip-communicator.org PHONE: +33.1.77.62.43.30
http://sip-communicator.org FAX: +33.1.77.62.47.31

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#7

Hey Ingo,

Could you please give it a try now?

Emil

На 15.12.10 19:11, Emil Ivov написа:

···

Hey Ingo,

OK got it. We'll take a look during the following days and will keep you
posted. Thanks for the reports!

Emil

На 15.12.10 15:57, Bauersachs Ingo написа:

Hey,

You're right as far as the USER_ID property goes, this is written correct when the account is saved for the first time. If you edit the account (e.g. for changing the proxy) the wrong displayed value is saved, so USER_ID becomes user@sip.example.com. But even when the account is not edited the Request URI contains the domain of the User ID instead of the registrar.

The SIP Messages I see in Wireshark are as follows (I stripped irrelevant lines):
REGISTER sip:example.com SIP/2.0
From: "alice" <sip:alice@example.com>;tag=b03f6a4b
To: "alice" <sip:alice@example.com>
Contact: "alice" <sip:alice@10.212.136.129:5060;transport=udp;registering_acc=example_com>;expires=600
Via: SIP/2.0/UDP 10.212.136.129:5060;branch=z9hG4bK-383133-56da8f38350b85e73c563c4a80d8c02f
Content-Length: 0

I expected the request URI to be sip:sip.example.com instead of sip:example.com.

The account properties were as follows when this request was sent:
ACCOUNT_UID=SIP\:alice@sip.example.com
SERVER_ADDRESS=sip.example.com
SERVER_ADDRESS_VALIDATED=true
USER_ID=alice@example.com

Regards,
Ingo

-----Original Message-----
From: Damian Minkov [mailto:damencho@sip-communicator.org]
Sent: Mittwoch, 15. Dezember 2010 10:48
To: dev@sip-communicator.dev.java.net
Subject: Re: [sip-comm-dev] SIP - Different registrar than domain in
username

Hi again,

I don't see any problem in the sip messages. And in the config file I
see the correct value under USER_ID for account properties, the only
problem I see is that when you go to edit the account you see the
wrong value as you describe in the field "SIP Id" which you cannot
edit. Is this what you mean?

Cheers
damencho

On Wed, Dec 15, 2010 at 11:21 AM, Bauersachs Ingo >>> <ingo.bauersachs@fhnw.ch> wrote:

Good morning,

Yep, that's exactly what I tried. But if I save the account in this way,

the user id becomes user@sip.example.com.

Regards,
Ingo

-----Original Message-----
From: Damian Minkov [mailto:damencho@sip-communicator.org]
Sent: Mittwoch, 15. Dezember 2010 09:49
To: dev@sip-communicator.dev.java.net
Subject: Re: [sip-comm-dev] SIP - Different registrar than domain in
username

Hi,

when you create a sip account and enter advance options you can fill
registrar and/or proxy. I'm not sure but isn't this what you are
looking for. Fill in as "SIP id" - user@example.com and fill in as
"Registrar" sip.example.com.

Regards
damencho

On Tue, Dec 14, 2010 at 9:21 PM, Bauersachs Ingo >>>>> <ingo.bauersachs@fhnw.ch> wrote:

Hello

Is there any specific reason why SIP Communicator enforces the

equality

of the registrar and the domain-part of the username in SIP accounts

(e.g.

user@example.com and registrar sip.example.com is currently

impossible)?

The account properties and the code in general seem to me that it was

once

possible to differentiate.

I need this specific functionality for my setup and enabled it using

the

attached patch. Could someone look into that and apply it if the
functionality was not intentionally disabled?

Regards,
Ingo

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-

communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
SIP Communicator
emcho@sip-communicator.org PHONE: +33.1.77.62.43.30
http://sip-communicator.org FAX: +33.1.77.62.47.31

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#8

Hey

Could you please give it a try now?

It works now, thanks! :slight_smile: I was reluctant to modify the AccountID class and therefore patched around in the SIP protocol...

But during this short test I found another bug/strange behavior when creating or editing a SIP account:
- Entering an invalid registrar domain (e.g. abc.example.com - simply unresolvable by DNS) and trying to save the account results in an exception. The Accound-Wizard simply closes and the account is gone.
- Editing an existing account and entering an invalid domain shows the error dialog with the exception as when it’s a new one and the dialog stays open so I could go back and edit again (ok so far). Clicking cancel now leaves the account saved with the invalid entry, causing it to disappear in the account list. After a restart it reappears.

Regards,
Ingo

new-account.log (16 KB)

editing-account.log (20.4 KB)

editing-account-afterrestart.log (13.9 KB)