[sip-comm-dev] sip-communicator.xml not correctly saved


#1

Hi devs,

It's been some times that I've noticed a problem when the sip-communicator.xml file is written at exit. Sometimes a big part of the file is missing, thus at next startup, sip-communicator fails to read it and ask again for account registration.

I experienced the problem again today on both MacOSX and Debian. Is this a known problem here? I could not see any issues in the tracker, I may have missed it. I can report one if needed.

Regards,

···

--
Romain KUNTZ
kuntz@sfc.wide.ad.jp

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#2

Hi Romain, hi devs,

I do not know if there is an issue in the tracker, but I have experimented the same problem since a few weeks on Debian (i.e. the sip-communicator.xml has no more </sip-communicator> end tag).
I do not have the time yet for searching and reporting the Exception, maybe in 1 or 2 weeks if this issue is not yet resolved (I know the sip-comunicator devs are very reactive to this kind of issue).
BTW, let me ask a question : Is it time to add a "dtd" for sip-communicator "xml" files for avoiding this kind of problem ?

Vincent

Romain KUNTZ wrote:

···

Hi devs,

It's been some times that I've noticed a problem when the sip-communicator.xml file is written at exit. Sometimes a big part of the file is missing, thus at next startup, sip-communicator fails to read it and ask again for account registration.

I experienced the problem again today on both MacOSX and Debian. Is this a known problem here? I could not see any issues in the tracker, I may have missed it. I can report one if needed.

Regards,