[sip-comm-dev] Setting up SIP Communicator for test calls?


#1

Thanks Emil. The asterisk box works like a charm.

···

--
My life has no purpose...my life has no direction...no aim...no meaning...
and yet I'm happy... I can't figure it out... What am I doing right?

Charles Schultz


#2

Hi Emil,

can you please tell me wich version of asterisk are you using? I'm wondering
if you made some special configuration to make it work perfectly with
sip-communicator? If yes please tell me what should I do..

Thanks a lot.


#3

asterisk is 1.2.1X. No special configuration I think. Your problem is with missing headers as I see in your mails in the list ?
Check your config - sip.conf . What is the settings for :
pedantic / must be no I think . the default is no
compactheaders / must be no also.

Only this two I can find related to the sip headers.

damencho

asmouta wrote:

···

Hi Emil,

can you please tell me wich version of asterisk are you using? I'm wondering if you made some special configuration to make it work perfectly with sip-communicator? If yes please tell me what should I do..

Thanks a lot.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#4

:frowning: these two parameters were commented so I uncomment them and do as you ask
me to but not success... I'm always having the same problem...

···

On 5/15/07, Damian Minkov <damencho@damencho.com> wrote:

asterisk is 1.2.1X. No special configuration I think. Your problem is
with missing headers as I see in your mails in the list ?
Check your config - sip.conf . What is the settings for :
pedantic / must be no I think . the default is no
compactheaders / must be no also.

Only this two I can find related to the sip headers.

damencho

asmouta wrote:
> Hi Emil,
>
> can you please tell me wich version of asterisk are you using? I'm
> wondering if you made some special configuration to make it work
> perfectly with sip-communicator? If yes please tell me what should I
do..
>
> Thanks a lot.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#5

hi,

what is your version of asterisk ? and try calls with
canreinvite=no
and
canreinvite=yes

is there any difference?

damencho

asmouta wrote:

···

:frowning: these two parameters were commented so I uncomment them and do as you ask me to but not success... I'm always having the same problem...

On 5/15/07, *Damian Minkov* <damencho@damencho.com > <mailto:damencho@damencho.com>> wrote:

    asterisk is 1.2.1X. No special configuration I think. Your problem is
    with missing headers as I see in your mails in the list ?
    Check your config - sip.conf . What is the settings for :
    pedantic / must be no I think . the default is no
    compactheaders / must be no also.

    Only this two I can find related to the sip headers.

    damencho

    asmouta wrote:
    > Hi Emil,
    >
    > can you please tell me wich version of asterisk are you using? I'm
    > wondering if you made some special configuration to make it work
    > perfectly with sip-communicator? If yes please tell me what
    should I do..
    >
    > Thanks a lot.

    ---------------------------------------------------------------------
    To unsubscribe, e-mail:
    dev-unsubscribe@sip-communicator.dev.java.net
    <mailto:dev-unsubscribe@sip-communicator.dev.java.net>
    For additional commands, e-mail:
    dev-help@sip-communicator.dev.java.net
    <mailto:dev-help@sip-communicator.dev.java.net>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#6

Hi Damian,

My version is an old one (I thought) asterisk-1.0.RC1, I'm trying to
download the latest one to see if it makes difference. I've tried with the
canreinvite parameter but it does change nothing.. Maybe something is wrong
with my sip.conf, can you please have a look at it?

[general]
port = 5060 ; Port to bind to
bindaddr = 0.0.0.0 ; Address to bind SIP channel to
;context = default
context = Fast ; Default context for incoming calls
;srvlookup = yes ; Enable DNS SRV lookups on outbound calls

pedantic = no ; Enable slow, pedantic checking for Pingtel
compactheaders = no
;tos=lowdelay

;maxexpirey=3600 ; Max length of incoming registration we
allow
;defaultexpirey=120 ; Default length of incoming/outoing
registration
;notifymimetype=text/plain ; Allow overriding of mime type in NOTIFY
;videosupport=yes ; Turn on support for SIP video

disallow=all ; Disallow all codecs
;allow=ulaw ; Allow codecs in order of preference
allow=alaw
;allow=G723
;allow=G729A
;allow=ilbc

[1560]
type=friend
secret=test1
host=dynamic
dtmfmode=inband ; Choices are inband, rfc2833, or info
nat = yes
;defaultip=192.168.0.59
;mailbox=1234,2345 ; Mailbox for message waiting indicator
restrictcid=yes
canreinvite=yes

[1561]
type=friend
secret=test
host=dynamic
nat = yes
dtmfmode=inband ; Choices are inband, rfc2833, or info
;defaultip=192.168.0.59
;mailbox=1234,2345 ; Mailbox for message waiting indicator
restrictcid=yes
canreinvite=yes
;callerID=1561

Thanks a lot for your help.


#7

hi,
nothing suspicious but your asterisk is really old. upgrade it and try it and of course report it here :slight_smile:
I saw in some posts that there are some sip implementations that don't send this max-forwards header maybe this was an issue in that release in asterisk.

damencho

asmouta wrote:

···

Hi Damian,

My version is an old one (I thought) asterisk-1.0.RC1, I'm trying to download the latest one to see if it makes difference. I've tried with the canreinvite parameter but it does change nothing.. Maybe something is wrong with my sip.conf, can you please have a look at it?

[general]
port = 5060 ; Port to bind to
bindaddr = 0.0.0.0 <http://0.0.0.0> ; Address to bind SIP channel to
;context = default
context = Fast ; Default context for incoming calls
;srvlookup = yes ; Enable DNS SRV lookups on outbound calls

pedantic = no ; Enable slow, pedantic checking for Pingtel
compactheaders = no
;tos=lowdelay

;maxexpirey=3600 ; Max length of incoming registration we allow
;defaultexpirey=120 ; Default length of incoming/outoing registration
;notifymimetype=text/plain ; Allow overriding of mime type in NOTIFY
;videosupport=yes ; Turn on support for SIP video

disallow=all ; Disallow all codecs
;allow=ulaw ; Allow codecs in order of preference
allow=alaw
;allow=G723
;allow=G729A
;allow=ilbc

[1560]
type=friend
secret=test1
host=dynamic
dtmfmode=inband ; Choices are inband, rfc2833, or info
nat = yes
;defaultip=192.168.0.59 <http://192.168.0.59>
;mailbox=1234,2345 ; Mailbox for message waiting indicator
restrictcid=yes
canreinvite=yes

[1561]
type=friend
secret=test
host=dynamic
nat = yes
dtmfmode=inband ; Choices are inband, rfc2833, or info
;defaultip=192.168.0.59 <http://192.168.0.59>
;mailbox=1234,2345 ; Mailbox for message waiting indicator
restrictcid=yes
canreinvite=yes
;callerID=1561

Thanks a lot for your help.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#8

Ok thanks a lot Damian, I'm still waiting for the asterisk download (low
speed here) then I'll give feedback.

Thanks a lot.

···

On 5/15/07, Damian Minkov <damencho@damencho.com> wrote:

hi,
nothing suspicious but your asterisk is really old. upgrade it and try
it and of course report it here :slight_smile:
I saw in some posts that there are some sip implementations that don't
send this max-forwards header maybe this was an issue in that release in
asterisk.

damencho

asmouta wrote:
> Hi Damian,
>
> My version is an old one (I thought) asterisk-1.0.RC1, I'm trying to
> download the latest one to see if it makes difference. I've tried with
> the canreinvite parameter but it does change nothing.. Maybe something
> is wrong with my sip.conf, can you please have a look at it?
>
> [general]
> port = 5060 ; Port to bind to
> bindaddr = 0.0.0.0 <http://0.0.0.0> ; Address to bind SIP
> channel to
> ;context = default
> context = Fast ; Default context for incoming calls
> ;srvlookup = yes ; Enable DNS SRV lookups on outbound
calls
>
> pedantic = no ; Enable slow, pedantic checking for Pingtel
> compactheaders = no
> ;tos=lowdelay
>
> ;maxexpirey=3600 ; Max length of incoming registration
> we allow
> ;defaultexpirey=120 ; Default length of incoming/outoing
> registration
> ;notifymimetype=text/plain ; Allow overriding of mime type in
NOTIFY
> ;videosupport=yes ; Turn on support for SIP video
>
> disallow=all ; Disallow all codecs
> ;allow=ulaw ; Allow codecs in order of preference
> allow=alaw
> ;allow=G723
> ;allow=G729A
> ;allow=ilbc
>
> [1560]
> type=friend
> secret=test1
> host=dynamic
> dtmfmode=inband ; Choices are inband, rfc2833, or info
> nat = yes
> ;defaultip=192.168.0.59 <http://192.168.0.59>
> ;mailbox=1234,2345 ; Mailbox for message waiting indicator
> restrictcid=yes
> canreinvite=yes
>
> [1561]
> type=friend
> secret=test
> host=dynamic
> nat = yes
> dtmfmode=inband ; Choices are inband, rfc2833, or info
> ;defaultip=192.168.0.59 <http://192.168.0.59>
> ;mailbox=1234,2345 ; Mailbox for message waiting indicator
> restrictcid=yes
> canreinvite=yes
> ;callerID=1561
>
> Thanks a lot for your help.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#9

Youuupiiiiiiiiiiiiii :slight_smile: it does work !!! It was all because of asterisk !!
Version 1.0.RC1 !!! Hope that will help someone else... I spent two weeks
debugging the sip-communicator and all the problem was because of asterisk.

Anyways, that's fine now when it does work :slight_smile: Just a little question which
codec will best work with the sip-communicator?

Thanks to all.

PS : I've installed the asterisk-1.2.18 version.

···

On 5/15/07, asmouta <asmouta@gmail.com> wrote:

Ok thanks a lot Damian, I'm still waiting for the asterisk download (low
speed here) then I'll give feedback.

Thanks a lot.

On 5/15/07, Damian Minkov <damencho@damencho.com> wrote:
>
> hi,
> nothing suspicious but your asterisk is really old. upgrade it and try
> it and of course report it here :slight_smile:
> I saw in some posts that there are some sip implementations that don't
> send this max-forwards header maybe this was an issue in that release in
>
> asterisk.
>
> damencho
>
> asmouta wrote:
> > Hi Damian,
> >
> > My version is an old one (I thought) asterisk-1.0.RC1, I'm trying to
> > download the latest one to see if it makes difference. I've tried with
>
> > the canreinvite parameter but it does change nothing.. Maybe something
> > is wrong with my sip.conf, can you please have a look at it?
> >
> > [general]
> > port = 5060 ; Port to bind to
> > bindaddr = 0.0.0.0 <http://0.0.0.0> ; Address to bind SIP
> > channel to
> > ;context = default
> > context = Fast ; Default context for incoming calls
> > ;srvlookup = yes ; Enable DNS SRV lookups on outbound
> calls
> >
> > pedantic = no ; Enable slow, pedantic checking for Pingtel
> > compactheaders = no
> > ;tos=lowdelay
> >
> > ;maxexpirey=3600 ; Max length of incoming registration
> > we allow
> > ;defaultexpirey=120 ; Default length of incoming/outoing
> > registration
> > ;notifymimetype=text/plain ; Allow overriding of mime type in
> NOTIFY
> > ;videosupport=yes ; Turn on support for SIP video
> >
> > disallow=all ; Disallow all codecs
> > ;allow=ulaw ; Allow codecs in order of preference
> > allow=alaw
> > ;allow=G723
> > ;allow=G729A
> > ;allow=ilbc
> >
> > [1560]
> > type=friend
> > secret=test1
> > host=dynamic
> > dtmfmode=inband ; Choices are inband, rfc2833, or info
> > nat = yes
> > ;defaultip=192.168.0.59 <http://192.168.0.59>
> > ;mailbox=1234,2345 ; Mailbox for message waiting
> indicator
> > restrictcid=yes
> > canreinvite=yes
> >
> > [1561]
> > type=friend
> > secret=test
> > host=dynamic
> > nat = yes
> > dtmfmode=inband ; Choices are inband, rfc2833, or info
> > ;defaultip=192.168.0.59 <http://192.168.0.59>
> > ;mailbox=1234,2345 ; Mailbox for message waiting
> indicator
> > restrictcid=yes
> > canreinvite=yes
> > ;callerID=1561
> >
> > Thanks a lot for your help.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
> For additional commands, e-mail: dev-help@sip-communicator.dev.java.net
>