[sip-comm-dev] Run si-communicator on windows 64bit and Java 64bit


#1

Hi all

I have such problem: I have Win7 64bit newly installed on my PC and I have
Java 64bit on it installed too (version 1.6.0_21, both JDK and JRE).
But I could not run sip-communicator on this configuration. I only obtain
message "JRE not found" (or simillar) and question if I vould like to
download java (I do not wont install any other java).
Is tehere any way how to tell SIP-communicator. This has happend even if I
have installed 64bit installation of SIP-communicator.

Note that other JAVA programs (Eclipse - in 64bit version, my company
software, tomcat, jetty, e-bank, ... ) run without problem on this
configuration.

Thanks.


#2

Hi Radek,

I will test again on my configuration but I remember the x64 installer works fine without any JDK/JRE error. Maybe it is because I have setup the JAVA_HOME environment.

Are your JDK are installed in the standard location (i.e. c:\Program Files\Java\...) ?

Just for a test, try setting the JAVA_HOME (pointing on your JDK or JRE) environment variable and launch again SIP Communicator.

Regards,

···

--
Seb

Le 09/09/2010 10:39, Radek Terber a �crit :

Hi all

I have such problem: I have Win7 64bit newly installed on my PC and I have Java 64bit on it installed too (version 1.6.0_21, both JDK and JRE).
But I could not run sip-communicator on this configuration. I only obtain message "JRE not found" (or simillar) and question if I vould like to download java (I do not wont install any other java).
Is tehere any way how to tell SIP-communicator. This has happend even if I have installed 64bit installation of SIP-communicator.

Note that other JAVA programs (Eclipse - in 64bit version, my company software, tomcat, jetty, e-bank, ... ) run without problem on this configuration.

Thanks.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#3

Hi Sebastien

thank you for response, java is installed instandard location, C:\Program
Files\java\jre6". When I set JAVA_HOME to this location, communicator starts
fine. But I thing it is still a bug, because "normal user" may not know how
set JAVA_HOME variable.

Have a nice day.

Radek.

···

2010/9/9 Sebastien Vincent <seb@sip-communicator.org>

Hi Radek,

I will test again on my configuration but I remember the x64 installer
works fine without any JDK/JRE error. Maybe it is because I have setup the
JAVA_HOME environment.

Are your JDK are installed in the standard location (i.e. c:\Program
Files\Java\...) ?

Just for a test, try setting the JAVA_HOME (pointing on your JDK or JRE)
environment variable and launch again SIP Communicator.

Regards,
--
Seb

Le 09/09/2010 10:39, Radek Terber a écrit :

Hi all

I have such problem: I have Win7 64bit newly installed on my PC and I have
Java 64bit on it installed too (version 1.6.0_21, both JDK and JRE).
But I could not run sip-communicator on this configuration. I only obtain
message "JRE not found" (or simillar) and question if I vould like to
download java (I do not wont install any other java).
Is tehere any way how to tell SIP-communicator. This has happend even if I
have installed 64bit installation of SIP-communicator.

Note that other JAVA programs (Eclipse - in 64bit version, my company
software, tomcat, jetty, e-bank, ... ) run without problem on this
configuration.

Thanks.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#4

Hi Radek,

OK now we know exactly the cause, we will take care of this problem.

Thanks,

···

--
Seb

Le 10/09/2010 11:05, Radek Terber a �crit :

Hi Sebastien

thank you for response, java is installed instandard location, C:\Program Files\java\jre6". When I set JAVA_HOME to this location, communicator starts fine. But I thing it is still a bug, because "normal user" may not know how set JAVA_HOME variable.

Have a nice day.

Radek.

2010/9/9 Sebastien Vincent <seb@sip-communicator.org <mailto:seb@sip-communicator.org>>

    Hi Radek,

    I will test again on my configuration but I remember the x64
    installer works fine without any JDK/JRE error. Maybe it is
    because I have setup the JAVA_HOME environment.

    Are your JDK are installed in the standard location (i.e.
    c:\Program Files\Java\...) ?

    Just for a test, try setting the JAVA_HOME (pointing on your JDK
    or JRE) environment variable and launch again SIP Communicator.

    Regards,
    --
    Seb

    Le 09/09/2010 10:39, Radek Terber a �crit :

        Hi all

        I have such problem: I have Win7 64bit newly installed on my
        PC and I have Java 64bit on it installed too (version
        1.6.0_21, both JDK and JRE).
        But I could not run sip-communicator on this configuration. I
        only obtain message "JRE not found" (or simillar) and question
        if I vould like to download java (I do not wont install any
        other java).
        Is tehere any way how to tell SIP-communicator. This has
        happend even if I have installed 64bit installation of
        SIP-communicator.

        Note that other JAVA programs (Eclipse - in 64bit version, my
        company software, tomcat, jetty, e-bank, ... ) run without
        problem on this configuration.

        Thanks.

    ---------------------------------------------------------------------
    To unsubscribe, e-mail:
    dev-unsubscribe@sip-communicator.dev.java.net
    <mailto:dev-unsubscribe@sip-communicator.dev.java.net>
    For additional commands, e-mail:
    dev-help@sip-communicator.dev.java.net
    <mailto:dev-help@sip-communicator.dev.java.net>


#5

Hi Radek,

I have made a change yesterday so now normally setting JAVA_HOME is not necessary anymore to launch SIP Communicator on Windows 64-bit. Can you try again with our latest installer and tell me if it works for you. Thanks.

Regards,

···

--
Seb

Le 10/09/2010 11:05, Radek Terber a �crit :

Hi Sebastien

thank you for response, java is installed instandard location, C:\Program Files\java\jre6". When I set JAVA_HOME to this location, communicator starts fine. But I thing it is still a bug, because "normal user" may not know how set JAVA_HOME variable.

Have a nice day.

Radek.

2010/9/9 Sebastien Vincent <seb@sip-communicator.org <mailto:seb@sip-communicator.org>>

    Hi Radek,

    I will test again on my configuration but I remember the x64
    installer works fine without any JDK/JRE error. Maybe it is
    because I have setup the JAVA_HOME environment.

    Are your JDK are installed in the standard location (i.e.
    c:\Program Files\Java\...) ?

    Just for a test, try setting the JAVA_HOME (pointing on your JDK
    or JRE) environment variable and launch again SIP Communicator.

    Regards,
    --
    Seb

    Le 09/09/2010 10:39, Radek Terber a �crit :

        Hi all

        I have such problem: I have Win7 64bit newly installed on my
        PC and I have Java 64bit on it installed too (version
        1.6.0_21, both JDK and JRE).
        But I could not run sip-communicator on this configuration. I
        only obtain message "JRE not found" (or simillar) and question
        if I vould like to download java (I do not wont install any
        other java).
        Is tehere any way how to tell SIP-communicator. This has
        happend even if I have installed 64bit installation of
        SIP-communicator.

        Note that other JAVA programs (Eclipse - in 64bit version, my
        company software, tomcat, jetty, e-bank, ... ) run without
        problem on this configuration.

        Thanks.

    ---------------------------------------------------------------------
    To unsubscribe, e-mail:
    dev-unsubscribe@sip-communicator.dev.java.net
    <mailto:dev-unsubscribe@sip-communicator.dev.java.net>
    For additional commands, e-mail:
    dev-help@sip-communicator.dev.java.net
    <mailto:dev-help@sip-communicator.dev.java.net>


#6

Hi Sebastien,

installation with latest installer looks fine - program started sucesfully
without JAVA_HOME set.

Regards

···

2010/9/14 Sebastien Vincent <seb@sip-communicator.org>

Hi Radek,

I have made a change yesterday so now normally setting JAVA_HOME is not
necessary anymore to launch SIP Communicator on Windows 64-bit. Can you try
again with our latest installer and tell me if it works for you. Thanks.

Regards,
--
Seb

Le 10/09/2010 11:05, Radek Terber a écrit :

Hi Sebastien

thank you for response, java is installed instandard location, C:\Program
Files\java\jre6". When I set JAVA_HOME to this location, communicator starts
fine. But I thing it is still a bug, because "normal user" may not know how
set JAVA_HOME variable.

Have a nice day.

Radek.

2010/9/9 Sebastien Vincent <seb@sip-communicator.org>

Hi Radek,

I will test again on my configuration but I remember the x64 installer
works fine without any JDK/JRE error. Maybe it is because I have setup the
JAVA_HOME environment.

Are your JDK are installed in the standard location (i.e. c:\Program
Files\Java\...) ?

Just for a test, try setting the JAVA_HOME (pointing on your JDK or JRE)
environment variable and launch again SIP Communicator.

Regards,
--
Seb

Le 09/09/2010 10:39, Radek Terber a écrit :

Hi all

I have such problem: I have Win7 64bit newly installed on my PC and I
have Java 64bit on it installed too (version 1.6.0_21, both JDK and JRE).
But I could not run sip-communicator on this configuration. I only obtain
message "JRE not found" (or simillar) and question if I vould like to
download java (I do not wont install any other java).
Is tehere any way how to tell SIP-communicator. This has happend even if
I have installed 64bit installation of SIP-communicator.

Note that other JAVA programs (Eclipse - in 64bit version, my company
software, tomcat, jetty, e-bank, ... ) run without problem on this
configuration.

Thanks.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net