[sip-comm-dev] Reply for ACK


#1

Hi!

I'm using SIP-Communicator with openser. When I make a call from A to B, and
B accept the call, openser failed with:

WARNING:sl:sl_send_reply: I won't send a reply for ACK!!

In consequence, B stays connecting and waiting the OK to start the call.

It only happen with openser and sip-communicator. In SER (Sip Express
Router) it works fine, and with other sip phones (like x-lite) it also works
fine.

I don't know what fail.

Thanks. Pablo.de


#2

Hello again Pablo,

I remember we were having the same issue with OpenSER and that it didn't appear with SER. There must be a problem with our messages (or the way open ser is treating them) but at the time we didn't have much time to track it down so it is still unresolved. In case you find it, we'd be very interested to know the reason!

Cheers
Emil

Pablo wrote:

···

Hi!

I�m using SIP-Communicator with openser. When I make a call from A to B, and B accept the call, openser failed with:

WARNING:sl:sl_send_reply: I won't send a reply for ACK!!

In consequence, B stays connecting and waiting the OK to start the call.

It only happen with openser and sip-communicator. In SER (Sip Express Router) it works fine, and with other sip phones (like x-lite) it also works fine.

I don�t know what fail.

Thanks. Pablo.de

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#3

Can you look at what tags are being used and also what transport is being used for the OK. It should be using TLS transport to send the OK. From and to tags should match. The contact specified in the OK should be a sips url. Also you may want to capture and post the OK from xlite and sip-comm here. I will eyeball the two and see if I notice a discrepancy. Do you?

Regards,

Ranga

Emil Ivov wrote:

···

Hello again Pablo,

I remember we were having the same issue with OpenSER and that it didn't appear with SER. There must be a problem with our messages (or the way open ser is treating them) but at the time we didn't have much time to track it down so it is still unresolved. In case you find it, we'd be very interested to know the reason!

Cheers
Emil

Pablo wrote:

Hi!

I�m using SIP-Communicator with openser. When I make a call from A to B, and B accept the call, openser failed with:

WARNING:sl:sl_send_reply: I won't send a reply for ACK!!

In consequence, B stays connecting and waiting the OK to start the call.

It only happen with openser and sip-communicator. In SER (Sip Express Router) it works fine, and with other sip phones (like x-lite) it also works fine.

I don�t know what fail.

Thanks. Pablo.de

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

--
M. Ranganathan

Advanced Networking Technologies Division,
National Institute of Standards and Technology (NIST),
100 Bureau Drive, Stop 8920, Gaithersburg, MD 20899. tel:301 975 3664 , fax:301 590 0932 http://w3.antd.nist.gov/
Advanced Networking Technologies For the People!

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net