[sip-comm-dev] Profiling with netbeans...


#1

Thing is: when I insert org.netbeans.lib.profiler.server to
util.manifest.mf's Import-Package it works for util bundle.
That means I need to add this line to all manifest files? Isn't there a
global import function?
it worked for file access and configuration too

···

On Fri, Apr 11, 2008 at 5:56 PM, <heavy@ungoverned.org> wrote:

Well, it depends on how everything is being launched...if no one has a
solution, I will try to look into it from a felix perspective.

-> richard

-----Original Message-----

From: "Thiago Bolaum" <bolaum@gmail.com>
Subj: Re: [sip-comm-dev] Profiling with netbeans...
Date: Fri Apr 11, 2008 15:50
Size: 2K
To: dev@sip-communicator.dev.java.net

it didn't work... I've added

org.osgi.framework.boot.delegation= org.netbeans.lib.profiler.server;

to lib/felix.client.run.properties without success. Same error comes up.
I have copied jfluid-server.jar (which contains
org.netbeans.lib.profiler.server.ProfilerRuntimeCPUFullInstr) to lib/.
Didn't work either.

I'm lost xD

On Fri, Apr 11, 2008 at 5:26 PM, Benoit Pradelle <ze_real_neo@yahoo.fr> > wrote:

> Hi all,
>
> Actually this file is lib/felix.client.run.properties but I already
tried
> to set classes from a profiler in this property but it didn't worked. I
hope
> that you'll have more luck than I did :slight_smile:
>
> Hope that helps,
> Ben
>
> On Fri, 11 Apr 2008 15:16:00 -0500 > > <heavy@ungoverned.org> wrote:
>
> >
> > whereever you found the system packages property...this is a Felix
> property, so you will likely be setting it in the config.properties file
of
> Felix in the SC, but I don't know where that is since I don't develop on
> SC...
> >
> > If you can't find it, someone else will be able to tell you where. :slight_smile:
> >
> > -> richard
> >
> > p.s. I would try to find it for you, but I am emailing from my
phone...
> >
> > -----Original Message-----
> >
> > From: "Thiago Bolaum" <bolaum@gmail.com>
> > Subj: Re: [sip-comm-dev] Profiling with netbeans...
> > Date: Fri Apr 11, 2008 15:09
> > Size: 4K
> > To: dev@sip-communicator.dev.java.net
> >
> > where do I find this property?
> > In the build file?
> >
> > On Fri, Apr 11, 2008 at 4:25 PM, <heavy@ungoverned.org> wrote:
> >
> > >
> > > I don't know if anyone has mentioned it yet, but you could just add
> the
> > > profiler packages to the org.osgi.framework.boot.delegation
property,
> then
> > > all bundles will have access to it without importing (assuming it is
> on the
> > > class path). This should only be used in your debugging setup...
> > >
> > > -> richard
> > >
> > > -----Original Message-----
> > >
> > > From: Damian Minkov <damencho@damencho.com>
> > > Subj: Re: [sip-comm-dev] Profiling with netbeans...
> > > Date: Fri Apr 11, 2008 1:32
> > > Size: 4K
> > > To: dev@sip-communicator.dev.java.net
> > >
> > > Hi,
> > >
> > > the error you get is that OSGi didn't see the classes of the profil
--- message truncated ---

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

--
Thiago 'bolaum' Borges Abdnur
----------------------------------
"Trust no one..."
- Deep Throat (The X-Files)