[sip-comm-dev] problems with speex codec


#1

Hi guys,
I've still some problems with speex codec. Now it's correctly
installed on our asterisk and it shows some translations to other
codecs, when I type 'show translation' command in asterisk prompt. I
set disallow=all and allow=speex for user, which I connect to with sip
communicator, sip communicator corretly registers on server, but when
I call conference room, sip communicator writes 'Failed' and asterisk
returns this:
Capabilities: us - 0x200 (speex), peer - audio=0x2f (g723|gsm|ulaw|alaw|adpcm)/video=0xd0000 (jpeg|h261|h263), combined - 0x0 (nothing)
Non-codec capabilities: us - 0x1 (telephone-event), peer - 0x0 (nothing), combined - 0x0 (nothing)
Dec 18 11:14:22 NOTICE[7957]: chan_sip.c:3685 process_sdp: No compatible codecs!

So it looks like client doesn't support the speex codec. Is it
necessary to set sip communicator to use the speex codec? I didn't
find any option to do this.

And I have another problem :slight_smile:
I tried to open sip communicator in my Eclipse using .project and
.classpath files in ide directory, but .classpath file contains
references to the libraries in the lib directory, which aren't there.
I've tried to remove these references, but then I wasn't able to
compile it in Eclipse :frowning: Am I doing anything wrong?

Sorry that I'm still disturbing you and thanx much for your answers.
Zdenek Louzensky

S pozdravem,
Zdeněk Louženský

···

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#2

Hi,
are you using the latest build of SIP Communicator.
In the log file (which is in user_home/.sip-communicator/log) do you see something like.
    impl.media.MediaControl.registerCustomCodecs() Codec : net.java.sip.communicator.impl.media.codec.audio.speex.JavaEncoder is succsefully registered : true
    impl.media.MediaControl.registerCustomCodecs() Codec : net.java.sip.communicator.impl.media.codec.audio.speex.JavaDecoder is succsefully registered : true
    ......
    impl.media.MediaControl.initProcessor() Audio=[2]=speex/rtp; sdp=110

For compilation I use ant (ant rebuild, ant run). I not familiar with eclipse. For Eclipse you can see :
http://www.sip-communicator.org/index.php/Documentation/ConfigureEclipseNew.

damencho

Zden�k Lou�ensk� wrote:

···

Hi guys,
I've still some problems with speex codec. Now it's correctly
installed on our asterisk and it shows some translations to other
codecs, when I type 'show translation' command in asterisk prompt. I
set disallow=all and allow=speex for user, which I connect to with sip
communicator, sip communicator corretly registers on server, but when
I call conference room, sip communicator writes 'Failed' and asterisk
returns this:
Capabilities: us - 0x200 (speex), peer - audio=0x2f (g723|gsm|ulaw|alaw|adpcm)/video=0xd0000 (jpeg|h261|h263), combined - 0x0 (nothing)
Non-codec capabilities: us - 0x1 (telephone-event), peer - 0x0 (nothing), combined - 0x0 (nothing)
Dec 18 11:14:22 NOTICE[7957]: chan_sip.c:3685 process_sdp: No compatible codecs!

So it looks like client doesn't support the speex codec. Is it
necessary to set sip communicator to use the speex codec? I didn't
find any option to do this.

And I have another problem :slight_smile:
I tried to open sip communicator in my Eclipse using .project and
.classpath files in ide directory, but .classpath file contains
references to the libraries in the lib directory, which aren't there.
I've tried to remove these references, but then I wasn't able to
compile it in Eclipse :frowning: Am I doing anything wrong?

Sorry that I'm still disturbing you and thanx much for your answers.
Zdenek Louzensky

S pozdravem,
Zden�k Lou�ensk�

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#3

Hi damencho,
my problem really was with the version of sip communicator, I think I
forgot to rebuild the old one, now the speex codec is working.
Is there any possibility to set speex codec bitrate on client side?
Now it's always using 8000 kbps and I'm trying to have higher bitrate,
I set it to higher bitrate on the server side, but it's still using only 8000 kbps.

Btw. I'm now waiting for observer rights for sip communicator project,
so I hope I'll then be able to compile sip communicator under Eclipse.
Thanks a lot.

Zdenek

···

Hi,
are you using the latest build of SIP Communicator.
In the log file (which is in user_home/.sip-communicator/log) do you see
something like.
    impl.media.MediaControl.registerCustomCodecs() Codec :
net.java.sip.communicator.impl.media.codec.audio.speex.JavaEncoder is
succsefully registered : true
    impl.media.MediaControl.registerCustomCodecs() Codec :
net.java.sip.communicator.impl.media.codec.audio.speex.JavaDecoder is
succsefully registered : true
    ......
    impl.media.MediaControl.initProcessor() Audio=[2]=speex/rtp; sdp=110

For compilation I use ant (ant rebuild, ant run). I not familiar with
eclipse. For Eclipse you can see :
http://www.sip-communicator.org/index.php/Documentation/ConfigureEclipseNew.

damencho

Zdeněk Louženský wrote:

Hi guys,
I've still some problems with speex codec. Now it's correctly
installed on our asterisk and it shows some translations to other
codecs, when I type 'show translation' command in asterisk prompt. I
set disallow=all and allow=speex for user, which I connect to with sip
communicator, sip communicator corretly registers on server, but when
I call conference room, sip communicator writes 'Failed' and asterisk
returns this:
Capabilities: us - 0x200 (speex), peer - audio=0x2f (g723|gsm|ulaw|alaw|adpcm)/video=0xd0000 (jpeg|h261|h263), combined - 0x0 (nothing)
Non-codec capabilities: us - 0x1 (telephone-event), peer - 0x0 (nothing), combined - 0x0 (nothing)
Dec 18 11:14:22 NOTICE[7957]: chan_sip.c:3685 process_sdp: No compatible codecs!

So it looks like client doesn't support the speex codec. Is it
necessary to set sip communicator to use the speex codec? I didn't
find any option to do this.

And I have another problem :slight_smile:
I tried to open sip communicator in my Eclipse using .project and
.classpath files in ide directory, but .classpath file contains
references to the libraries in the lib directory, which aren't there.
I've tried to remove these references, but then I wasn't able to
compile it in Eclipse :frowning: Am I doing anything wrong?

Sorry that I'm still disturbing you and thanx much for your answers.
Zdenek Louzensky

S pozdravem,
Zdeněk Louženský

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail:
dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#4

Hi,
currently there is no option to do so. We must discuss this how to set it in the code.
I there is any move on this question I will response here.

damencho

Zden�k Lou�ensk� wrote:

···

Hi damencho,
my problem really was with the version of sip communicator, I think I
forgot to rebuild the old one, now the speex codec is working.
Is there any possibility to set speex codec bitrate on client side?
Now it's always using 8000 kbps and I'm trying to have higher bitrate,
I set it to higher bitrate on the server side, but it's still using only 8000 kbps.

Btw. I'm now waiting for observer rights for sip communicator project,
so I hope I'll then be able to compile sip communicator under Eclipse.
Thanks a lot.

Zdenek

Hi,
are you using the latest build of SIP Communicator.
In the log file (which is in user_home/.sip-communicator/log) do you see
something like.
    impl.media.MediaControl.registerCustomCodecs() Codec : net.java.sip.communicator.impl.media.codec.audio.speex.JavaEncoder is succsefully registered : true
    impl.media.MediaControl.registerCustomCodecs() Codec : net.java.sip.communicator.impl.media.codec.audio.speex.JavaDecoder is succsefully registered : true
    ......
    impl.media.MediaControl.initProcessor() Audio=[2]=speex/rtp; sdp=110
    
For compilation I use ant (ant rebuild, ant run). I not familiar with eclipse. For Eclipse you can see :
http://www.sip-communicator.org/index.php/Documentation/ConfigureEclipseNew.
    
damencho
    
Zden�k Lou�ensk� wrote:
    

Hi guys,
I've still some problems with speex codec. Now it's correctly
installed on our asterisk and it shows some translations to other
codecs, when I type 'show translation' command in asterisk prompt. I
set disallow=all and allow=speex for user, which I connect to with sip
communicator, sip communicator corretly registers on server, but when
I call conference room, sip communicator writes 'Failed' and asterisk
returns this:
Capabilities: us - 0x200 (speex), peer - audio=0x2f (g723|gsm|ulaw|alaw|adpcm)/video=0xd0000 (jpeg|h261|h263), combined - 0x0 (nothing)
Non-codec capabilities: us - 0x1 (telephone-event), peer - 0x0 (nothing), combined - 0x0 (nothing)
Dec 18 11:14:22 NOTICE[7957]: chan_sip.c:3685 process_sdp: No compatible codecs!

So it looks like client doesn't support the speex codec. Is it
necessary to set sip communicator to use the speex codec? I didn't
find any option to do this.

And I have another problem :slight_smile:
I tried to open sip communicator in my Eclipse using .project and
.classpath files in ide directory, but .classpath file contains
references to the libraries in the lib directory, which aren't there.
I've tried to remove these references, but then I wasn't able to
compile it in Eclipse :frowning: Am I doing anything wrong?

Sorry that I'm still disturbing you and thanx much for your answers.
Zdenek Louzensky

S pozdravem,
Zden�k Lou�ensk�

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail:
dev-help@sip-communicator.dev.java.net
    
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#5

Ok, thanx damencho.
I'll be waiting for your response :wink:

You probably can't help me with my Eclipse problem (because you use ant
for compilation), so I'll post it as
new email to the list.

···

Hi,
currently there is no option to do so. We must discuss this how to set
it in the code.
I there is any move on this question I will response here.

damencho

Zdeněk Louženský wrote:

Hi damencho,
my problem really was with the version of sip communicator, I think I
forgot to rebuild the old one, now the speex codec is working.
Is there any possibility to set speex codec bitrate on client side?
Now it's always using 8000 kbps and I'm trying to have higher bitrate,
I set it to higher bitrate on the server side, but it's still using only 8000 kbps.

Btw. I'm now waiting for observer rights for sip communicator project,
so I hope I'll then be able to compile sip communicator under Eclipse.
Thanks a lot.

Zdenek

Hi,
are you using the latest build of SIP Communicator.
In the log file (which is in user_home/.sip-communicator/log) do you see
something like.
    impl.media.MediaControl.registerCustomCodecs() Codec :
net.java.sip.communicator.impl.media.codec.audio.speex.JavaEncoder is
succsefully registered : true
    impl.media.MediaControl.registerCustomCodecs() Codec :
net.java.sip.communicator.impl.media.codec.audio.speex.JavaDecoder is
succsefully registered : true
    ......
    impl.media.MediaControl.initProcessor() Audio=[2]=speex/rtp; sdp=110
    
For compilation I use ant (ant rebuild, ant run). I not familiar with
eclipse. For Eclipse you can see :
http://www.sip-communicator.org/index.php/Documentation/ConfigureEclipseNew.
    
damencho
    
Zdeněk Louženský wrote:
    

Hi guys,
I've still some problems with speex codec. Now it's correctly
installed on our asterisk and it shows some translations to other
codecs, when I type 'show translation' command in asterisk prompt. I
set disallow=all and allow=speex for user, which I connect to with sip
communicator, sip communicator corretly registers on server, but when
I call conference room, sip communicator writes 'Failed' and asterisk
returns this:
Capabilities: us - 0x200 (speex), peer - audio=0x2f (g723|gsm|ulaw|alaw|adpcm)/video=0xd0000 (jpeg|h261|h263), combined - 0x0 (nothing)
Non-codec capabilities: us - 0x1 (telephone-event), peer - 0x0 (nothing), combined - 0x0 (nothing)
Dec 18 11:14:22 NOTICE[7957]: chan_sip.c:3685 process_sdp: No compatible codecs!

So it looks like client doesn't support the speex codec. Is it
necessary to set sip communicator to use the speex codec? I didn't
find any option to do this.

And I have another problem :slight_smile:
I tried to open sip communicator in my Eclipse using .project and
.classpath files in ide directory, but .classpath file contains
references to the libraries in the lib directory, which aren't there.
I've tried to remove these references, but then I wasn't able to
compile it in Eclipse :frowning: Am I doing anything wrong?

Sorry that I'm still disturbing you and thanx much for your answers.
Zdenek Louzensky

S pozdravem,
Zdeněk Louženský

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail:
dev-help@sip-communicator.dev.java.net
    
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail:
dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net