[sip-comm-dev] Problem with windows installer


#1

Hi everybody!!
I still have a problem creating a windows installer. I create the windows
installer, apparently the create proccess is OK.
build-installation-windows:
[propertyfile] Creating new property file:
C:\eclipse\Workspace\sip-communicator\release\windows\versionupdate.properties
     [copy] Copying 1 file to
C:\eclipse\Workspace\sip-communicator\release\windows
     [copy] Copying 1 file to
C:\eclipse\Workspace\sip-communicator\release\windows\tmp
     [copy] Copying 1 file to
C:\eclipse\Workspace\sip-communicator\release\windows\tmp
     [copy] Copying 1 file to
C:\eclipse\Workspace\sip-communicator\release\windows\tmp\jre
     [copy] Copying 1 file to
C:\eclipse\Workspace\sip-communicator\release\windows\tmp
   [izpack] Building installer jar:
C:\eclipse\Workspace\sip-communicator\release\windows\tmp\sip-communicator-windows.jar
   [izpack] Copying 62 files into installer
   [izpack] Merging 8 jars into installer
   [izpack] Writing 5 Packs into installer
      [zip] Building zip:
C:\eclipse\Workspace\sip-communicator\release\windows\sip-communicator-1.0-alpha3-0.build.by.SVN-windows.zip
     [exec] 7-Zip 4.65 Copyright (c) 1999-2009 Igor Pavlov 2009-02-03
     [exec] Scanning
     [exec] Creating archive data.7z
     [exec] Compressing sip-communicator-windows.jar
     [exec] Compressing tmp-installer-windows.xml
     [exec] Compressing launcher.ini
     [exec] Compressing jre\jre-windows.exe
     [exec] Compressing setup-sip-communicator.exe
     [exec] Everything is Ok
     [copy] Copying 1 file to
C:\eclipse\Workspace\sip-communicator\release\windows\tmp
   [concat] Binary concatenation of 3 resources to
C:\eclipse\Workspace\sip-communicator\release\windows\sip-communicator-1.0-alpha3-0.build.by.SVN.exe
   [delete] Deleting directory
C:\eclipse\Workspace\sip-communicator\release\windows\tmp

But, when I open the sip-communicator-1.0-alpha3-0.build.by.SVN.exe, the
program ask me if I want to install the program, I click on YES, then it
extracts all the files... and a warning window appears, this windowI shows
the next message: The sip-communicator installer you are attempting to run
seems to have a copy already running.
I am sure that there are no other sip-communicator installers running.
If I run the executable jar file (sip-communicator-windows.jar) in the
Command Promp, the same warning window I've described before appears, and in
the Command Promp I have a java.lang.ClassNotFoundException:
com.izforge.izpack.panels.HelloPanel2

I don't know what can be the problem... any idea?
Thanks in advance!!!!
Regards
Marta


#2

Marta,

The IzPack installer for Windows isn't actively supported because it
has multiple issues with installation and uninstallation and the
nightly builds of SIP Communicator are based on MSI/WiX. I'm
mentioning it just as an explanation why answers to problems regarding
the IzPack installer for Windows may be a touch difficult to get at
the time of this writing. We will, however, welcome your patches for
any problems you're able to resolve.

Best regards,
Lubo

···

On Tue, Mar 17, 2009 at 6:22 PM, Marta Luna Serrano <martalun@gmail.com> wrote:

Hi everybody!!
I still have a problem creating a windows installer. I create the windows
installer, apparently the create proccess is OK.
build-installation-windows:
[propertyfile] Creating new property file:
C:\eclipse\Workspace\sip-communicator\release\windows\versionupdate.properties
[copy] Copying 1 file to
C:\eclipse\Workspace\sip-communicator\release\windows
[copy] Copying 1 file to
C:\eclipse\Workspace\sip-communicator\release\windows\tmp
[copy] Copying 1 file to
C:\eclipse\Workspace\sip-communicator\release\windows\tmp
[copy] Copying 1 file to
C:\eclipse\Workspace\sip-communicator\release\windows\tmp\jre
[copy] Copying 1 file to
C:\eclipse\Workspace\sip-communicator\release\windows\tmp
[izpack] Building installer jar:
C:\eclipse\Workspace\sip-communicator\release\windows\tmp\sip-communicator-windows.jar
[izpack] Copying 62 files into installer
[izpack] Merging 8 jars into installer
[izpack] Writing 5 Packs into installer
[zip] Building zip:
C:\eclipse\Workspace\sip-communicator\release\windows\sip-communicator-1.0-alpha3-0.build.by.SVN-windows.zip
[exec] 7-Zip 4.65 Copyright (c) 1999-2009 Igor Pavlov 2009-02-03
[exec] Scanning
[exec] Creating archive data.7z
[exec] Compressing sip-communicator-windows.jar
[exec] Compressing tmp-installer-windows.xml
[exec] Compressing launcher.ini
[exec] Compressing jre\jre-windows.exe
[exec] Compressing setup-sip-communicator.exe
[exec] Everything is Ok
[copy] Copying 1 file to
C:\eclipse\Workspace\sip-communicator\release\windows\tmp
[concat] Binary concatenation of 3 resources to
C:\eclipse\Workspace\sip-communicator\release\windows\sip-communicator-1.0-alpha3-0.build.by.SVN.exe
[delete] Deleting directory
C:\eclipse\Workspace\sip-communicator\release\windows\tmp

But, when I open the sip-communicator-1.0-alpha3-0.build.by.SVN.exe, the
program ask me if I want to install the program, I click on YES, then it
extracts all the files... and a warning window appears, this windowI shows
the next message: The sip-communicator installer you are attempting to run
seems to have a copy already running.
I am sure that there are no other sip-communicator installers running.
If I run the executable jar file (sip-communicator-windows.jar) in the
Command Promp, the same warning window I've described before appears, and in
the Command Promp I have a java.lang.ClassNotFoundException:
com.izforge.izpack.panels.HelloPanel2

I don't know what can be the problem... any idea?
Thanks in advance!!!!
Regards
Marta

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net