[sip-comm-dev] Problem in installing SC and configuring eclipse for SC


#1

Hi,

I am interested in studying the sip communicator project and contribute to
it. Thus I tried to install the exe and followed developer documentation in
order to first configure the IDE and look at the source code, during which I
came across following problems to which I could not find a solution. Thus I
thought of writing to dev mailing list and ask for help.

1) When I tried to install the exe for windows; in my vista OS,
installation happens fine but when I tried to luanch SC, an error occurs
saying "Could not create the java virtual machine". I have installed Java
SDK 6 and working with Netbeans 6.1 with out a problem in my machine. Could
you please suggest why such an error occurs? Is it due to a problem in
vista?

2) According to the developer documentation I tried to configure eclipse to
compile SC. Subclipse installed fine, but as the step 4 of the document
says, when I tried to update subclipse 1.2.0 to the one that matches SC, I
get an error where I could not proceed further. (I am using java-europa
eclipse. I downloaded and tried to use ganymed eclipse aswel but did not got
any solution). Can you tell me what is the most suitable version of eclipse
to work with SC?

3) I joined the project as an observer and I tried to access irc channel to
get a solution to my above problems, but I was redirected to a page which
displays "access forbidden". How can I access irc channel?

I am a new bee to this and though I tried to figure out a solution, so far I
could not. So if any of you could please give any suggestions it would be a
great help for me to proceed.
I apologize if this is an irrelevant thing to be asked in this mailing list.

Thank you.
regards,
Hasini.


#2

Hi Hasini,

1) When I tried to install the exe for windows; in my vista OS,
installation happens fine but when I tried to luanch SC, an error occurs
saying "Could not create the java virtual machine". I have installed Java
SDK 6 and working with Netbeans 6.1 with out a problem in my machine. Could
you please suggest why such an error occurs? Is it due to a problem in
vista?

I think it's the second report of such an issue. The first one was
recently submitted and, if I'm not mistaken, the OS was Windows XP.
Emil started looking into it so the changes are pretty high that it'll
be resolved soon.

2) According to the developer documentation I tried to configure eclipse to
compile SC. Subclipse installed fine, but as the step 4 of the document
says, when I tried to update subclipse 1.2.0 to the one that matches SC, I
get an error where I could not proceed further. (I am using java-europa
eclipse. I downloaded and tried to use ganymed eclipse aswel but did not got
any solution). Can you tell me what is the most suitable version of eclipse
to work with SC?

I use Eclipse 3.4.1. Anyway, SC can be developed with Europa as well.
I myself plan to switch to 3.5M5.

The subject of Subversion integration in Eclipse though is a different
matter. For what it's worth, Subversion integration in Eclipse isn't
required to contribute to the project, a command-line client will
suffice. Besides, you don't have commit rights to the repository. From
personal experience, I'm inclined to consider Subclipse the worse of
the two evils and I feel less annoyed by Subversive. On the other
hand, Subversive can be a pain to install right. Anyway, SC doesn't
mandate any specific way of installation of either Subclipse or
Subversive so you can just follow the installation instructions of the
integration product of your choice.

3) I joined the project as an observer and I tried to access irc channel to
get a solution to my above problems, but I was redirected to a page which
displays "access forbidden". How can I access irc channel?

Point your IRC client to irc.freenode.net and, after it connects, join
the channel #sip-communicator - that's how I do it and there's never
been anything more or special to get it to work.

Best regards,
Lubo

ยทยทยท

On Wed, Feb 4, 2009 at 9:31 AM, Hasini Gunasinghe <hasi7786@gmail.com> wrote:

Hi,

I am interested in studying the sip communicator project and contribute to
it. Thus I tried to install the exe and followed developer documentation in
order to first configure the IDE and look at the source code, during which I
came across following problems to which I could not find a solution. Thus I
thought of writing to dev mailing list and ask for help.

1) When I tried to install the exe for windows; in my vista OS,
installation happens fine but when I tried to luanch SC, an error occurs
saying "Could not create the java virtual machine". I have installed Java
SDK 6 and working with Netbeans 6.1 with out a problem in my machine. Could
you please suggest why such an error occurs? Is it due to a problem in
vista?

2) According to the developer documentation I tried to configure eclipse to
compile SC. Subclipse installed fine, but as the step 4 of the document
says, when I tried to update subclipse 1.2.0 to the one that matches SC, I
get an error where I could not proceed further. (I am using java-europa
eclipse. I downloaded and tried to use ganymed eclipse aswel but did not got
any solution). Can you tell me what is the most suitable version of eclipse
to work with SC?

3) I joined the project as an observer and I tried to access irc channel to
get a solution to my above problems, but I was redirected to a page which
displays "access forbidden". How can I access irc channel?

I am a new bee to this and though I tried to figure out a solution, so far I
could not. So if any of you could please give any suggestions it would be a
great help for me to proceed.
I apologize if this is an irrelevant thing to be asked in this mailing list.

Thank you.
regards,
Hasini.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net