[sip-comm-dev] Outgoing Jingle call failed


#1

What a pity - today I failed to call the same contact I called successfully yesterday (remember the router SIP helper issue -obviously this wasn't the cause.)

Please see the attached log. What's wrong?

Thanks for help
Conrad

jingle_call_ice.log (13.5 KB)


#2

Hey Conrad,

На 16.12.10 21:27, Conrad Beckert написа:

What a pity - today I failed to call the same contact I called
successfully yesterday (remember the router SIP helper issue
-obviously this wasn't the cause.)

Yes, I wanted to respond to this yesterday but didn't get a chance to.
Normally SIP ALG issues would apply when a NAT box is eager to help you
resolve your NAT problems and replaces your private addresses with those
from its "WAN" interface, only when doing so does it badly and messes up
the media streams.

That kind of issues shouldn't occur with Jingle since XMPP messages are
generally encrypted. The issue that you could come across is a router
that only allows UDP traffic after seeing a SIP exchange ... but this is
supposedly less common.

Please see the attached log. What's wrong?

You seem to have two calls in there. The first one failed indeed. The
reason is that SC could not successfully exchange packets on any of the
addresses that exchanged with your correspondent. In order to confirm
whether this is really what happened, we'd need to see the pcap files
from your log folder (for the same session). In case you didn't save
them, could you please rerun the test? (Oh, and you do need to have
Packet Logging enabled)

Now, the second call in there does seem OK though. One of the addresses
that didn't work the first time, seemed to work this time. Can you tell
us exactly what happened?

Cheers,
Emil

···

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#3

Hey Conrad,

We've looked at the logs from the tests you and I had the other evening.
It appears that while I was getting all your STUN messages you weren't
seeing any of mine so ICE processing determines there's no viable route
between us.

We are not 100% sure why this happens, and it's quite strange that
things worked when I was the one calling you. At this point I'd be more
inclined to believe that the issue is related to your NAT box.

It might make sense to check whether adding a TURN server would help. In
case you don't have one around, we'll create an account for you on ours.
Let me know when you'd have a minute.

Cheers,
Emil

На 16.12.10 21:27, Conrad Beckert написа:

···

What a pity - today I failed to call the same contact I called
successfully yesterday (remember the router SIP helper issue
-obviously this wasn't the cause.)

Please see the attached log. What's wrong?

Thanks for help Conrad

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#4

Hi Emil,

for the record: I've changed the configuration of my router and was able to call.

I had configured a DMZ and hence forwarded all ports to the local address of my machine. For some strange reason it failed.

One might argue that a DMZ is meant to function as a border check point for all IP traffic - so it might consider packets trying to circumvent it as offenders. This explains why the outgoing packets get lost.

But the good question is: why does SIP to Asterisk work with the same configuration?

Kind Regards
Conrad

-------- Original-Nachricht --------

···

Datum: Sun, 19 Dec 2010 10:54:44 +0200
Von: Emil Ivov <emcho@sip-communicator.org>
An: dev@sip-communicator.dev.java.net
CC: Conrad Beckert <conrad_videokonferenz@gmx.de>
Betreff: Re: [sip-comm-dev] Outgoing Jingle call failed

Hey Conrad,

We've looked at the logs from the tests you and I had the other evening.
It appears that while I was getting all your STUN messages you weren't
seeing any of mine so ICE processing determines there's no viable route
between us.

We are not 100% sure why this happens, and it's quite strange that
things worked when I was the one calling you. At this point I'd be more
inclined to believe that the issue is related to your NAT box.

It might make sense to check whether adding a TURN server would help. In
case you don't have one around, we'll create an account for you on ours.
Let me know when you'd have a minute.

Cheers,
Emil

На 16.12.10 21:27, Conrad Beckert написа:
> What a pity - today I failed to call the same contact I called
> successfully yesterday (remember the router SIP helper issue
> -obviously this wasn't the cause.)
>
> Please see the attached log. What's wrong?
>
> Thanks for help Conrad
>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net