[sip-comm-dev] Outgoing Call


#1

Hi Everybody,

My SIP Communicator can register itself in OpenIMSCore server. Now the registration is working perfectly. Now I am working on making a call from SIP Communicator. I have tested my SIP Communicator with other client. If I call to my SIP Communicator form other client like IMS Communicator the session establishment is working. But if I try to call from my SIP Communicator to any other client or to SIP Communicator itself, then it's not working. This means incoming call is working but outgoing call is not working

From the network trace I found 400 Bad requests - Not following indicated Service-Routes. It seems like SIP Communicator is missing the Service Route. I am trying to debugging this problem now.

It will be really helpful for me if I get a feedback for this problem.

I am sending the network trace by attachment.

Best regards

Yeasin Habib
Student
Smart Networked Environments Cluster
Connected Consumer Solutions
Philips Research Laboratories

Building HTC 34 Room 6-58
High Tech Campus
5656 AE Eindhoven
The Netherlands
Tel: +31 40 27 49556
Fax: +31 40 27 46321
E-mail: yeasin.habib@philips.com<mailto:yeasin.habib@philips.com>

outgoing_call.pcap (18.6 KB)


#2

Hi Yeasin,

From the network trace I found 400 Bad requests - Not following indicated
Service-Routes. It seems like SIP Communicator is missing the Service
Route. I am trying to debugging this problem now.

As you found already: the Service-Route is ignored by your client.
In 200 OK of REGISTER request the client receives a Service-Route header
field which it MUST use as a preloaded route in every following initial
requests. Your SIP Communicator ignores the Service-Route header field and
therefore the request is rejected by P-CSCF.

There are now 2 options:
- only use Service-Route capable clients, or
- let the P-CSCF enforce the route.
The 2nd option is easy to activate in pcscf.cfg as " #Variant 2 - enforce
routes and let the dialog continue".

Regards
Franz

···

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#3

Hi Yeasin,

As Franz has pointed SIP Communicator is currently not handling
Service-Route headers. It shouldn't be difficult to implement this
though so if you have the time I encourage you to give it a try.

Let us know if you need any help or further explanations.

Cheers
Emil

Franz Edler написа:

···

Hi Yeasin,

From the network trace I found 400 Bad requests - Not following indicated
Service-Routes. It seems like SIP Communicator is missing the Service
Route. I am trying to debugging this problem now.

As you found already: the Service-Route is ignored by your client.
In 200 OK of REGISTER request the client receives a Service-Route header
field which it MUST use as a preloaded route in every following initial
requests. Your SIP Communicator ignores the Service-Route header field and
therefore the request is rejected by P-CSCF.

There are now 2 options:
- only use Service-Route capable clients, or
- let the P-CSCF enforce the route.
The 2nd option is easy to activate in pcscf.cfg as " #Variant 2 - enforce
routes and let the dialog continue".

Regards
Franz

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net