[sip-comm-dev] org.osgi.framework.BundleException: Unresolved package in bundle ERROR


#1

hi guys, i think this is a pretty simple problem but i just can not get it fixed in any way.

i am trying to create a service in the sip-communicator. the service requires asteriskJava jar file which i already put in the classpath of the sip communicator. i can compile without any error. i have also put in all the proper imports in manifest file and in the felix.client.run.properties files. and yet i get this following error:

[java] ERROR: Error starting reference:file:sc-bundles/asteriskevent.jar (org.osgi.framework.BundleException: Unresolved package in bundle 59: package; (&(package=net.java.sip.communicator.service.asteriskevent)(version>=0.0.0)))
[java] org.osgi.framework.BundleException: Unresolved package in bundle 59: package; (&(package=net.java.sip.communicator.service.asteriskevent)(version>=0.0.0))
[java] at org.apache.felix.framework.Felix._resolveBundle(Felix.java:1650)
[java] at org.apache.felix.framework.Felix._startBundle(Felix.java:1517)
[java] at org.apache.felix.framework.Felix.startBundle(Felix.java:1470)
[java] at org.apache.felix.framework.Felix.setFrameworkStartLevel(Felix.java:1065)
[java] at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:258)
[java] at java.lang.Thread.run(Unknown Source)

my manifest file for asteriskEvent service is:

Bundle-Activator: net.java.sip.communicator.impl.asteriskevent.AsteriskEventActivator
Bundle-Name: Asterisk Event
Bundle-Description: An implementation of the Asterisk server listerner.
Bundle-Vendor: khan.softverk.co.th
Bundle-Version: 0.0.0
Import-Package: org.osgi.framework,
net.java.sip.communicator.service.asteriskevent,
org.asteriskjava.live.AsteriskChannel,
org.asteriskjava.live.AsteriskQueue,
org.asteriskjava.live.AsteriskServer,
org.asteriskjava.live.AsteriskServerListener,
org.asteriskjava.live.DefaultAsteriskServer,
org.asteriskjava.live.MeetMeRoom,
org.asteriskjava.live.MeetMeUser

and my felix