[sip-comm-dev] NPE during SC initialization


#1

All,

today I updated my SC and got a lot of changes during SVN update.

However, when trying to start SC it somehow throws an NPE:

run:
      [java]
      [java] Welcome to Felix.
      [java] =================
      [java]
      [java] libxcb: WARNING! Program tries to unlock a connection without having acquired
      [java] a lock first, which indicates a programming error.
      [java] There will be no further warnings about this issue.
      [java] libxcb: WARNING! Program tries to lock an already locked connection,
      [java] which indicates a programming error.
      [java] There will be no further warnings about this issue.
      [java] 15:55:23.742 INFO: impl.protocol.zeroconf.ZeroconfActivator.start().74 Zeroconf protocol implementation [STARTED].
      [java] ERROR: Error starting reference:file:sc-bundles/swing-ui.jar (org.osgi.framework.BundleException: Activator start error.)
      [java] java.lang.NullPointerException
      [java] at net.java.sip.communicator.impl.gui.UIServiceImpl.initCustomFonts(UIServiceImpl.java:949)
      [java] at net.java.sip.communicator.impl.gui.UIServiceImpl.setDefaultThemePack(UIServiceImpl.java:828)
      [java] at net.java.sip.communicator.impl.gui.UIServiceImpl.loadApplicationGui(UIServiceImpl.java:108)
      [java] at net.java.sip.communicator.impl.gui.GuiActivator.start(GuiActivator.java:96)
      [java] at org.apache.felix.framework.util.SecureAction.startActivator(SecureAction.java:589)
      [java] at org.apache.felix.framework.Felix._startBundle(Felix.java:1536)
      [java] at org.apache.felix.framework.Felix.startBundle(Felix.java:1470)
      [java] at org.apache.felix.framework.Felix.setFrameworkStartLevel(Felix.java:1065)
      [java] at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:258)
      [java] at java.lang.Thread.run(Thread.java:595)
      [java] ERROR: Error starting reference:file:sc-bundles/systray.jar (org.osgi.framework.BundleException: Activator start error.)
      [java] java.lang.NullPointerException: Specified service reference cannot be null.

Digging into the problem have a look at call UIServiceImpl which calls
setDefaultThemePack() (which in trun calls initCustomFonts() before it creates
the mainFrame window - that's a bad idea.

Regards,
Werner

···

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net