[sip-comm-dev] newbie question - setting up and debugging sip-communicator with netbeans


#1

Hi,

This is my first mail. I am sure i sound like a stupid with this question, but i have been trying to setup sip-communicator with netbeans and debug it for 3 days now,which is not working. i have followed the steps exactly described in http://www.sip-communicator.org/index.php/Documentation/ConfigureNetbeansNew . now i can build and run the source code jsut fine but when i press “debug main project” , it always shows “nbproject/ide-targets.xml” not found. i am a newbie to netbeans, and i have googled quite exhastedly about how to generate that file. it says that file will be autometically generated the first time i click “debug main project”, but it does not work. i am missing osmethign obvious.

has anyone else run into this problem and does anyone know how to solve it? i really need to have it working on netbeans. i am using netbeasn 6.1 with latest jdk (1.6).

also does anyone has an working copy of ide-target.xml file? if possible, i would like to take a look at it?

regards,

Shrouk Khan

···

To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#2

HaZArd wrote:

Hi,

This is my first mail. I am sure i sound like a stupid with this question, but i have been trying to setup sip-communicator with netbeans and debug it for 3 days now,which is not working. i have followed the steps exactly described in http://www.sip-communicator.org/index.php/Documentation/ConfigureNetbeansNew . now i can build and run the source code jsut fine but when i press "debug main project" , it always shows "nbproject/ide-targets.xml" not found. i am a newbie to netbeans, and i have googled quite exhastedly about how to generate that file. it says that file will be autometically generated the first time i click "debug main project", but it does not work. i am missing osmethign obvious.

  > has anyone else run into this problem and does anyone know how to solve

it? i really need to have it working on netbeans. i am using netbeasn 6.1 with latest jdk (1.6).

also does anyone has an working copy of ide-target.xml file? if possible, i would like to take a look at it?

Hi. I am currently away travelling, so it is difficult for me to help you much because the internet connectivity is poor where I am at the moment.

ide-target.xml was accidentally committed to the repository by someone a long time ago. It wasn't needed, but was the result of one of the developers setting up his or her own netbeans environment incorrectly AND THEN doing a "commit all changed files".

I did some cleaning up because the netbeans files had become hopelessly out of date. I set up build.xml and project.xml so they no longer referenced the redundant file (it never did anything anyway!) I spent a lot of time updating the sip communicator wiki to describe how to set it up for properly netbeans, too.

Have you followed the latest instructions on the wiki - particularly about how to copy the project.xml from the ide/nbproject/ directory? You need to do this or everything will go wrong.

Currently, my own netbeans environment is debugging OK, but I am using a version of the repository that is 2 weeks old. I have problems debugging the unit tests and I've also noticed that there have been some classpath changes since I last updated my sandbox. Once you've got past the ide-target.xml problem, you will probably end up in the same place as me!

I am sorry I cannot help more at the moment, but I hope this advice moves you forward a bit. By the way, I also have netbeans 6.1 and java 6, running under ubuntu hardy.

Regards,

Brian

···

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#3

Hi,
yes i downloaded the old version of the sip communicator(alpha 2) and i was able to debug it. and now the problem is that i can not step into a line or step over or even stop at a break point.
i have put a couple of lines in the main metho ( jsut to check if the debugging it working fine or not, such as System.out.println("starting sip-com") ; and rebuild and debug again) but the debugger seems to take no notice of anything.
 
also i am now trying to use eclipse from your instruction on http://www.sip-communicator.org/index.php/Documentation/ConfigureEclipseNew and when i debug, i get stcuk at the console where it says:
"
Welcome to Felix.

···

=================

Enter profile name:
"
 
i have searched the mailing list, it looks like felix property is not setup correctly. i have already setup the debug arguments as instructed in  http://www.sip-communicator.org/index.php/Documentation/ConfigureEclipseNew  as:
 
-Dfelix.config.properties=file:lib/felix.client.run.properties
-Djava.util.logging.config.file=lib/logging.properties
 
but stil the problem persists.
 
any idea what to do? what is the profile name i should supply ?
 
regards,
Shrouk Khan

--- On Wed, 5/21/08, Brian Burch <brian@PingToo.com> wrote:

From: Brian Burch <brian@PingToo.com>

Subject: Re: [sip-comm-dev] newbie question - setting up and debugging sip-communicator with netbeans
To: dev@sip-communicator.dev.java.net
Date: Wednesday, May 21, 2008, 4:03 AM

HaZArd wrote:
> Hi,
>
> This is my first mail. I am sure i sound like a stupid with this
> question, but i have been trying to setup sip-communicator with netbeans
> and debug it for 3 days now,which is not working. i have followed the
> steps exactly described in
>
http://www.sip-communicator.org/index.php/Documentation/ConfigureNetbeansNew .
> now i can build and run the source code jsut fine but when i press
> "debug main project" , it always shows
"nbproject/ide-targets.xml" not
> found. i am a newbie to netbeans, and i have googled quite exhastedly
> about how to generate that file. it says that file will be autometically
> generated the first time i click "debug main project", but it
does not
> work. i am missing osmethign obvious.
>
  > has anyone else run into this problem and does anyone know how to solve
> it? i really need to have it working on netbeans. i am using netbeasn
> 6.1 with latest jdk (1.6).
>
> also does anyone has an working copy of ide-target.xml file? if
> possible, i would like to take a look at it?

Hi. I am currently away travelling, so it is difficult for me to help
you much because the internet connectivity is poor where I am at the moment.

ide-target.xml was accidentally committed to the repository by someone a
long time ago. It wasn't needed, but was the result of one of the
developers setting up his or her own netbeans environment incorrectly
AND THEN doing a "commit all changed files".

I did some cleaning up because the netbeans files had become hopelessly
out of date. I set up build.xml and project.xml so they no longer
referenced the redundant file (it never did anything anyway!) I spent a
lot of time updating the sip communicator wiki to describe how to set it
up for properly netbeans, too.

Have you followed the latest instructions on the wiki - particularly
about how to copy the project.xml from the ide/nbproject/ directory? You
need to do this or everything will go wrong.

Currently, my own netbeans environment is debugging OK, but I am using a
version of the repository that is 2 weeks old. I have problems debugging
the unit tests and I've also noticed that there have been some classpath
changes since I last updated my sandbox. Once you've got past the
ide-target.xml problem, you will probably end up in the same place as me!

I am sorry I cannot help more at the moment, but I hope this advice
moves you forward a bit. By the way, I also have netbeans 6.1 and java
6, running under ubuntu hardy.

Regards,

Brian

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#4

Hello All,

     I am unable to debug the SipCommunicator project while running with the
netbeans ide. Can any one from the dev explain me how to debug it.

Thanks.
Vinoth Kumar.

···

On Wed, May 21, 2008 at 2:08 PM, HaZArd <gypsydeema2000@yahoo.com> wrote:

Hi,

yes i downloaded the old version of the sip communicator(alpha 2) and i was
able to debug it. and now the problem is that i can not step into a line or
step over or even stop at a break point.

i have put a couple of lines in the main metho ( jsut to check if the
debugging it working fine or not, such as System.out.println("starting
sip-com") ; and rebuild and debug again) but the debugger seems to take no
notice of anything.

also i am now trying to use eclipse from your instruction on
http://www.sip-communicator.org/index.php/Documentation/ConfigureEclipseNew and
when i debug, i get stcuk at the console where it says:

"

Welcome to Felix.

=================

Enter profile name:

"

i have searched the mailing list, it looks like felix property is not setup
correctly. i have already setup the debug arguments as instructed in
http://www.sip-communicator.org/index.php/Documentation/ConfigureEclipseNew
as:

-Dfelix.config.properties=file:lib/felix.client.run.properties
-Djava.util.logging.config.file=lib/logging.properties

but stil the problem persists.

any idea what to do? what is the profile name i should supply ?

regards,

Shrouk Khan

--- On *Wed, 5/21/08, Brian Burch <brian@PingToo.com>* wrote:

From: Brian Burch <brian@PingToo.com>
Subject: Re: [sip-comm-dev] newbie question - setting up and debugging
sip-communicator with netbeans
To: dev@sip-communicator.dev.java.net
Date: Wednesday, May 21, 2008, 4:03 AM

HaZArd wrote:
> Hi,
>
> This is my first mail. I am sure i sound like a stupid with this
> question, but i have been trying to setup sip-communicator with netbeans
> and debug it for 3 days now,which is not working. i have followed the
> steps exactly described in
>http://www.sip-communicator.org/index.php/Documentation/ConfigureNetbeansNew .
> now i can build and run the source code jsut fine but when i press
> "debug main project" , it always shows
"nbproject/ide-targets.xml" not
> found. i am a newbie to netbeans, and i have googled quite exhastedly
> about how to generate that file. it says that file will be autometically
> generated the first time i click "debug main project", but it
does not
> work. i am missing osmethign obvious.
>
  > has anyone else run into this problem and does anyone know how to solve
> it? i really need to have it working on netbeans. i am using netbeasn
> 6.1 with latest jdk (1.6).
>
> also does anyone has an working copy of ide-target.xml file? if
> possible, i would like to take a look at it?

Hi. I am currently away travelling, so it is difficult for me to help
you much because the internet connectivity is poor where I am at the moment.

ide-target.xml was accidentally committed to the repository by someone a
long time ago. It wasn't needed, but was the result of one of the
developers setting up his or her own netbeans environment incorrectly
AND THEN doing a "commit all changed files".

I did some cleaning up because the netbeans files had become hopelessly
out of date. I set up build.xml and project.xml so they no longer
referenced the redundant file (it never did anything anyway!) I spent a
lot of time updating the sip communicator wiki to describe how to set it
up for properly netbeans, too.

Have you followed the latest instructions on the wiki - particularly
about how to copy the project.xml from the ide/nbproject/ directory? You
need to do this or everything will go wrong.

Currently, my own netbeans environment is debugging OK, but I am using a
version of the repository that is 2 weeks old. I have problems debugging
the unit tests and I've also noticed that there have been some classpath
changes since I last updated my sandbox. Once you've got past the
ide-target.xml problem, you will probably end up in the same place as me!

I am sorry I cannot help more at the moment, but I hope this advice
moves you forward a bit. By the way, I also have netbeans 6.1 and java
6, running under ubuntu hardy.

Regards,

Brian

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net