[sip-comm-dev] Network failure


#1

I get an error while trying to log to SIP on an external server. Works fine
on local server. X-lite can also connect fine to the external server.

Windows 7 pro 64 bit

here are the logs with the wireshark trace.

sip-communicator.pcap (9.43 KB)

sip-communicator0.log.0 (14 KB)

···

--
Richard Lavoie
IT consultant / consultant en informatique


#2

Ok the problem was that the SIP account was set with no server in the SIP
id. Altough the registrar and proxy were set to the right server, this
didn't work either.

It would be nice to have a better error than a network failure.

Also, I just found out that specifying TCP in proxy connection uses TLS, I
see a whole bunch of SSL communication when selected TCP, shouldn't that be
TLS that uses SSL communication ?

···

On Sat, Jan 8, 2011 at 6:07 PM, Richard Lavoie <lavoie.richard@gmail.com>wrote:

I get an error while trying to log to SIP on an external server. Works
fine on local server. X-lite can also connect fine to the external server.

Windows 7 pro 64 bit

here are the logs with the wireshark trace.

--
Richard Lavoie
IT consultant / consultant en informatique

--
Richard Lavoie
IT consultant / consultant en informatique


#3

Hey Richard,

На 09.01.11 00:19, Richard Lavoie написа:

Ok the problem was that the SIP account was set with no server in the
SIP id. Altough the registrar and proxy were set to the right server,
this didn't work either.

It would be nice to have a better error than a network failure.

Indeed, could you please enter an issue for this in our tracker?

Also, I just found out that specifying TCP in proxy connection uses TLS,
I see a whole bunch of SSL communication when selected TCP, shouldn't
that be TLS that uses SSL communication ?

For the record, this was cleared as a non-issue on the IRC channel.
Wireshark was simply labeling the 5061 port that the account was
configured to us TCP on as "sip-tls"

Cheers,
Emil

···

On Sat, Jan 8, 2011 at 6:07 PM, Richard Lavoie <lavoie.richard@gmail.com > <mailto:lavoie.richard@gmail.com>> wrote:

    I get an error while trying to log to SIP on an external server.
    Works fine on local server. X-lite can also connect fine to the
    external server.

    Windows 7 pro 64 bit

    here are the logs with the wireshark trace.

    --
    Richard Lavoie
    IT consultant / consultant en informatique

--
Richard Lavoie
IT consultant / consultant en informatique

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
SIP Communicator
emcho@sip-communicator.org PHONE: +33.1.77.62.43.30
http://sip-communicator.org FAX: +33.1.77.62.47.31

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net