[sip-comm-dev] Links not working with IceWeasel


#1

Hello Yana,

as I was looking at the issues I saw this : Links not working with IceWeasel Issue:197.
And I look at the CVS of the project I saw that the CVS have some enhancements that we can use and that are missing in the RC4 version
we are using. The browsers are described in a properties file so we can easily add new browsers!
What about moving to the last CVS version and I will try to fix the problem ?

damencho

···

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#2

Hi all,

as I was looking at the problem with the browser and open links. I saw there is a problem with setting the environment variable path when running from ant. I fix that with adding

<property name="path" value="${system.PATH}"/>

in the build.xml.
Will somebody confirm this ? Or I'm wrong ?

damencho

···

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#3

Hello Damian,

Damian Minkov wrote:

Hi all,

as I was looking at the problem with the browser and open links. I saw there is a problem with setting the environment variable path when running from ant. I fix that with adding

<property name="path" value="${system.PATH}"/>

Right now the environment variable is set on line as follows

<condition property="path"
            value="\{basedir\}/{lib}/native/windows:${system.PATH}">
     <isset property="is.running.windows"/>
</condition>

In other words it would only be set when running on windows. I had coded it this way because we only needed the path so that we could add JMF's dll-s to it (there's no LD_LIBRARY_PATH on windows).

If I understand correctly you are saying that BrowserLauncher uses a a system property named the same way as the env var "path" in order to look for possible browser locations. Is that it?

If so then I guess we could remove the windows condition when setting the path property in build.xml.

Emil

···

in the build.xml.
Will somebody confirm this ? Or I'm wrong ?

damencho

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#4

Hi Emil,

you misunderstood me. The BrowserLauncher uses for example command which. If the path is not set correctly this command cannot be found.
I was looking at the run target where you have
<env key="PATH" value="\{path\}&quot;/&gt; you can see the problem in logs when the variable java\.library\.path is printed \. \(&lt;sysproperty key=&quot;java\.library\.path&quot; value=&quot;{ld.library.path}:${path}"/> )

I mean that environment variable PATH is not set correctly to the java executable when starting sip-communicator.

damencho

···

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#5

OK I think I understand now. I've tried to fix the problem. Is it OK now? (Seems to work for me)

Emil

Damian Minkov wrote:

···

Hi Emil,

you misunderstood me. The BrowserLauncher uses for example command which. If the path is not set correctly this command cannot be found.
I was looking at the run target where you have
<env key="PATH" value="\{path\}&quot;/&gt; you can see the problem in logs when the variable java\.library\.path is printed \. \(&lt;sysproperty key=&quot;java\.library\.path&quot; value=&quot;{ld.library.path}:${path}"/> )

I mean that environment variable PATH is not set correctly to the java executable when starting sip-communicator.

damencho

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#6

Emil Ivov wrote:

OK I think I understand now. I've tried to fix the problem. Is it OK now? (Seems to work for me)

Yes everything is fine now. Iceweasel is working also :slight_smile:

damencho

···

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net