[sip-comm-dev] Jingle problem on NAT


#1

Hi
I'm still having strange problems on the Jingle calls, the calls works on and off, i use always the same environment, 2 or 3 box behind NAT, the calls some time works and many times gives "Call ended by remote party Reason : the call ICE Failed-Application" What i don' understand is why on the same network environment with interval of few seconds one call is ok and one is in error and so for dozen of calls. In attach the complete log folder.

Thanks for the help.

Regards
Fabio

log.zip (90.2 KB)


#2

Hi,

It seems that when peer receives session-accept, ICE processing is not
completly finished and it fails after.

Please try attached patch that will wait ICE processing to be finished
before process session-accept.

Regards,

sc-patch.diff (581 Bytes)

···

--
Seb

2010/12/21 Fabio Telme <fabio@telme.sg>

Hi
I'm still having strange problems on the Jingle calls, the calls works on
and off, i use always the same environment, 2 or 3 box behind NAT, the
calls some time works and many times gives "Call ended by remote party
Reason : the call ICE Failed-Application" What i don' understand is why on
the same network environment with interval of few seconds one call is ok and
one is in error and so for dozen of calls. In attach the complete log
folder.

Thanks for the help.

Regards
Fabio

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#3

Hi Sebastian,

Thanks very much for the patch i will try immediatly.
Are you going to apply this patch in the next nightly build ?

Thanks
Fabio

···

Il giorno 21/dic/2010, alle ore 22.42, Sebastien Vincent ha scritto:

Hi,

It seems that when peer receives session-accept, ICE processing is not completly finished and it fails after.

Please try attached patch that will wait ICE processing to be finished before process session-accept.

Regards,
--
Seb

2010/12/21 Fabio Telme <fabio@telme.sg>
Hi
I'm still having strange problems on the Jingle calls, the calls works on and off, i use always the same environment, 2 or 3 box behind NAT, the calls some time works and many times gives "Call ended by remote party Reason : the call ICE Failed-Application" What i don' understand is why on the same network environment with interval of few seconds one call is ok and one is in error and so for dozen of calls. In attach the complete log folder.

Thanks for the help.

Regards
Fabio

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

<sc-patch.diff>---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#4

Hi Fabio,

···

2010/12/21 Fabio Telme <fabio@telme.sg>

Hi Sebastian,

Thanks very much for the patch i will try immediatly.
Are you going to apply this patch in the next nightly build ?

I have not tested a lot yesterday night when I made the patch however I
don't think the changes will introduce problem. Just tell me if you still
have "ICE failed" on Jingle calls with this patch.

Regards,
--
Seb

Thanks
Fabio

Il giorno 21/dic/2010, alle ore 22.42, Sebastien Vincent ha scritto:

Hi,

It seems that when peer receives session-accept, ICE processing is not
completly finished and it fails after.

Please try attached patch that will wait ICE processing to be finished
before process session-accept.

Regards,
--
Seb

2010/12/21 Fabio Telme <fabio@telme.sg>

Hi
I'm still having strange problems on the Jingle calls, the calls works on
and off, i use always the same environment, 2 or 3 box behind NAT, the
calls some time works and many times gives "Call ended by remote party
Reason : the call ICE Failed-Application" What i don' understand is why on
the same network environment with interval of few seconds one call is ok and
one is in error and so for dozen of calls. In attach the complete log
folder.

Thanks for the help.

Regards
Fabio

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

<sc-patch.diff>
---------------------------------------------------------------------

To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#5

Hi Seb

I made some tests and it improved a lot, on some calls i'm still have that error but now only when i'm on a double Nat , so i will investigate more if it is the same problem.
Anyway i think this patch is very useful to make ICE more stable, and should be submitted for next build.

Regards
Fabio

···

Il giorno 22/dic/2010, alle ore 07.29, Sebastien Vincent ha scritto:

Hi Fabio,

2010/12/21 Fabio Telme <fabio@telme.sg>
Hi Sebastian,

Thanks very much for the patch i will try immediatly.
Are you going to apply this patch in the next nightly build ?

I have not tested a lot yesterday night when I made the patch however I don't think the changes will introduce problem. Just tell me if you still have "ICE failed" on Jingle calls with this patch.

Regards,
--
Seb

Thanks
Fabio

Il giorno 21/dic/2010, alle ore 22.42, Sebastien Vincent ha scritto:

Hi,

It seems that when peer receives session-accept, ICE processing is not completly finished and it fails after.

Please try attached patch that will wait ICE processing to be finished before process session-accept.

Regards,
--
Seb

2010/12/21 Fabio Telme <fabio@telme.sg>
Hi
I'm still having strange problems on the Jingle calls, the calls works on and off, i use always the same environment, 2 or 3 box behind NAT, the calls some time works and many times gives "Call ended by remote party Reason : the call ICE Failed-Application" What i don' understand is why on the same network environment with interval of few seconds one call is ok and one is in error and so for dozen of calls. In attach the complete log folder.

Thanks for the help.

Regards
Fabio

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

<sc-patch.diff>---------------------------------------------------------------------

To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net