[sip-comm-dev] Jabber : upgrading to the latest smack libs available


#1

Hi all,

I am trying to upgrade to the latest smack lib (3.0.4). There are little change to their API,
in the jingle API. As I runned jabber junit tests succesfully, I think that other parts of SC
which use the lib will not be impacted.

    Sympho.

···

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#2

Hey Sympho,

Just a thought, did you retroweave it before committing? If I remember
correctly, smack requires 1.5 and for the time being we are still 1.4.
It shouldn't take you long.

Emil

Sympho wrote:

···

Hi all,

I am trying to upgrade to the latest smack lib (3.0.4). There are little
change to their API,
in the jingle API. As I runned jabber junit tests succesfully, I think
that other parts of SC
which use the lib will not be impacted.

    Sympho.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#3

Emil Ivov a �crit :

Hey Sympho,

Just a thought, did you retroweave it before committing? If I remember
correctly, smack requires 1.5 and for the time being we are still 1.4.
It shouldn't take you long.

Thanks for the recall, it should now be ok.

    Sympho

···

Emil

Sympho wrote:
  

Hi all,

I am trying to upgrade to the latest smack lib (3.0.4). There are little change to their API,
in the jingle API. As I runned jabber junit tests succesfully, I think that other parts of SC
which use the lib will not be impacted.

    Sympho.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#4

Hi,

Is anybody using Eclipse for developing sip communicator ?

Has anybody used the subversive plugin for downloading the sip communicator source code ?

Thanks

Charlie

···

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#5

Hi Charlie,

I'm sure that a lot of people here are using Eclipse for developing on SC. I don't know much about subversive but you can find a very complete tutorial on how setup Eclipse for retrieving the SC sources here :

http://www.sip-communicator.org/index.php/Documentation/ConfigureEclipseNew

The tutorial isn't using subversive but Subclipse which is a very good plugin too.

Hope this helps,
Ben

Charlie Kelly a �crit :

···

Hi,

Is anybody using Eclipse for developing sip communicator ?

Has anybody used the subversive plugin for downloading the sip communicator source code ?

Thanks

Charlie

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#6

Hi Charlie,

Thomas pointed you an url where you have _documentation_ on how to get
the source wirh subversion :

http://www.sip-communicator.org/index.php/Development/VersionControl

The *source url* itself is :

https://sip-communicator.dev.java.net/svn/sip-communicator/trunk

Many are using eclipse. If you can't get the source with the plugin,
you can always use a standalone svn client.

Cheers.

···

Hi,

Is anybody using Eclipse for developing sip communicator ?

Has anybody used the subversive plugin for downloading the sip communicator source code ?

Thanks

Charlie

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#7

Hi Ben,

Thanks. I think this is what I have been looking for.

Charlie

Benoit Pradelle wrote:

···

Hi Charlie,

I'm sure that a lot of people here are using Eclipse for developing on SC. I don't know much about subversive but you can find a very complete tutorial on how setup Eclipse for retrieving the SC sources here :

http://www.sip-communicator.org/index.php/Documentation/ConfigureEclipseNew

The tutorial isn't using subversive but Subclipse which is a very good plugin too.

Hope this helps,
Ben

Charlie Kelly a �crit :

Hi,

Is anybody using Eclipse for developing sip communicator ?

Has anybody used the subversive plugin for downloading the sip communicator source code ?

Thanks

Charlie

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#8

Hi Sympho,

I tried that yesterday, but it didn't work.
I'll try the tutorial in the posting by Ben.

Thanks

Charlie

Sympho wrote:

···

Hi Charlie,

Thomas pointed you an url where you have _documentation_ on how to get
the source wirh subversion :

http://www.sip-communicator.org/index.php/Development/VersionControl

The *source url* itself is :

>https://sip-communicator.dev.java.net/svn/sip-communicator/trunk

Many are using eclipse. If you can't get the source with the plugin,
you can always use a standalone svn client.

Cheers.
>

Hi,

Is anybody using Eclipse for developing sip communicator ?

Has anybody used the subversive plugin for downloading the sip communicator source code ?

Thanks

Charlie

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#9

Hi,

I've downloaded the source code into Eclipse and used ANT to rebuild and compile it.
This works fine.

Now I am trying to run the program.

I'm trying to follow the instructions from: http://www.sip-communicator.org/index.php/Documentation/ConfigureEclipseNew

    Setting up Eclipse for SIP Communicator

    * Copy the files *.project* and *.classpath* from
      PROJECT_DIR/ide/eclipse to PROJECT_DIR
    * Right button click on the project in the Package explorer and
      select /Refresh/.
    * Done.

The problem is that the .classpath and .project files are not in this directory.

My question: where can I find the .classpath and .project files ?

Thanks

Charlie

···

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#10

Hi Charlie,

Charlie Kelly a �crit :

Hi,

I've downloaded the source code into Eclipse and used ANT to rebuild and compile it.
This works fine.

Now I am trying to run the program.

I'm trying to follow the instructions from: http://www.sip-communicator.org/index.php/Documentation/ConfigureEclipseNew

   Setting up Eclipse for SIP Communicator

   * Copy the files *.project* and *.classpath* from
     PROJECT_DIR/ide/eclipse to PROJECT_DIR
   * Right button click on the project in the Package explorer and
     select /Refresh/.
   * Done.

The problem is that the .classpath and .project files are not in this directory.

You should have these files as you have downloaded the source, but, if not, go here
.classpath:
    https://sip-communicator.dev.java.net/source/browse/sip-communicator/trunk/ide/eclipse/.classpath?rev=2921&view=markup
.project:
    https://sip-communicator.dev.java.net/source/browse/sip-communicator/trunk/ide/eclipse/.project?rev=2016&view=markup

and click to the "download" link for each file, save them in your project folder (if you have a directory named "trunk" it should be that one)

you can also found instructions here
    https://sip-communicator.dev.java.net/source/browse/sip-communicator/trunk/ide/eclipse/README?rev=9&view=markup

good luck :slight_smile:

    Sympho

···

My question: where can I find the .classpath and .project files ?

Thanks

Charlie

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net