[sip-comm-dev] incorrect charset for French translation


#1

Hey all,

Isn't the french translation resource file in an incorrect charset ? Stop me if I'm wrong but I think that this file should be in UTF-8 and is currently in the ISO-something format ?
Should we correct it or is it a problem related to my OS configured in UTF-8 ?

Ben

···

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#2

Hi Benoit,

In my local copy of the repository, the file is currently encode in UTF-8 (Does your favorite editor tells you that the file is UTF-8?), but SC execution (with "ant run") does not manage to display it correctly.

Hope this help,
Vincent

Benoit Pradelle wrote:

···

Hey all,

Isn't the french translation resource file in an incorrect charset ? Stop me if I'm wrong but I think that this file should be in UTF-8 and is currently in the ISO-something format ?
Should we correct it or is it a problem related to my OS configured in UTF-8 ?

Ben

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#3

Hi all!

I've just had a look at it. The location of the translation properties files
in the project was changed recently. Unfortunately, we forgot to change the
native2ascii task in the build.xml, which converts the properties files from
UTF-8 to the ISO-8859-1 with escapes which Java internally uses. Therefore,
non-ASCII characters don't display correctly.

If noone else has time, I can fix it. I haven't had a look at the new
properties layout yet, so it might better be done by someone else.

Cheers
Michael Koch

···

Hi Benoit,

In my local copy of the repository, the file is currently encode in
UTF-8 (Does your favorite editor tells you that the file is
UTF-8?), but
SC execution (with "ant run") does not manage to display it correctly.

Hope this help,
Vincent

Benoit Pradelle wrote:
> Hey all,
>
> Isn't the french translation resource file in an incorrect
charset ?
> Stop me if I'm wrong but I think that this file should be
in UTF-8 and
> is currently in the ISO-something format ?
> Should we correct it or is it a problem related to my OS
configured in
> UTF-8 ?
>
> Ben
>
>
>
---------------------------------------------------------------------
> To unsubscribe, e-mail:
dev-unsubscribe@sip-communicator.dev.java.net
> For additional commands, e-mail:
dev-help@sip-communicator.dev.java.net
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail:
dev-help@sip-communicator.dev.java.net


#4

Hi all,

Sorry, it's my fault:( I have moved the files and have forgotten to change the task. Will take care of this!

Cheers,
Yana

Koch Michael wrote:

···

Hi all!

I've just had a look at it. The location of the translation properties files
in the project was changed recently. Unfortunately, we forgot to change the
native2ascii task in the build.xml, which converts the properties files from
UTF-8 to the ISO-8859-1 with escapes which Java internally uses. Therefore,
non-ASCII characters don't display correctly.

If noone else has time, I can fix it. I haven't had a look at the new
properties layout yet, so it might better be done by someone else.

Cheers
Michael Koch

Hi Benoit,

In my local copy of the repository, the file is currently encode in UTF-8 (Does your favorite editor tells you that the file is UTF-8?), but SC execution (with "ant run") does not manage to display it correctly.

Hope this help,
Vincent

Benoit Pradelle wrote:

Hey all,

Isn't the french translation resource file in an incorrect

charset ?

Stop me if I'm wrong but I think that this file should be

in UTF-8 and

is currently in the ISO-something format ?
Should we correct it or is it a problem related to my OS

configured in

UTF-8 ?

Ben

---------------------------------------------------------------------

To unsubscribe, e-mail:

dev-unsubscribe@sip-communicator.dev.java.net

For additional commands, e-mail:

dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#5

Hey guys,

I have committed a fix. Let me know it it's working for you.

Cheers,
Yana

Yana Stamcheva wrote:

···

Hi all,

Sorry, it's my fault:( I have moved the files and have forgotten to change the task. Will take care of this!

Cheers,
Yana

Koch Michael wrote:

Hi all!

I've just had a look at it. The location of the translation properties files
in the project was changed recently. Unfortunately, we forgot to change the
native2ascii task in the build.xml, which converts the properties files from
UTF-8 to the ISO-8859-1 with escapes which Java internally uses. Therefore,
non-ASCII characters don't display correctly.

If noone else has time, I can fix it. I haven't had a look at the new
properties layout yet, so it might better be done by someone else.

Cheers
Michael Koch

Hi Benoit,

In my local copy of the repository, the file is currently encode in UTF-8 (Does your favorite editor tells you that the file is UTF-8?), but SC execution (with "ant run") does not manage to display it correctly.

Hope this help,
Vincent

Benoit Pradelle wrote:

Hey all,

Isn't the french translation resource file in an incorrect

charset ?

Stop me if I'm wrong but I think that this file should be

in UTF-8 and

is currently in the ISO-something format ?
Should we correct it or is it a problem related to my OS

configured in

UTF-8 ?

Ben

---------------------------------------------------------------------

To unsubscribe, e-mail:

dev-unsubscribe@sip-communicator.dev.java.net

For additional commands, e-mail:

dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#6

Sorry, but the problem is still there :frowning:

Vincent

Yana Stamcheva wrote:

···

Hey guys,

I have committed a fix. Let me know it it's working for you.

Cheers,
Yana

Yana Stamcheva wrote:

Hi all,

Sorry, it's my fault:( I have moved the files and have forgotten to change the task. Will take care of this!

Cheers,
Yana

Koch Michael wrote:

Hi all!

I've just had a look at it. The location of the translation properties files
in the project was changed recently. Unfortunately, we forgot to change the
native2ascii task in the build.xml, which converts the properties files from
UTF-8 to the ISO-8859-1 with escapes which Java internally uses. Therefore,
non-ASCII characters don't display correctly.

If noone else has time, I can fix it. I haven't had a look at the new
properties layout yet, so it might better be done by someone else.

Cheers
Michael Koch

Hi Benoit,

In my local copy of the repository, the file is currently encode in UTF-8 (Does your favorite editor tells you that the file is UTF-8?), but SC execution (with "ant run") does not manage to display it correctly.

Hope this help,
Vincent

Benoit Pradelle wrote:

Hey all,

Isn't the french translation resource file in an incorrect

charset ?

Stop me if I'm wrong but I think that this file should be

in UTF-8 and

is currently in the ISO-something format ?
Should we correct it or is it a problem related to my OS

configured in

UTF-8 ?

Ben

---------------------------------------------------------------------

To unsubscribe, e-mail:

dev-unsubscribe@sip-communicator.dev.java.net

For additional commands, e-mail:

dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#7

Hey Yana,

I'm sorry but even with the latest build.xml (rev 3485), it's still not working for me.

Ben

Yana Stamcheva a �crit :

···

Hey guys,

I have committed a fix. Let me know it it's working for you.

Cheers,
Yana

Yana Stamcheva wrote:

Hi all,

Sorry, it's my fault:( I have moved the files and have forgotten to change the task. Will take care of this!

Cheers,
Yana

Koch Michael wrote:

Hi all!

I've just had a look at it. The location of the translation properties files
in the project was changed recently. Unfortunately, we forgot to change the
native2ascii task in the build.xml, which converts the properties files from
UTF-8 to the ISO-8859-1 with escapes which Java internally uses. Therefore,
non-ASCII characters don't display correctly.

If noone else has time, I can fix it. I haven't had a look at the new
properties layout yet, so it might better be done by someone else.

Cheers
Michael Koch

Hi Benoit,

In my local copy of the repository, the file is currently encode in UTF-8 (Does your favorite editor tells you that the file is UTF-8?), but SC execution (with "ant run") does not manage to display it correctly.

Hope this help,
Vincent

Benoit Pradelle wrote:

Hey all,

Isn't the french translation resource file in an incorrect

charset ?

Stop me if I'm wrong but I think that this file should be

in UTF-8 and

is currently in the ISO-something format ?
Should we correct it or is it a problem related to my OS

configured in

UTF-8 ?

Ben

---------------------------------------------------------------------

To unsubscribe, e-mail:

dev-unsubscribe@sip-communicator.dev.java.net

For additional commands, e-mail:

dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#8

Hi Vincent,

it's just that we have no successful build, which contains the modifications:( We're working on the problem now.

Yana

Vincent Lucas wrote:

···

Sorry, but the problem is still there :frowning:

Vincent

Yana Stamcheva wrote:

Hey guys,

I have committed a fix. Let me know it it's working for you.

Cheers,
Yana

Yana Stamcheva wrote:

Hi all,

Sorry, it's my fault:( I have moved the files and have forgotten to change the task. Will take care of this!

Cheers,
Yana

Koch Michael wrote:

Hi all!

I've just had a look at it. The location of the translation properties files
in the project was changed recently. Unfortunately, we forgot to change the
native2ascii task in the build.xml, which converts the properties files from
UTF-8 to the ISO-8859-1 with escapes which Java internally uses. Therefore,
non-ASCII characters don't display correctly.

If noone else has time, I can fix it. I haven't had a look at the new
properties layout yet, so it might better be done by someone else.

Cheers
Michael Koch

Hi Benoit,

In my local copy of the repository, the file is currently encode in UTF-8 (Does your favorite editor tells you that the file is UTF-8?), but SC execution (with "ant run") does not manage to display it correctly.

Hope this help,
Vincent

Benoit Pradelle wrote:

Hey all,

Isn't the french translation resource file in an incorrect

charset ?

Stop me if I'm wrong but I think that this file should be

in UTF-8 and

is currently in the ISO-something format ?
Should we correct it or is it a problem related to my OS

configured in

UTF-8 ?

Ben

---------------------------------------------------------------------

To unsubscribe, e-mail:

dev-unsubscribe@sip-communicator.dev.java.net

For additional commands, e-mail:

dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#9

Hi all!

I've fixed the fix :slight_smile: The French translation (and the others too) should
work now. You can try by running SIP Communicator with "ant
-Duser.language=fr run".

The "native2ascii" ant task was ignoring the translation properties files
because the "resources" task had already copied them to the target directory
(without changing the encoding).

Cheers
Michael Koch

···

Hey Yana,

I'm sorry but even with the latest build.xml (rev 3485), it's
still not
working for me.

Ben

Yana Stamcheva a écrit :
> Hey guys,
>
> I have committed a fix. Let me know it it's working for you.
>
> Cheers,
> Yana
>
> Yana Stamcheva wrote:
>> Hi all,
>>
>> Sorry, it's my fault:( I have moved the files and have
forgotten to
>> change the task. Will take care of this!
>>
>> Cheers,
>> Yana
>>
>> Koch Michael wrote:
>>> Hi all!
>>>
>>> I've just had a look at it. The location of the translation
>>> properties files
>>> in the project was changed recently. Unfortunately, we forgot to
>>> change the
>>> native2ascii task in the build.xml, which converts the properties
>>> files from
>>> UTF-8 to the ISO-8859-1 with escapes which Java internally uses.
>>> Therefore,
>>> non-ASCII characters don't display correctly.
>>>
>>> If noone else has time, I can fix it. I haven't had a
look at the new
>>> properties layout yet, so it might better be done by someone else.
>>>
>>> Cheers
>>> Michael Koch
>>>
>>>> Hi Benoit,
>>>>
>>>> In my local copy of the repository, the file is
currently encode in
>>>> UTF-8 (Does your favorite editor tells you that the file is
>>>> UTF-8?), but SC execution (with "ant run") does not manage to
>>>> display it correctly.
>>>>
>>>> Hope this help,
>>>> Vincent
>>>>
>>>> Benoit Pradelle wrote:
>>>>> Hey all,
>>>>>
>>>>> Isn't the french translation resource file in an incorrect
>>>> charset ?
>>>>> Stop me if I'm wrong but I think that this file should be
>>>> in UTF-8 and
>>>>> is currently in the ISO-something format ?
>>>>> Should we correct it or is it a problem related to my OS
>>>> configured in
>>>>> UTF-8 ?
>>>>>
>>>>> Ben


#10

Hi Michael,

I confirm your fix fixes the fix :slight_smile:

Cheers,
Vincent

Koch Michael wrote:

···

Hi all!

I've fixed the fix :slight_smile: The French translation (and the others too) should
work now. You can try by running SIP Communicator with "ant
-Duser.language=fr run".

The "native2ascii" ant task was ignoring the translation properties files
because the "resources" task had already copied them to the target directory
(without changing the encoding).

Cheers
Michael Koch

Hey Yana,

I'm sorry but even with the latest build.xml (rev 3485), it's still not working for me.

Ben

Yana Stamcheva a �crit :

Hey guys,

I have committed a fix. Let me know it it's working for you.

Cheers,
Yana

Yana Stamcheva wrote:

Hi all,

Sorry, it's my fault:( I have moved the files and have

forgotten to

change the task. Will take care of this!

Cheers,
Yana

Koch Michael wrote:

Hi all!

I've just had a look at it. The location of the translation properties files
in the project was changed recently. Unfortunately, we forgot to change the
native2ascii task in the build.xml, which converts the properties files from
UTF-8 to the ISO-8859-1 with escapes which Java internally uses. Therefore,
non-ASCII characters don't display correctly.

If noone else has time, I can fix it. I haven't had a

look at the new

properties layout yet, so it might better be done by someone else.

Cheers
Michael Koch

Hi Benoit,

In my local copy of the repository, the file is

currently encode in

UTF-8 (Does your favorite editor tells you that the file is UTF-8?), but SC execution (with "ant run") does not manage to display it correctly.

Hope this help,
Vincent

Benoit Pradelle wrote:

Hey all,

Isn't the french translation resource file in an incorrect

charset ?

Stop me if I'm wrong but I think that this file should be

in UTF-8 and

is currently in the ISO-something format ?
Should we correct it or is it a problem related to my OS

configured in

UTF-8 ?

Ben

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#11

Hey Michael,

Great:) Thanks!

Actually I was thinking that it will overwrite the files:(

Cheers,
Yana

Koch Michael wrote:

···

Hi all!

I've fixed the fix :slight_smile: The French translation (and the others too) should
work now. You can try by running SIP Communicator with "ant
-Duser.language=fr run".

The "native2ascii" ant task was ignoring the translation properties files
because the "resources" task had already copied them to the target directory
(without changing the encoding).

Cheers
Michael Koch

Hey Yana,

I'm sorry but even with the latest build.xml (rev 3485), it's still not working for me.

Ben

Yana Stamcheva a �crit :

Hey guys,

I have committed a fix. Let me know it it's working for you.

Cheers,
Yana

Yana Stamcheva wrote:

Hi all,

Sorry, it's my fault:( I have moved the files and have

forgotten to

change the task. Will take care of this!

Cheers,
Yana

Koch Michael wrote:

Hi all!

I've just had a look at it. The location of the translation properties files
in the project was changed recently. Unfortunately, we forgot to change the
native2ascii task in the build.xml, which converts the properties files from
UTF-8 to the ISO-8859-1 with escapes which Java internally uses. Therefore,
non-ASCII characters don't display correctly.

If noone else has time, I can fix it. I haven't had a

look at the new

properties layout yet, so it might better be done by someone else.

Cheers
Michael Koch

Hi Benoit,

In my local copy of the repository, the file is

currently encode in

UTF-8 (Does your favorite editor tells you that the file is UTF-8?), but SC execution (with "ant run") does not manage to display it correctly.

Hope this help,
Vincent

Benoit Pradelle wrote:

Hey all,

Isn't the french translation resource file in an incorrect

charset ?

Stop me if I'm wrong but I think that this file should be

in UTF-8 and

is currently in the ISO-something format ?
Should we correct it or is it a problem related to my OS

configured in

UTF-8 ?

Ben

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net