[sip-comm-dev] help needed to configure eclipse


#1

hi,
Im prasad and im interested in working on Sip communicator project. im
currrently trying to get the sourse code in eclipse but i find it a little
difficult.
http://www.sip-communicator.org/index.php/Documentation/ConfigureEclipseNewIn
this tutorial it says to set the evnvironment variables.

"In the "Environment" tab of the configuration add a new variable called
path and let it point to the system path and additionally to the library
path for your system. For Windows this is

   - *%path%;./lib/native/windows. *

"
Im working on kubuntu so im not sure how to set the EVs . when i run
configurations for "Debug SipCommunicator" an error occurs saying "launch
configuration Debug SipCommunicator referances non existing project
sip-communicator". Can anybody please help me with this.
thanks in advance,
PJ


#2

Hey PJ,

I hope some of the other developers will be able to step up and answer
your question.

In the meantime, I think that debugging isn't a must at this point and
your could just explore the source with Eclipse and run the
application in your terminal using Ant and the rebuild/make and run
targets. Please let me know if this works for you before your question
is answered.

Regards,
Lubo

···

On Sat, Mar 21, 2009 at 8:44 AM, Prasad Jeewantha <jeewamp@gmail.com> wrote:

hi,
Im prasad and im interested in working on Sip communicator project. im
currrently trying to get the sourse code in eclipse but i find it a little
difficult.
http://www.sip-communicator.org/index.php/Documentation/ConfigureEclipseNew
In this tutorial it says to set the evnvironment variables.

"In the "Environment" tab of the configuration add a new variable called
path and let it point to the system path and additionally to the library
path for your system. For Windows this is

%path%;./lib/native/windows.

"
Im working on kubuntu so im not sure how to set the EVs . when i run
configurations for "Debug SipCommunicator" an error occurs saying "launch
configuration Debug SipCommunicator referances non existing project
sip-communicator". Can anybody please help me with this.
thanks in advance,
PJ

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#3

Hi Prasad, Lubo, all,

If you have difficulties to set up you environment variables, perhaps
you should try to run SC using ant. If you still want to setup your
path environment variable, on kubuntu, it should be something like
%path%;./lib/native/linux.

Cheers,

Ben

···

On Sat, Mar 21, 2009 at 12:39, Lubomir Marinov <lubomir.marinov@gmail.com> wrote:

Hey PJ,

I hope some of the other developers will be able to step up and answer
your question.

In the meantime, I think that debugging isn't a must at this point and
your could just explore the source with Eclipse and run the
application in your terminal using Ant and the rebuild/make and run
targets. Please let me know if this works for you before your question
is answered.

Regards,
Lubo

On Sat, Mar 21, 2009 at 8:44 AM, Prasad Jeewantha <jeewamp@gmail.com> wrote:

hi,
Im prasad and im interested in working on Sip communicator project. im
currrently trying to get the sourse code in eclipse but i find it a little
difficult.
http://www.sip-communicator.org/index.php/Documentation/ConfigureEclipseNew
In this tutorial it says to set the evnvironment variables.

"In the "Environment" tab of the configuration add a new variable called
path and let it point to the system path and additionally to the library
path for your system. For Windows this is

%path%;./lib/native/windows.

"
Im working on kubuntu so im not sure how to set the EVs . when i run
configurations for "Debug SipCommunicator" an error occurs saying "launch
configuration Debug SipCommunicator referances non existing project
sip-communicator". Can anybody please help me with this.
thanks in advance,
PJ

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#4

Hi Prasad,

Am using ubuntu over here. Kindly ignore the enviornment tab option. I just
followed all the steps given in detail with screenshots. I could build it
successfully. And able to run the sip-communicator application.

Dont forget to clean, rebuild and then run it ( Run Configuration ).

regarding setting environment variables in ubuntu/kubuntu
env- for all environmental variables
to set it : add the line
export <EV_name>=<PATH>
to home/user/.bashrc

thats it.

For running SIP-COMMUNICATOR on eclipse - i think there shud be no need.

Even am a newbie to sip-communicator, Expect some developers out here to
correct me in case of any issues.

Cheers,
Arun Reddy

···

2009/3/21 Lubomir Marinov <lubomir.marinov@gmail.com>

Hey PJ,

I hope some of the other developers will be able to step up and answer
your question.

In the meantime, I think that debugging isn't a must at this point and
your could just explore the source with Eclipse and run the
application in your terminal using Ant and the rebuild/make and run
targets. Please let me know if this works for you before your question
is answered.

Regards,
Lubo

On Sat, Mar 21, 2009 at 8:44 AM, Prasad Jeewantha <jeewamp@gmail.com> > wrote:
> hi,
> Im prasad and im interested in working on Sip communicator project. im
> currrently trying to get the sourse code in eclipse but i find it a
little
> difficult.
>
http://www.sip-communicator.org/index.php/Documentation/ConfigureEclipseNew
> In this tutorial it says to set the evnvironment variables.
>
> "In the "Environment" tab of the configuration add a new variable called
> path and let it point to the system path and additionally to the library
> path for your system. For Windows this is
>
> %path%;./lib/native/windows.
>
> "
> Im working on kubuntu so im not sure how to set the EVs . when i run
> configurations for "Debug SipCommunicator" an error occurs saying "launch
> configuration Debug SipCommunicator referances non existing project
> sip-communicator". Can anybody please help me with this.
> thanks in advance,
> PJ

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

--
Best Regards,
Arun Reddy


#5

Hi all,
Thank you so much for your kind concern :). I managed to build SC but i
still cant run the application even after cleaning and rebuilding. When i
run it within the IDE(ANT window) it says buid successful. but i cant see
the application running. how can I run it in my terminal? thanks again :slight_smile:
cheers
pj


#6

hi all,
i finally managed to get sc working. I really appreciate all your help.
thank you so much.. :slight_smile:
cheers,
pj