[sip-comm-dev] FMJ and Java 1.5 - comments?


#1

Wayne Meissner, who works on gstreamer-java and JNA, asked me if JNA moving to Java 1.5 would cause problems for FMJ.

I personally find it limiting to always use 1.4, and although most of FMJ will compile/run without 1.5, there are a few corners which still require it.

In particular, lti-civil (used for video capture) and ffmpeg-java (used for wrapping ffmpeg) are using 1.5. Certainly their source code could be changed to remove generics and such if it were absolutely needed. However, I find that once you start using generics and see how it improves the code readability and quality, it is hard to go back.

I have told Wayne that I don't mind if JNA requires 1.5, but I thought I should solicit broader opinions on this, both from the FMJ and the SC teams.

I seem to recall that SC uses 1.4 as its standard, but I don't have any real info on that.

Ken

···

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#2

Hello Ken,

We are indeed trying to stick to 1.4 for the time being though we are
successfully using several 1.5 libs with retroweaver.

People have been asking for 1.5 for some time now and we are probably
going to move soon (we also want to use generics! :slight_smile: ). The reasons why
we have not already done so include:

1. I've been hearing that there are problems with 1.5 and JavaSound on
windows. I haven't experienced them personally, but then again, I
haven't been doing a lot of testing on 1.5. I imagine you have done so
so I'd be interested to hear your thoughts. These problems are supposed
to have been fixed with 1.6.

2. There is no 1.5 compliant J2ME version. The latest CDC is 1.4
compatible. That said, porting SIP Communicator to CDC would probably
require substantial modifications anyway so having to remove generics
here and there and/or retroweave several bundles would probably not that
big of a deal (and besides I am not really aware of anyone working in
this direction)

So, in other words, I don't think that 1.5 is a problem!

Cheers
Emil

Ken Larson wrote:

···

Wayne Meissner, who works on gstreamer-java and JNA, asked me if JNA
moving to Java 1.5 would cause problems for FMJ.

I personally find it limiting to always use 1.4, and although most of
FMJ will compile/run without 1.5, there are a few corners which still
require it.

In particular, lti-civil (used for video capture) and ffmpeg-java (used
for wrapping ffmpeg) are using 1.5. Certainly their source code could
be changed to remove generics and such if it were absolutely needed.
However, I find that once you start using generics and see how it
improves the code readability and quality, it is hard to go back.

I have told Wayne that I don't mind if JNA requires 1.5, but I thought I
should solicit broader opinions on this, both from the FMJ and the SC teams.

I seem to recall that SC uses 1.4 as its standard, but I don't have any
real info on that.

Ken

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net