[sip-comm-dev] Eclipse Configuration - PATH


#1

Hi,

Fallowing the tutorial

http://www.sip-communicator.org/index.php/Documentation/ConfigureEclipseNew

I have tried to configure eclipse (Eclipse Version 3.3.1.1, Windows XP ),
everything work fine, only I can't get the systray icon :(.

I have create a variable named "path" with the value : *
%path%;./lib/native/windows*

like the exemple show :

http://www.sip-communicator.org/wiki/pub/uploads/Documentation/eclipseProjectConfiguration3.png

09:09:51.125 SEVERE: impl.systray.jdic.SystrayServiceJdicImpl.<init>().107
Failed to create a systray!java.lang.UnsatisfiedLinkError: ....

When I use the ANT -> build.xml everything is OK.

The problem is the same when I use Ubuntu or Windows XP, and try to
Configure, Run and Debug sip communicator through Eclipse

Any help please.

Thanks

Cheers

PS: Excuse for my English.

···

--
Daniel VELJJANOSKI


#2

Hi!

The configuration guide is exemplary for windows. On linux the path variable
has to point into the linux sub directory.

In which directory are you running SC? In the working directory as shown in
http://www.sip-communicator.org/wiki/pub/uploads/Documentation/eclipseProjec
tConfiguration2.png ?

You you find the dlls in the lib/native/windows directory?

···

Von: Daniel Veljjanoski [mailto:danielveljanoski@gmail.com]
Gesendet: Dienstag, 10. Juni 2008 09:30
An: dev@sip-communicator.dev.java.net
Betreff: [sip-comm-dev] Eclipse Configuration - PATH

Hi,

Fallowing the tutorial

http://www.sip-communicator.org/index.php/Documentation/ConfigureEclipseNew

I have tried to configure eclipse (Eclipse Version 3.3.1.1, Windows XP ),
everything work fine, only I can't get the systray icon :(.

I have create a variable named "path" with the value :
%path%;./lib/native/windows

like the exemple show :

http://www.sip-communicator.org/wiki/pub/uploads/Documentation/eclipseProjec
tConfiguration3.png

09:09:51.125 SEVERE: impl.systray.jdic.SystrayServiceJdicImpl.<init>().107
Failed to create a systray!java.lang.UnsatisfiedLinkError: ....

When I use the ANT -> build.xml everything is OK.

The problem is the same when I use Ubuntu or Windows XP, and try to
Configure, Run and Debug sip communicator through Eclipse

Any help please.

Thanks

Cheers

PS: Excuse for my English.

--
Daniel VELJJANOSKI


#3

Hey Thomas,

Thanks for your answer.

I know that the configuration guide is for windows, and I am trying to
Configure, Run and Debug sip communicator through Eclipse Version
3.3.1.1(Windows XP).

Re: Yes I find the dlls in the lib/native/windows.

<....>\sip-communicator\lib\native\windows>dir

Directory of <....>\\sip-communicator\lib\native\windows

23/05/2008 09:34 AM <DIR> .
23/05/2008 09:34 AM <DIR> ..
04/06/2008 01:30 PM 61,440 IeEmbed.exe
04/06/2008 01:30 PM 110,592 jdic.dll
04/06/2008 01:30 PM 53,248 jdic_misc.dll
04/06/2008 01:30 PM 49,152 jmacm.dll
04/06/2008 01:30 PM 53,248 jmam.dll
04/06/2008 01:30 PM 49,152 jmcvid.dll
04/06/2008 01:30 PM 40,960 jmdaud.dll
04/06/2008 01:30 PM 28,672 jmdaudc.dll
04/06/2008 01:30 PM 32,768 jmddraw.dll
04/06/2008 01:30 PM 32,768 jmfjawt.dll
04/06/2008 01:30 PM 98,304 jmg723.dll
04/06/2008 01:30 PM 36,864 jmgdi.dll
04/06/2008 01:30 PM 57,344 jmgsm.dll
04/06/2008 01:30 PM 282,624 jmh261.dll
04/06/2008 01:30 PM 106,496 jmh263enc.dll
04/06/2008 01:30 PM 143,360 jmjpeg.dll
04/06/2008 01:30 PM 28,672 jmmci.dll
04/06/2008 01:30 PM 380,928 jmmpa.dll
04/06/2008 01:30 PM 77,824 jmmpegv.dll
04/06/2008 01:30 PM 73,728 jmutil.dll
04/06/2008 01:30 PM 36,864 jmvcm.dll
04/06/2008 01:30 PM 45,056 jmvfw.dll
04/06/2008 01:30 PM 184,320 jmvh263.dll
04/06/2008 01:30 PM 413,696 jsound.dll
04/06/2008 01:30 PM 192,512 MozEmbed.exe
04/06/2008 01:30 PM 1,154,250 soundbank.gm
04/06/2008 01:30 PM 45,056 tray.dll
              27 File(s) 3,869,898 bytes
               2 Dir(s) 290,590,216,192 bytes free

Using : -Djava.library.path=lib\native\windows as VM Argument

(https://sip-communicator.dev.java.net/servlets/ReadMsg?list=dev&msgNo=2525)

doesn't help :(.

Thanks

···

On Tue, Jun 10, 2008 at 9:40 AM, Thomas Hofer < mailinglisten@familie-hofer.net> wrote:

Hi!

The configuration guide is exemplary for windows. On linux the path
variable has to point into the linux sub directory.

In which directory are you running SC? In the working directory as shown in

http://www.sip-communicator.org/wiki/pub/uploads/Documentation/eclipseProjectConfiguration2.png?

You you find the dlls in the lib/native/windows directory?

*Von:* Daniel Veljjanoski [mailto:danielveljanoski@gmail.com]
*Gesendet:* Dienstag, 10. Juni 2008 09:30
*An:* dev@sip-communicator.dev.java.net
*Betreff:* [sip-comm-dev] Eclipse Configuration - PATH

Hi,

Fallowing the tutorial

http://www.sip-communicator.org/index.php/Documentation/ConfigureEclipseNew

I have tried to configure eclipse (Eclipse Version 3.3.1.1, Windows XP ),
everything work fine, only I can't get the systray icon :(.

I have create a variable named "path" with the value : *
%path%;./lib/native/windows*

like the exemple show :

http://www.sip-communicator.org/wiki/pub/uploads/Documentation/eclipseProjectConfiguration3.png

09:09:51.125 SEVERE: impl.systray.jdic.SystrayServiceJdicImpl.<init>().107
Failed to create a systray!java.lang.UnsatisfiedLinkError: ....

When I use the ANT -> build.xml everything is OK.

The problem is the same when I use Ubuntu or Windows XP, and try to
Configure, Run and Debug sip communicator through Eclipse

Any help please.

Thanks

Cheers

PS: Excuse for my English.

--
Daniel VELJJANOSKI

--
Daniel VELJJANOSKI


#4

Hi again,

Here is the problem given by eclipse :

09:56:12.093 SEVERE: impl.systray.jdic.SystrayServiceJdicImpl.<init>().107
Failed to create a systray!

java.lang.UnsatisfiedLinkError:
org.jdesktop.jdic.tray.internal.impl.GnomeSystemTrayService.initNative(Ljava/lang/String;)V

at org.jdesktop.jdic.tray.internal.impl.GnomeSystemTrayService.initNative(*Native
Method*)

at
org.jdesktop.jdic.tray.internal.impl.GnomeSystemTrayService.<clinit>(Unknown
Source)

at
org.jdesktop.jdic.tray.internal.impl.ServiceManagerStub.getService(Unknown
Source)

at org.jdesktop.jdic.tray.internal.ServiceManager.getService(Unknown Source)

at org.jdesktop.jdic.tray.SystemTray.<clinit>(Unknown Source)

at
net.java.sip.communicator.impl.systray.jdic.SystrayServiceJdicImpl.<init>(*
SystrayServiceJdicImpl.java:103*)

at net.java.sip.communicator.impl.systray.SystrayActivator.start(*
SystrayActivator.java:51*)

at org.apache.felix.framework.util.SecureAction.startActivator(*
SecureAction.java:589*)

at org.apache.felix.framework.Felix._startBundle(*Felix.java:1536*)

at org.apache.felix.framework.Felix.startBundle(*Felix.java:1470*)

at org.apache.felix.framework.Felix.setFrameworkStartLevel(*Felix.java:1065*
)

at org.apache.felix.framework.StartLevelImpl.run(*StartLevelImpl.java:258*)

at java.lang.Thread.run(*Thread.java:619*)

Like I have mentioned I am using Windows XP, but I can see in the exception
above GnomeSystemTrayService???

Cheers

···

On Tue, Jun 10, 2008 at 9:53 AM, Daniel Veljjanoski < danielveljanoski@gmail.com> wrote:

Hey Thomas,

Thanks for your answer.

I know that the configuration guide is for windows, and I am trying to
Configure, Run and Debug sip communicator through Eclipse Version 3.3.1.1(Windows XP).

Re: Yes I find the dlls in the lib/native/windows.

<....>\sip-communicator\lib\native\windows>dir

Directory of <....>\\sip-communicator\lib\native\windows

23/05/2008 09:34 AM <DIR> .
23/05/2008 09:34 AM <DIR> ..
04/06/2008 01:30 PM 61,440 IeEmbed.exe
04/06/2008 01:30 PM 110,592 jdic.dll
04/06/2008 01:30 PM 53,248 jdic_misc.dll
04/06/2008 01:30 PM 49,152 jmacm.dll
04/06/2008 01:30 PM 53,248 jmam.dll
04/06/2008 01:30 PM 49,152 jmcvid.dll
04/06/2008 01:30 PM 40,960 jmdaud.dll
04/06/2008 01:30 PM 28,672 jmdaudc.dll
04/06/2008 01:30 PM 32,768 jmddraw.dll
04/06/2008 01:30 PM 32,768 jmfjawt.dll
04/06/2008 01:30 PM 98,304 jmg723.dll
04/06/2008 01:30 PM 36,864 jmgdi.dll
04/06/2008 01:30 PM 57,344 jmgsm.dll
04/06/2008 01:30 PM 282,624 jmh261.dll
04/06/2008 01:30 PM 106,496 jmh263enc.dll
04/06/2008 01:30 PM 143,360 jmjpeg.dll
04/06/2008 01:30 PM 28,672 jmmci.dll
04/06/2008 01:30 PM 380,928 jmmpa.dll
04/06/2008 01:30 PM 77,824 jmmpegv.dll
04/06/2008 01:30 PM 73,728 jmutil.dll
04/06/2008 01:30 PM 36,864 jmvcm.dll
04/06/2008 01:30 PM 45,056 jmvfw.dll
04/06/2008 01:30 PM 184,320 jmvh263.dll
04/06/2008 01:30 PM 413,696 jsound.dll
04/06/2008 01:30 PM 192,512 MozEmbed.exe
04/06/2008 01:30 PM 1,154,250 soundbank.gm
04/06/2008 01:30 PM 45,056 tray.dll
              27 File(s) 3,869,898 bytes
               2 Dir(s) 290,590,216,192 bytes free

Using : -Djava.library.path=lib\native\windows as VM Argument

(
https://sip-communicator.dev.java.net/servlets/ReadMsg?list=dev&msgNo=2525
)

doesn't help :(.

Thanks

On Tue, Jun 10, 2008 at 9:40 AM, Thomas Hofer < > mailinglisten@familie-hofer.net> wrote:

Hi!

The configuration guide is exemplary for windows. On linux the path
variable has to point into the linux sub directory.

In which directory are you running SC? In the working directory as shown
in
http://www.sip-communicator.org/wiki/pub/uploads/Documentation/eclipseProjectConfiguration2.png?

You you find the dlls in the lib/native/windows directory?

*Von:* Daniel Veljjanoski [mailto:danielveljanoski@gmail.com]
*Gesendet:* Dienstag, 10. Juni 2008 09:30
*An:* dev@sip-communicator.dev.java.net
*Betreff:* [sip-comm-dev] Eclipse Configuration - PATH

Hi,

Fallowing the tutorial

http://www.sip-communicator.org/index.php/Documentation/ConfigureEclipseNew

I have tried to configure eclipse (Eclipse Version 3.3.1.1, Windows XP ),
everything work fine, only I can't get the systray icon :(.

I have create a variable named "path" with the value : *
%path%;./lib/native/windows*

like the exemple show :

http://www.sip-communicator.org/wiki/pub/uploads/Documentation/eclipseProjectConfiguration3.png

09:09:51.125 SEVERE: impl.systray.jdic.SystrayServiceJdicImpl.<init>().107
Failed to create a systray!java.lang.UnsatisfiedLinkError: ....

When I use the ANT -> build.xml everything is OK.

The problem is the same when I use Ubuntu or Windows XP, and try to
Configure, Run and Debug sip communicator through Eclipse

Any help please.

Thanks

Cheers

PS: Excuse for my English.

--
Daniel VELJJANOSKI

--
Daniel VELJJANOSKI

--
Daniel VELJJANOSKI


#5

I must mentioned that others Systray services are started :
Below a send the part from the log file ...

10:06:55.765 SEVERE: impl.systray.jdic.SystrayServiceJdicImpl.<init>().107
Failed to create a systray!
java.lang.UnsatisfiedLinkError:
org.jdesktop.jdic.tray.internal.impl.GnomeSystemTrayService.initNative(Ljava/lang/String;)V
    at
org.jdesktop.jdic.tray.internal.impl.GnomeSystemTrayService.initNative(Native
Method)
    at
org.jdesktop.jdic.tray.internal.impl.GnomeSystemTrayService.<clinit>(Unknown
Source)
    at
org.jdesktop.jdic.tray.internal.impl.ServiceManagerStub.getService(Unknown
Source)
    at org.jdesktop.jdic.tray.internal.ServiceManager.getService(Unknown
Source)
    at org.jdesktop.jdic.tray.SystemTray.<clinit>(Unknown Source)
    at
net.java.sip.communicator.impl.systray.jdic.SystrayServiceJdicImpl.<init>(SystrayServiceJdicImpl.java:103)
    at
net.java.sip.communicator.impl.systray.SystrayActivator.start(SystrayActivator.java:51)
    at
org.apache.felix.framework.util.SecureAction.startActivator(SecureAction.java:589)
    at org.apache.felix.framework.Felix._startBundle(Felix.java:1536)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:1470)
    at
org.apache.felix.framework.Felix.setFrameworkStartLevel(Felix.java:1065)
    at
org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:258)
    at java.lang.Thread.run(Thread.java:619)
10:06:55.765 FINE:
impl.protocol.sip.ProtocolProviderServiceSipImpl.getMaxForwardsHeader().1567
generated max forwards: Max-Forwards: 70

10:06:55.765 INFO: impl.systray.SystrayActivator.start().53 Systray
Service...[ STARTED ]
10:06:55.765 FINER:
impl.callhistory.CallHistoryServiceImpl.serviceChanged().640 Received a
service event for:
net.java.sip.communicator.impl.systray.jdic.SystrayServiceJdicImpl
10:06:55.765 FINER:
impl.msghistory.MessageHistoryServiceImpl.serviceChanged().858 Received a
service event for:
net.java.sip.communicator.impl.systray.jdic.SystrayServiceJdicImpl
10:06:55.765 FINER:
impl.contactlist.MetaContactListServiceImpl.serviceChanged().1775 Received a
service event for:
net.java.sip.communicator.impl.systray.jdic.SystrayServiceJdicImpl
10:06:55.781 INFO: impl.systray.SystrayActivator.start().60 Systray Service
...[REGISTERED]
10:06:55.781 FINEST: impl.systray.SystrayActivator.start().62 [entry] start
10:06:55.781 FINEST: impl.systray.SystrayActivator.start().65 [exit] start

Cheers

···

On Tue, Jun 10, 2008 at 10:02 AM, Daniel Veljjanoski < danielveljanoski@gmail.com> wrote:

Hi again,

Here is the problem given by eclipse :

09:56:12.093 SEVERE:
impl.systray.jdic.SystrayServiceJdicImpl.<init>().107 Failed to create a
systray!

java.lang.UnsatisfiedLinkError:
org.jdesktop.jdic.tray.internal.impl.GnomeSystemTrayService.initNative(Ljava/lang/String;)V

at org.jdesktop.jdic.tray.internal.impl.GnomeSystemTrayService.initNative(
*Native Method*)

at
org.jdesktop.jdic.tray.internal.impl.GnomeSystemTrayService.<clinit>(Unknown
Source)

at
org.jdesktop.jdic.tray.internal.impl.ServiceManagerStub.getService(Unknown
Source)

at org.jdesktop.jdic.tray.internal.ServiceManager.getService(Unknown
Source)

at org.jdesktop.jdic.tray.SystemTray.<clinit>(Unknown Source)

at
net.java.sip.communicator.impl.systray.jdic.SystrayServiceJdicImpl.<init>(
*SystrayServiceJdicImpl.java:103*)

at net.java.sip.communicator.impl.systray.SystrayActivator.start(*
SystrayActivator.java:51*)

at org.apache.felix.framework.util.SecureAction.startActivator(*
SecureAction.java:589*)

at org.apache.felix.framework.Felix._startBundle(*Felix.java:1536*)

at org.apache.felix.framework.Felix.startBundle(*Felix.java:1470*)

at org.apache.felix.framework.Felix.setFrameworkStartLevel(*
Felix.java:1065*)

at org.apache.felix.framework.StartLevelImpl.run(*StartLevelImpl.java:258*
)

at java.lang.Thread.run(*Thread.java:619*)

Like I have mentioned I am using Windows XP, but I can see in the
exception above GnomeSystemTrayService???

Cheers

On Tue, Jun 10, 2008 at 9:53 AM, Daniel Veljjanoski < > danielveljanoski@gmail.com> wrote:

Hey Thomas,

Thanks for your answer.

I know that the configuration guide is for windows, and I am trying to
Configure, Run and Debug sip communicator through Eclipse Version 3.3.1.1(Windows XP).

Re: Yes I find the dlls in the lib/native/windows.

<....>\sip-communicator\lib\native\windows>dir

Directory of <....>\\sip-communicator\lib\native\windows

23/05/2008 09:34 AM <DIR> .
23/05/2008 09:34 AM <DIR> ..
04/06/2008 01:30 PM 61,440 IeEmbed.exe
04/06/2008 01:30 PM 110,592 jdic.dll
04/06/2008 01:30 PM 53,248 jdic_misc.dll
04/06/2008 01:30 PM 49,152 jmacm.dll
04/06/2008 01:30 PM 53,248 jmam.dll
04/06/2008 01:30 PM 49,152 jmcvid.dll
04/06/2008 01:30 PM 40,960 jmdaud.dll
04/06/2008 01:30 PM 28,672 jmdaudc.dll
04/06/2008 01:30 PM 32,768 jmddraw.dll
04/06/2008 01:30 PM 32,768 jmfjawt.dll
04/06/2008 01:30 PM 98,304 jmg723.dll
04/06/2008 01:30 PM 36,864 jmgdi.dll
04/06/2008 01:30 PM 57,344 jmgsm.dll
04/06/2008 01:30 PM 282,624 jmh261.dll
04/06/2008 01:30 PM 106,496 jmh263enc.dll
04/06/2008 01:30 PM 143,360 jmjpeg.dll
04/06/2008 01:30 PM 28,672 jmmci.dll
04/06/2008 01:30 PM 380,928 jmmpa.dll
04/06/2008 01:30 PM 77,824 jmmpegv.dll
04/06/2008 01:30 PM 73,728 jmutil.dll
04/06/2008 01:30 PM 36,864 jmvcm.dll
04/06/2008 01:30 PM 45,056 jmvfw.dll
04/06/2008 01:30 PM 184,320 jmvh263.dll
04/06/2008 01:30 PM 413,696 jsound.dll
04/06/2008 01:30 PM 192,512 MozEmbed.exe
04/06/2008 01:30 PM 1,154,250 soundbank.gm
04/06/2008 01:30 PM 45,056 tray.dll
              27 File(s) 3,869,898 bytes
               2 Dir(s) 290,590,216,192 bytes free

Using : -Djava.library.path=lib\native\windows as VM Argument

(
https://sip-communicator.dev.java.net/servlets/ReadMsg?list=dev&msgNo=2525
)

doesn't help :(.

Thanks

On Tue, Jun 10, 2008 at 9:40 AM, Thomas Hofer < >> mailinglisten@familie-hofer.net> wrote:

Hi!

The configuration guide is exemplary for windows. On linux the path
variable has to point into the linux sub directory.

In which directory are you running SC? In the working directory as shown
in
http://www.sip-communicator.org/wiki/pub/uploads/Documentation/eclipseProjectConfiguration2.png?

You you find the dlls in the lib/native/windows directory?

*Von:* Daniel Veljjanoski [mailto:danielveljanoski@gmail.com]
*Gesendet:* Dienstag, 10. Juni 2008 09:30
*An:* dev@sip-communicator.dev.java.net
*Betreff:* [sip-comm-dev] Eclipse Configuration - PATH

Hi,

Fallowing the tutorial

http://www.sip-communicator.org/index.php/Documentation/ConfigureEclipseNew

I have tried to configure eclipse (Eclipse Version 3.3.1.1, Windows XP
), everything work fine, only I can't get the systray icon :(.

I have create a variable named "path" with the value : *
%path%;./lib/native/windows*

like the exemple show :

http://www.sip-communicator.org/wiki/pub/uploads/Documentation/eclipseProjectConfiguration3.png

09:09:51.125 SEVERE:
impl.systray.jdic.SystrayServiceJdicImpl.<init>().107 Failed to create a
systray!java.lang.UnsatisfiedLinkError: ....

When I use the ANT -> build.xml everything is OK.

The problem is the same when I use Ubuntu or Windows XP, and try to
Configure, Run and Debug sip communicator through Eclipse

Any help please.

Thanks

Cheers

PS: Excuse for my English.

--
Daniel VELJJANOSKI

--
Daniel VELJJANOSKI

--
Daniel VELJJANOSKI

--
Daniel VELJJANOSKI