[sip-comm-dev] Connection problem to IPv4 SIP providers and peers on GNU/Linux (and a workaround)


#1

Hi,

Yesterday, I was unable to connect to any IPv4 SIP providers as well as IPv4 SIP peers. My network was configured correctly and the peers and providers reply to the ICMP echo request. Connections to IPv6 providers and peers works good (for all my work I use only IPv6). My computers runs GNU/Linux Debian Squeeze ("upgraded" daily). FYI on Windows it runs fine.

I found the reason and a workaround. It is due to the introduction of bindv6only=1 by default in GNU/Linux Debian Squeeze. You could check it at /proc/sys/net/ipv6/bindv6only and /etc/sysctl.d/bindv6only.conf. See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=560044. One solution proposed in the bugreport is to add java.net.preferIPv4Stack=true but it does not work in SC. Setting bindv6only to 0 (echo 0 > /proc/sys/net/ipv6/bindv6only or set 0 in /etc/sysctl.d/bindv6only.conf file) solve the problem.

Maybe it affects other GNU/Linux distributions. But with this workaround all works fine.

Regards,

···

--
Sebastien

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#2

Hi,

I think I have seen this on clean installed Ubuntu Karmic, but after
few updates everything was working fine. But haven't seen this
resolution.

Thanks for sharing it with us :slight_smile:
damencho

···

On Thu, Jan 7, 2010 at 10:25 AM, Sebastien Vincent <seb@sip-communicator.org> wrote:

Hi,

Yesterday, I was unable to connect to any IPv4 SIP providers as well as IPv4
SIP peers. My network was configured correctly and the peers and providers
reply to the ICMP echo request. Connections to IPv6 providers and peers
works good (for all my work I use only IPv6). My computers runs GNU/Linux
Debian Squeeze ("upgraded" daily). FYI on Windows it runs fine.

I found the reason and a workaround. It is due to the introduction of
bindv6only=1 by default in GNU/Linux Debian Squeeze. You could check it at
/proc/sys/net/ipv6/bindv6only and /etc/sysctl.d/bindv6only.conf. See
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=560044. One solution
proposed in the bugreport is to add java.net.preferIPv4Stack=true but it
does not work in SC. Setting bindv6only to 0 (echo 0 >
/proc/sys/net/ipv6/bindv6only or set 0 in /etc/sysctl.d/bindv6only.conf
file) solve the problem.

Maybe it affects other GNU/Linux distributions. But with this workaround all
works fine.

Regards,
--
Sebastien

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net