[sip-comm-dev] Chinese translation of SIP communicator/Font handling in SIP-Communicator


#1

Hi NIE PIN!

Hi, dear Michael,
Thanks for your work. But i tested the Chinese translation on my windows.
The scrambled character is still there. I installed eastern asian fonts and
nothing happens.
Since the browser can display Chinese correctly and the contacts in sipcomm
is also good, I wonder what is the problem on sipcomm configurations?
Or must it be a Chinese os for correct display?

Sorry for my late reply. To be honest, I don't really know the answer. Your Chinese properties file looked right when I opened it in Emacs (on Windows). But when I start SIP Communicator, I get scrambled characters just like you. I assumed it was just me and that it would work for you since you already have your environment set up for Chinese.

I do have some knowledge of Java font handling in general from my own open source project http://jgloss.sourceforge.net/ (unfortunately unmaintained for lack of time), so I can probably figure out how to make it work. I just need some pointers from the other developers who better know the SIP Communicator GUI. Therefore, I am also posting this to the mailing list.

The (Sun) Java runtime chooses its standard fonts for dialogs and such based on the country and language settings you pass at startup (defaulting to the OS settings). So if the GUI is using the standard fonts, the characters should display correctly. This is probably why contacts are displayed right. My guess is that SIP Communicator sets a custom font for the other controls, which doesn't contain Chinese characters. Can someone confirm this? If you could point me to where this happens, I could maybe suggest a fix.

Cheers
Michael Koch


#2

Hi, Michel,
Thanks for your mail.
Well, my windows is not setup in Chinese. It is in English by default. But I
installed "eastern asian languages" from the control panel. It does not
work. You may be right that JVM takes default font from OS directly for
upper applications.

Anyway, I have no clue on dealing with fonts. Looking forward to the great
answers

BR

niepin

···

On Wed, Mar 5, 2008 at 2:50 PM, Koch Michael <MKoch@rowa.de> wrote:

Hi NIE PIN!

>Hi, dear Michael,
>Thanks for your work. But i tested the Chinese translation on my windows.
>The scrambled character is still there. I installed eastern asian fonts
and
>nothing happens.
>Since the browser can display Chinese correctly and the contacts in
sipcomm
>is also good, I wonder what is the problem on sipcomm configurations?
>Or must it be a Chinese os for correct display?

Sorry for my late reply. To be honest, I don't really know the answer.
Your Chinese properties file looked right when I opened it in Emacs (on
Windows). But when I start SIP Communicator, I get scrambled characters just
like you. I assumed it was just me and that it would work for you since you
already have your environment set up for Chinese.

I do have some knowledge of Java font handling in general from my own open
source project http://jgloss.sourceforge.net/ (unfortunately unmaintained
for lack of time), so I can probably figure out how to make it work. I just
need some pointers from the other developers who better know the SIP
Communicator GUI. Therefore, I am also posting this to the mailing list.

The (Sun) Java runtime chooses its standard fonts for dialogs and such
based on the country and language settings you pass at startup (defaulting
to the OS settings). So if the GUI is using the standard fonts, the
characters should display correctly. This is probably why contacts are
displayed right. My guess is that SIP Communicator sets a custom font for
the other controls, which doesn't contain Chinese characters. Can someone
confirm this? If you could point me to where this happens, I could maybe
suggest a fix.

Cheers
Michael Koch

--
BR
NIE PIN
TML@HUT, Helsinki, Finland
ANTD@NIST, Gaithersburg, USA
Ph: +1 (301)975-6049


#3

Hey Michael, and Niepin,

I just tried the Chinese version of SIP Communicator and didn't have any
problems. I did it on Linux though so, I was wondering whether you were
running it on another platform and if yes, whether it could an issue
related to the OS.

In any case, Yana would correct me if I am wrong, I don't think we are
changing the font used with menus labels and buttons.

Cheers
Emil

P.S. Niepin, I didn't get the chance to do this earlier so I'd like to
thank you for contributing the Chinese translation! Cool stuff!

pin nie написа:

···

Hi, Michel,
Thanks for your mail.
Well, my windows is not setup in Chinese. It is in English by default.
But I installed "eastern asian languages" from the control panel. It
does not work. You may be right that JVM takes default font from OS
directly for upper applications.

Anyway, I have no clue on dealing with fonts. Looking forward to the
great answers

BR

niepin

On Wed, Mar 5, 2008 at 2:50 PM, Koch Michael <MKoch@rowa.de > <mailto:MKoch@rowa.de>> wrote:

    Hi NIE PIN!

    >Hi, dear Michael,
    >Thanks for your work. But i tested the Chinese translation on my
    windows.
    >The scrambled character is still there. I installed eastern asian
    fonts and
    >nothing happens.
    >Since the browser can display Chinese correctly and the contacts in
    sipcomm
    >is also good, I wonder what is the problem on sipcomm configurations?
    >Or must it be a Chinese os for correct display?

    Sorry for my late reply. To be honest, I don't really know the
    answer. Your Chinese properties file looked right when I opened it
    in Emacs (on Windows). But when I start SIP Communicator, I get
    scrambled characters just like you. I assumed it was just me and
    that it would work for you since you already have your environment
    set up for Chinese.

    I do have some knowledge of Java font handling in general from my
    own open source project http://jgloss.sourceforge.net/
    (unfortunately unmaintained for lack of time), so I can probably
    figure out how to make it work. I just need some pointers from the
    other developers who better know the SIP Communicator GUI.
    Therefore, I am also posting this to the mailing list.

    The (Sun) Java runtime chooses its standard fonts for dialogs and
    such based on the country and language settings you pass at startup
    (defaulting to the OS settings). So if the GUI is using the standard
    fonts, the characters should display correctly. This is probably why
    contacts are displayed right. My guess is that SIP Communicator sets
    a custom font for the other controls, which doesn't contain Chinese
    characters. Can someone confirm this? If you could point me to where
    this happens, I could maybe suggest a fix.

    Cheers
    Michael Koch

--
BR
NIE PIN
TML@HUT, Helsinki, Finland
ANTD@NIST, Gaithersburg, USA
Ph: +1 (301)975-6049

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#4

Hi Michael,

sorry for the late reply. We're using a custom font and I agree that this could cause the problem. We could check that easily by changing the font. I just want to check first whether all components use the same font. Will write you later today.

Cheers,
Yana

Koch Michael wrote:

···

Hi NIE PIN!

Hi, dear Michael,
Thanks for your work. But i tested the Chinese translation on my windows.
The scrambled character is still there. I installed eastern asian fonts and
nothing happens.
Since the browser can display Chinese correctly and the contacts in sipcomm
is also good, I wonder what is the problem on sipcomm configurations?
Or must it be a Chinese os for correct display?

Sorry for my late reply. To be honest, I don't really know the answer. Your Chinese properties file looked right when I opened it in Emacs (on Windows). But when I start SIP Communicator, I get scrambled characters just like you. I assumed it was just me and that it would work for you since you already have your environment set up for Chinese.

I do have some knowledge of Java font handling in general from my own open source project http://jgloss.sourceforge.net/ (unfortunately unmaintained for lack of time), so I can probably figure out how to make it work. I just need some pointers from the other developers who better know the SIP Communicator GUI. Therefore, I am also posting this to the mailing list.

The (Sun) Java runtime chooses its standard fonts for dialogs and such based on the country and language settings you pass at startup (defaulting to the OS settings). So if the GUI is using the standard fonts, the characters should display correctly. This is probably why contacts are displayed right. My guess is that SIP Communicator sets a custom font for the other controls, which doesn't contain Chinese characters. Can someone confirm this? If you could point me to where this happens, I could maybe suggest a fix.

Cheers
Michael Koch

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#5

Hey Emil,
Sorry to bother you.
Yesterday I installed sipcomm, and found that the Chinese characters are all
squares.
Today I find you are talking about this problem, so I just wanna tell you
that I think it's because of the configurations of fonts, some fonts don't
contain enough Chinese characters. I'm using a Chinese OS(Windows XP), so I
guess it's not related to the OS version. But I also have no idea of how to
fix it.

regards,
Dai Zhiwei

···

2008/3/8, Emil Ivov <emcho@sip-communicator.org>:

Hey Michael, and Niepin,

I just tried the Chinese version of SIP Communicator and didn't have any
problems. I did it on Linux though so, I was wondering whether you were
running it on another platform and if yes, whether it could an issue
related to the OS.

In any case, Yana would correct me if I am wrong, I don't think we are
changing the font used with menus labels and buttons.

Cheers
Emil

P.S. Niepin, I didn't get the chance to do this earlier so I'd like to
thank you for contributing the Chinese translation! Cool stuff!

pin nie написа:
> Hi, Michel,
> Thanks for your mail.
> Well, my windows is not setup in Chinese. It is in English by default.
> But I installed "eastern asian languages" from the control panel. It
> does not work. You may be right that JVM takes default font from OS
> directly for upper applications.
>
> Anyway, I have no clue on dealing with fonts. Looking forward to the
> great answers
>
> BR
>
> niepin
>
> On Wed, Mar 5, 2008 at 2:50 PM, Koch Michael <MKoch@rowa.de > > <mailto:MKoch@rowa.de>> wrote:
>
> Hi NIE PIN!
>
> >Hi, dear Michael,
> >Thanks for your work. But i tested the Chinese translation on my
> windows.
> >The scrambled character is still there. I installed eastern asian
> fonts and
> >nothing happens.
> >Since the browser can display Chinese correctly and the contacts in
> sipcomm
> >is also good, I wonder what is the problem on sipcomm
configurations?
> >Or must it be a Chinese os for correct display?
>
> Sorry for my late reply. To be honest, I don't really know the
> answer. Your Chinese properties file looked right when I opened it
> in Emacs (on Windows). But when I start SIP Communicator, I get
> scrambled characters just like you. I assumed it was just me and
> that it would work for you since you already have your environment
> set up for Chinese.
>
> I do have some knowledge of Java font handling in general from my
> own open source project http://jgloss.sourceforge.net/
> (unfortunately unmaintained for lack of time), so I can probably
> figure out how to make it work. I just need some pointers from the
> other developers who better know the SIP Communicator GUI.
> Therefore, I am also posting this to the mailing list.
>
> The (Sun) Java runtime chooses its standard fonts for dialogs and
> such based on the country and language settings you pass at startup
> (defaulting to the OS settings). So if the GUI is using the standard
> fonts, the characters should display correctly. This is probably why
> contacts are displayed right. My guess is that SIP Communicator sets
> a custom font for the other controls, which doesn't contain Chinese
> characters. Can someone confirm this? If you could point me to where
> this happens, I could maybe suggest a fix.
>
> Cheers
> Michael Koch
>
>
>
>
> --
> BR
> NIE PIN
> TML@HUT, Helsinki, Finland
> ANTD@NIST, Gaithersburg, USA
> Ph: +1 (301)975-6049

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#6

Hi Yana,

I've finally had some time to try it out myself. I found that Verdana is
defined in several places as font choice. I replaced all occurrences of
Verdana with sansserif. This is a standard font defined by the Java VM with
different real fonts used depending on the operating system. It is
configured to cover a wide variety of glyphs. After that, Chinese characters
were working fine.

I was testing on Ubuntu Linux, by the way. So all the Linux users who were
reporting success earlier probably don't have a Verdana font installed (I
had one).

So a short-term solution would be to change the default font. This probably
wouldn't look too nice, though. A more complex possibility would be to
define a list of fonts and check at runtime if one of the fonts defines the
glyphs needed to show the texts defined in the translated resource file
(this is possible with Font.canDisplayUpTo). The last font in the list would
be the sansserif or possibly serif fallback.

I'm afraid I won't have time to actually implement that. But I would be
happy to discuss the possible approaches further.

Cheers
Michael Koch

···

Hi Michael,

sorry for the late reply. We're using a custom font and I agree that
this could cause the problem. We could check that easily by
changing the
font. I just want to check first whether all components use the same
font. Will write you later today.

Cheers,
Yana

Koch Michael wrote:
> Hi NIE PIN!
>
>> Hi, dear Michael,
>> Thanks for your work. But i tested the Chinese translation
on my windows.
>> The scrambled character is still there. I installed
eastern asian fonts and
>> nothing happens.
>> Since the browser can display Chinese correctly and the
contacts in sipcomm
>> is also good, I wonder what is the problem on sipcomm
configurations?
>> Or must it be a Chinese os for correct display?
>
> Sorry for my late reply. To be honest, I don't really know
the answer. Your Chinese properties file looked right when I
opened it in Emacs (on Windows). But when I start SIP
Communicator, I get scrambled characters just like you. I
assumed it was just me and that it would work for you since
you already have your environment set up for Chinese.
>
> I do have some knowledge of Java font handling in general
from my own open source project
http://jgloss.sourceforge.net/ (unfortunately unmaintained
for lack of time), so I can probably figure out how to make
it work. I just need some pointers from the other developers
who better know the SIP Communicator GUI. Therefore, I am
also posting this to the mailing list.
>
> The (Sun) Java runtime chooses its standard fonts for
dialogs and such based on the country and language settings
you pass at startup (defaulting to the OS settings). So if
the GUI is using the standard fonts, the characters should
display correctly. This is probably why contacts are
displayed right. My guess is that SIP Communicator sets a
custom font for the other controls, which doesn't contain
Chinese characters. Can someone confirm this? If you could
point me to where this happens, I could maybe suggest a fix.
>
> Cheers
> Michael Koch
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail:
dev-help@sip-communicator.dev.java.net


#7

Thanks for the detail Dai,

OK, so I guess it's a Windows issue. (Anyone can confirm this running on
Mac OS X?).

Yana, maybe you'd have an idea as to what might be causing this?

Emil

DaiZW написа:

···

Hey Emil,
Sorry to bother you.
Yesterday I installed sipcomm, and found that the Chinese characters are
all squares.
Today I find you are talking about this problem, so I just wanna tell
you that I think it's because of the configurations of fonts, some fonts
don't contain enough Chinese characters. I'm using a Chinese OS(Windows
XP), so I guess it's not related to the OS version. But I also have no
idea of how to fix it.

regards,
Dai Zhiwei

2008/3/8, Emil Ivov <emcho@sip-communicator.org
<mailto:emcho@sip-communicator.org>>:

    Hey Michael, and Niepin,

    I just tried the Chinese version of SIP Communicator and didn't have any
    problems. I did it on Linux though so, I was wondering whether you were
    running it on another platform and if yes, whether it could an issue
    related to the OS.

    In any case, Yana would correct me if I am wrong, I don't think we are
    changing the font used with menus labels and buttons.

    Cheers
    Emil

    P.S. Niepin, I didn't get the chance to do this earlier so I'd like to
    thank you for contributing the Chinese translation! Cool stuff!

    pin nie написа:
    > Hi, Michel,
    > Thanks for your mail.
    > Well, my windows is not setup in Chinese. It is in English by default.
    > But I installed "eastern asian languages" from the control panel. It
    > does not work. You may be right that JVM takes default font from OS
    > directly for upper applications.
    >
    > Anyway, I have no clue on dealing with fonts. Looking forward to the
    > great answers
    >
    > BR
    >
    > niepin
    >
    > On Wed, Mar 5, 2008 at 2:50 PM, Koch Michael <MKoch@rowa.de > <mailto:MKoch@rowa.de> > > <mailto:MKoch@rowa.de <mailto:MKoch@rowa.de>>> wrote:
    >
    > Hi NIE PIN!
    >
    > >Hi, dear Michael,
    > >Thanks for your work. But i tested the Chinese translation on my
    > windows.
    > >The scrambled character is still there. I installed eastern asian
    > fonts and
    > >nothing happens.
    > >Since the browser can display Chinese correctly and the
    contacts in
    > sipcomm
    > >is also good, I wonder what is the problem on sipcomm
    configurations?
    > >Or must it be a Chinese os for correct display?
    >
    > Sorry for my late reply. To be honest, I don't really know the
    > answer. Your Chinese properties file looked right when I opened it
    > in Emacs (on Windows). But when I start SIP Communicator, I get
    > scrambled characters just like you. I assumed it was just me and
    > that it would work for you since you already have your environment
    > set up for Chinese.
    >
    > I do have some knowledge of Java font handling in general from my
    > own open source project http://jgloss.sourceforge.net/
    > (unfortunately unmaintained for lack of time), so I can probably
    > figure out how to make it work. I just need some pointers from the
    > other developers who better know the SIP Communicator GUI.
    > Therefore, I am also posting this to the mailing list.
    >
    > The (Sun) Java runtime chooses its standard fonts for dialogs and
    > such based on the country and language settings you pass at
    startup
    > (defaulting to the OS settings). So if the GUI is using the
    standard
    > fonts, the characters should display correctly. This is
    probably why
    > contacts are displayed right. My guess is that SIP
    Communicator sets
    > a custom font for the other controls, which doesn't contain
    Chinese
    > characters. Can someone confirm this? If you could point me to
    where
    > this happens, I could maybe suggest a fix.
    >
    > Cheers
    > Michael Koch
    >
    >
    >
    >
    > --
    > BR
    > NIE PIN
    > TML@HUT, Helsinki, Finland
    > ANTD@NIST, Gaithersburg, USA
    > Ph: +1 (301)975-6049

    ---------------------------------------------------------------------
    To unsubscribe, e-mail:
    dev-unsubscribe@sip-communicator.dev.java.net
    <mailto:dev-unsubscribe@sip-communicator.dev.java.net>
    For additional commands, e-mail:
    dev-help@sip-communicator.dev.java.net
    <mailto:dev-help@sip-communicator.dev.java.net>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#8

Hi,

OK, so I guess it's a Windows issue. (Anyone can confirm this running on
Mac OS X?).

I'm willing to test it on OSX but even though I select Chinese as the primary OS language I still have the english menu in SIP Communicator (looks like it does not find the correct chinese property file matching the language selection).

Enclosed is my MacOSX config, maybe Dai can tell me if it's the correct langage set? (there are many to choose between).

Cheers,
romain

···

On 2008/03/08, at 22:00, Emil Ivov wrote:


#9

Hi Romain,
I didn't use a OSX before, so I'm not very familiar with this OS.
But maybe I can offer some help, as a Chinese, :slight_smile:
Please check out the accessories, I put some marks on them.

cheers,
Dai

···

2008/3/10, Romain KUNTZ <kuntz@clarinet.u-strasbg.fr>:

Hi,

On 2008/03/08, at 22:00, Emil Ivov wrote:
> OK, so I guess it's a Windows issue. (Anyone can confirm this
> running on
> Mac OS X?).

I'm willing to test it on OSX but even though I select Chinese as the
primary OS language I still have the english menu in SIP Communicator
(looks like it does not find the correct chinese property file
matching the language selection).

Enclosed is my MacOSX config, maybe Dai can tell me if it's the
correct langage set? (there are many to choose between).

Cheers,

romain

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#10

Hi Dai,

Thanks for your help, I could get the Chinese translation working! It seems to be correctly displayed on OSX.

Cheers,
romain


#11

Hey Romain,
You are welcome.
Indeed, it works. I am happy to see that.

Emil, if I change the region to English(America) in ControlPanel, sipcomm
works well.
But if I change back to Chinese(Simp), as I said before, there are some
problems(please check out the accessories).
And what's kind of odd, some Chinese charactors can be displayed, some not.

regards,
Dai

ps: what about add a function of changing language using the menu?

···

2008/3/10, Romain KUNTZ <kuntz@lsiit.u-strasbg.fr>:

Hi Dai,

Thanks for your help, I could get the Chinese translation working! It
seems to be correctly displayed on OSX.

Cheers,

romain