[sip-comm-dev] Can not call out on Linux


#1

Hello,

I tried sip-communicator to ring a phone number but the call window just
hang at message: Initialize call

and I have to click hang up after a while and got he message in the console

15:15:06.776 SEVERE: impl.protocol.sip.
CallPeerSipImpl.hangup().777 Could not determine call peer state!

The strange thing is that it used to work once - then not working - and I
suspect sun-java has some problem so I remove it and install openjdk-6 -
after that it worked again. I exit the program and now just tried - old
problem happened.

This is on Ubuntu Lucid update to date system ; and sip-communicator version
: 1.0-alpha6-nightly.build.3174

I have not tried on window yet or another Linux distro yet.

Many thanks

···

--
Steve Kieu
Ph: +61-7-3367-3241
sip:*01161428@sipbroker.com


#2

Hi,

I found where the problem is, is someone confirmed then file a bug

The problem is that I do not use standard port 5060 for the client, and one
of the component (the sip handling module or the GUI reading sip state still
ask for port 5060?) does not honor the setting and changed accordingly. Some
where hard coded the port 5060.

So If I changed Tool/Options/General/Sip Client Port back to 5060 and secure
to 5061 - things work again.

Unfortunately I could not do that because I route all 5060 to my sipura link
sys device - this is the main telephone we use at home. So that bug prevent
me to use sipcommunicator .

Please confirmed and if possible fixed the bug. Many thanks.

···

---------- Forwarded message ----------

From: Steve Kieu <msh.computing@gmail.com>

Date: Sun, Dec 19, 2010 at 3:40 PM
Subject: Can not call out on Linux
To: dev@sip-communicator.dev.java.net

Hello,

I tried sip-communicator to ring a phone number but the call window just
hang at message: Initialize call

and I have to click hang up after a while and got he message in the console

15:15:06.776 SEVERE: impl.protocol.sip.
CallPeerSipImpl.hangup().777 Could not determine call peer state!

The strange thing is that it used to work once - then not working - and I
suspect sun-java has some problem so I remove it and install openjdk-6 -
after that it worked again. I exit the program and now just tried - old
problem happened.

This is on Ubuntu Lucid update to date system ; and sip-communicator version
: 1.0-alpha6-nightly.build.3174

I have not tried on window yet or another Linux distro yet.

Many thanks

--
Steve Kieu
Ph: +61-7-3367-3241
sip:*01161428@sipbroker.com

--
Steve Kieu


#3

Hey Steve,

Could you please enable "Packet Logging" for all protocols in SIP
Communicator's advanced settings and then send us the content of your
log folder?

(more inline)

На 19.12.10 09:44, Steve Kieu написа:

Hi,

I found where the problem is, is someone confirmed then file a bug

The problem is that I do not use standard port 5060 for the client, and
one of the component (the sip handling module or the GUI reading sip
state still ask for port 5060?) does not honor the setting and changed
accordingly. Some where hard coded the port 5060.

Changing the local SIP port in SIP Communicator is known to work and did
not show any problems during our internal tests. This is why we'd need
to see the logs.

Unfortunately I could not do that because I route all 5060 to my sipura
link sys device - this is the main telephone we use at home. So that bug
prevent me to use sipcommunicator .

I am not sure I understand. How would your external device have anything
to do with the port that SIP Communicator is using on your computer?

Cheers,
Emil

···

Please confirmed and if possible fixed the bug. Many thanks.

---------- Forwarded message ----------
From: *Steve Kieu* <msh.computing@gmail.com
<mailto:msh.computing@gmail.com>>
Date: Sun, Dec 19, 2010 at 3:40 PM
Subject: Can not call out on Linux
To: dev@sip-communicator.dev.java.net
<mailto:dev@sip-communicator.dev.java.net>

Hello,

I tried sip-communicator to ring a phone number but the call window just
hang at message: Initialize call

and I have to click hang up after a while and got he message in the console

15:15:06.776 SEVERE: impl.protocol.sip.
CallPeerSipImpl.hangup().777 Could not determine call peer state!

The strange thing is that it used to work once - then not working - and
I suspect sun-java has some problem so I remove it and install openjdk-6
- after that it worked again. I exit the program and now just tried -
old problem happened.

This is on Ubuntu Lucid update to date system ; and sip-communicator
version : 1.0-alpha6-nightly.build.3174

I have not tried on window yet or another Linux distro yet.

Many thanks

--
Steve Kieu
Ph: +61-7-3367-3241
sip:*01161428@sipbroker.com <mailto:01161428@sipbroker.com>

--
Steve Kieu

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
SIP Communicator
emcho@sip-communicator.org PHONE: +33.1.77.62.43.30
http://sip-communicator.org FAX: +33.1.77.62.47.31

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#4

Hello,

Sorry not to make it clear,

The modem forward all UDP 5060 to my ata linksys spa1001 - That is why it
affects sip-communicator (running on a computer in the same local network)
if it only can listen on port 5060 for incoming sip signal. I need all other
sip client in my home network to listen on different port. Hope that it is
clear to you now.

Please find the log file attached.

Many thanks,

Regards,

sipcommunicator-log.zip (13.1 KB)

···

On Sun, Dec 19, 2010 at 11:13 PM, Emil Ivov <emcho@sip-communicator.org>wrote:

Hey Steve,

Could you please enable "Packet Logging" for all protocols in SIP
Communicator's advanced settings and then send us the content of your
log folder?

(more inline)

На 19.12.10 09:44, Steve Kieu написа:
> Hi,
>
> I found where the problem is, is someone confirmed then file a bug
>
> The problem is that I do not use standard port 5060 for the client, and
> one of the component (the sip handling module or the GUI reading sip
> state still ask for port 5060?) does not honor the setting and changed
> accordingly. Some where hard coded the port 5060.

Changing the local SIP port in SIP Communicator is known to work and did
not show any problems during our internal tests. This is why we'd need
to see the logs.

> Unfortunately I could not do that because I route all 5060 to my sipura
> link sys device - this is the main telephone we use at home. So that bug
> prevent me to use sipcommunicator .

I am not sure I understand. How would your external device have anything
to do with the port that SIP Communicator is using on your computer?

Cheers,
Emil

>
> Please confirmed and if possible fixed the bug. Many thanks.
>
>
>
>
>
> ---------- Forwarded message ----------
> From: *Steve Kieu* <msh.computing@gmail.com
> <mailto:msh.computing@gmail.com>>
> Date: Sun, Dec 19, 2010 at 3:40 PM
> Subject: Can not call out on Linux
> To: dev@sip-communicator.dev.java.net
> <mailto:dev@sip-communicator.dev.java.net>
>
>
>
> Hello,
>
> I tried sip-communicator to ring a phone number but the call window just
> hang at message: Initialize call
>
> and I have to click hang up after a while and got he message in the
console
>
> 15:15:06.776 SEVERE: impl.protocol.sip.
> CallPeerSipImpl.hangup().777 Could not determine call peer state!
>
> The strange thing is that it used to work once - then not working - and
> I suspect sun-java has some problem so I remove it and install openjdk-6
> - after that it worked again. I exit the program and now just tried -
> old problem happened.
>
> This is on Ubuntu Lucid update to date system ; and sip-communicator
> version : 1.0-alpha6-nightly.build.3174
>
> I have not tried on window yet or another Linux distro yet.
>
> Many thanks
>
>
> --
> Steve Kieu
> Ph: +61-7-3367-3241
> sip:*01161428@sipbroker.com <mailto:01161428@sipbroker.com>
>
>
>
>
> --
> Steve Kieu

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
SIP Communicator
emcho@sip-communicator.org PHONE: +33.1.77.62.43.30
http://sip-communicator.org FAX: +33.1.77.62.47.31

--
Steve Kieu


#5

На 19.12.10 23:23, Steve Kieu написа:

Hello,

Sorry not to make it clear,

The modem forward all UDP 5060 to my ata linksys spa1001 - That is why
it affects sip-communicator (running on a computer in the same local
network) if it only can listen on port 5060 for incoming sip signal. I
need all other sip client in my home network to listen on different
port.

The fact that SIP Communicator listens on port 5060 should have
absolutely no impact on what port your NAT would map to it. If you've
already setup a static forward from your NAT's public address to your
SPA, then SIP Communicator would simply be assigned another port even if
it also uses 5060. This is how NATs work (although one can never count
on those for being consistent).

Cheers,
Emil

···

Hope that it is clear to you now.

Please find the log file attached.

Many thanks,

Regards,

On Sun, Dec 19, 2010 at 11:13 PM, Emil Ivov <emcho@sip-communicator.org > <mailto:emcho@sip-communicator.org>> wrote:

    Hey Steve,

    Could you please enable "Packet Logging" for all protocols in SIP
    Communicator's advanced settings and then send us the content of your
    log folder?

    (more inline)

    На 19.12.10 09:44, Steve Kieu написа:
    > Hi,
    >
    > I found where the problem is, is someone confirmed then file a bug
    >
    > The problem is that I do not use standard port 5060 for the
    client, and
    > one of the component (the sip handling module or the GUI reading sip
    > state still ask for port 5060?) does not honor the setting and changed
    > accordingly. Some where hard coded the port 5060.

    Changing the local SIP port in SIP Communicator is known to work and did
    not show any problems during our internal tests. This is why we'd need
    to see the logs.

    > Unfortunately I could not do that because I route all 5060 to my
    sipura
    > link sys device - this is the main telephone we use at home. So
    that bug
    > prevent me to use sipcommunicator .

    I am not sure I understand. How would your external device have anything
    to do with the port that SIP Communicator is using on your computer?

    Cheers,
    Emil

    >
    > Please confirmed and if possible fixed the bug. Many thanks.
    >
    >
    >
    >
    >
    > ---------- Forwarded message ----------
    > From: *Steve Kieu* <msh.computing@gmail.com
    <mailto:msh.computing@gmail.com>
    > <mailto:msh.computing@gmail.com <mailto:msh.computing@gmail.com>>>
    > Date: Sun, Dec 19, 2010 at 3:40 PM
    > Subject: Can not call out on Linux
    > To: dev@sip-communicator.dev.java.net
    <mailto:dev@sip-communicator.dev.java.net>
    > <mailto:dev@sip-communicator.dev.java.net
    <mailto:dev@sip-communicator.dev.java.net>>
    >
    >
    >
    > Hello,
    >
    > I tried sip-communicator to ring a phone number but the call
    window just
    > hang at message: Initialize call
    >
    > and I have to click hang up after a while and got he message in
    the console
    >
    > 15:15:06.776 SEVERE: impl.protocol.sip.
    > CallPeerSipImpl.hangup().777 Could not determine call peer state!
    >
    > The strange thing is that it used to work once - then not working
    - and
    > I suspect sun-java has some problem so I remove it and install
    openjdk-6
    > - after that it worked again. I exit the program and now just tried -
    > old problem happened.
    >
    > This is on Ubuntu Lucid update to date system ; and sip-communicator
    > version : 1.0-alpha6-nightly.build.3174
    >
    > I have not tried on window yet or another Linux distro yet.
    >
    > Many thanks
    >
    >
    > --
    > Steve Kieu
    > Ph: +61-7-3367-3241
    > sip:*01161428@sipbroker.com <mailto:01161428@sipbroker.com>
    <mailto:01161428@sipbroker.com <mailto:01161428@sipbroker.com>>
    >
    >
    >
    >
    > --
    > Steve Kieu

    --
    Emil Ivov, Ph.D. 67000 Strasbourg,
    Project Lead France
    SIP Communicator
    emcho@sip-communicator.org <mailto:emcho@sip-communicator.org>
                  PHONE: +33.1.77.62.43.30
    http://sip-communicator.org FAX: +33.1.77.62.47.31

--
Steve Kieu

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
SIP Communicator
emcho@sip-communicator.org PHONE: +33.1.77.62.43.30
http://sip-communicator.org FAX: +33.1.77.62.47.31

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#6

Hello there,

I will re test it tonight (Australian time) as I am at work now and no
longer access to the home network.

I am still positive that if I change back to 5060 - things work, if changed
to any other port, when calling out, the GUI just waiting and finally
failed.

Cheers,

···

On Mon, Dec 20, 2010 at 7:51 AM, Steve Kieu <msh.computing@gmail.com> wrote:

The fact that SIP Communicator listens on port 5060 should have

absolutely no impact on what port your NAT would map to it. If you've
already setup a static forward from your NAT's public address to your
SPA, then SIP Communicator would simply be assigned another port even if
it also uses 5060. This is how NATs work (although one can never count
on those for being consistent).

You are correct if the modem / firewall does correct port translation. I
will test tonight if mine does but I doubt it.

The fact this symptom is still a bug in simp-communicator somewhere.

Cheers,

Cheers,
Emil

> Hope that it is clear to you now.
>
> Please find the log file attached.
>
> Many thanks,
>
> Regards,
>
>
> On Sun, Dec 19, 2010 at 11:13 PM, Emil Ivov <emcho@sip-communicator.org >> > <mailto:emcho@sip-communicator.org>> wrote:
>
> Hey Steve,
>
> Could you please enable "Packet Logging" for all protocols in SIP
> Communicator's advanced settings and then send us the content of
your
> log folder?
>
> (more inline)
>
> На 19.12.10 09:44, Steve Kieu написа:
> > Hi,
> >
> > I found where the problem is, is someone confirmed then file a bug
> >
> > The problem is that I do not use standard port 5060 for the
> client, and
> > one of the component (the sip handling module or the GUI reading
sip
> > state still ask for port 5060?) does not honor the setting and
changed
> > accordingly. Some where hard coded the port 5060.
>
> Changing the local SIP port in SIP Communicator is known to work and
did
> not show any problems during our internal tests. This is why we'd
need
> to see the logs.
>
> > Unfortunately I could not do that because I route all 5060 to my
> sipura
> > link sys device - this is the main telephone we use at home. So
> that bug
> > prevent me to use sipcommunicator .
>
> I am not sure I understand. How would your external device have
anything
> to do with the port that SIP Communicator is using on your computer?
>
> Cheers,
> Emil
>
> >
> > Please confirmed and if possible fixed the bug. Many thanks.
> >
> >
> >
> >
> >
> > ---------- Forwarded message ----------
> > From: *Steve Kieu* <msh.computing@gmail.com
> <mailto:msh.computing@gmail.com>
> > <mailto:msh.computing@gmail.com <mailto:msh.computing@gmail.com
>>>
> > Date: Sun, Dec 19, 2010 at 3:40 PM
> > Subject: Can not call out on Linux
> > To: dev@sip-communicator.dev.java.net
> <mailto:dev@sip-communicator.dev.java.net>
> > <mailto:dev@sip-communicator.dev.java.net
> <mailto:dev@sip-communicator.dev.java.net>>
> >
> >
> >
> > Hello,
> >
> > I tried sip-communicator to ring a phone number but the call
> window just
> > hang at message: Initialize call
> >
> > and I have to click hang up after a while and got he message in
> the console
> >
> > 15:15:06.776 SEVERE: impl.protocol.sip.
> > CallPeerSipImpl.hangup().777 Could not determine call peer state!
> >
> > The strange thing is that it used to work once - then not working
> - and
> > I suspect sun-java has some problem so I remove it and install
> openjdk-6
> > - after that it worked again. I exit the program and now just
tried -
> > old problem happened.
> >
> > This is on Ubuntu Lucid update to date system ; and
sip-communicator
> > version : 1.0-alpha6-nightly.build.3174
> >
> > I have not tried on window yet or another Linux distro yet.
> >
> > Many thanks
> >
> >
> > --
> > Steve Kieu
> > Ph: +61-7-3367-3241
> > sip:*01161428@sipbroker.com <mailto:01161428@sipbroker.com>
> <mailto:01161428@sipbroker.com <mailto:01161428@sipbroker.com>>
> >
> >
> >
> >
> > --
> > Steve Kieu
>
> --
> Emil Ivov, Ph.D. 67000 Strasbourg,
> Project Lead France
> SIP Communicator
> emcho@sip-communicator.org <mailto:emcho@sip-communicator.org>
> PHONE: +33.1.77.62.43.30
> http://sip-communicator.org FAX:
+33.1.77.62.47.31
>
>
>
>
> --
> Steve Kieu

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
SIP Communicator
emcho@sip-communicator.org PHONE: +33.1.77.62.43.30
http://sip-communicator.org FAX: +33.1.77.62.47.31

--
Steve Kieu

--
Steve Kieu
Ph: +61-7-3367-3241
sip:*01161428@sipbroker.com


#7

Steve,

На 20.12.10 00:36, Steve Kieu написа:

Hello there,

I will re test it tonight (Australian time) as I am at work now and no
longer access to the home network.

I am still positive that if I change back to 5060 - things work, if
changed to any other port, when calling out, the GUI just waiting and
finally failed.

I already mentioned that we are unable to reproduce this and would need
logs in order to investigate.

Cheers,
Emil

···

Cheers,

On Mon, Dec 20, 2010 at 7:51 AM, Steve Kieu <msh.computing@gmail.com > <mailto:msh.computing@gmail.com>> wrote:

        The fact that SIP Communicator listens on port 5060 should have
        absolutely no impact on what port your NAT would map to it. If
        you've
        already setup a static forward from your NAT's public address to
        your
        SPA, then SIP Communicator would simply be assigned another port
        even if
        it also uses 5060. This is how NATs work (although one can never
        count
        on those for being consistent).

    You are correct if the modem / firewall does correct port
    translation. I will test tonight if mine does but I doubt it.

    The fact this symptom is still a bug in simp-communicator somewhere.

     Cheers,

        Cheers,
        Emil

        > Hope that it is clear to you now.
        >
        > Please find the log file attached.
        >
        > Many thanks,
        >
        > Regards,
        >
        >
        > On Sun, Dec 19, 2010 at 11:13 PM, Emil Ivov > <emcho@sip-communicator.org <mailto:emcho@sip-communicator.org> > > <mailto:emcho@sip-communicator.org > <mailto:emcho@sip-communicator.org>>> wrote:
        >
        > Hey Steve,
        >
        > Could you please enable "Packet Logging" for all protocols
        in SIP
        > Communicator's advanced settings and then send us the
        content of your
        > log folder?
        >
        > (more inline)
        >
        > На 19.12.10 09:44, Steve Kieu написа:
        > > Hi,
        > >
        > > I found where the problem is, is someone confirmed then
        file a bug
        > >
        > > The problem is that I do not use standard port 5060 for the
        > client, and
        > > one of the component (the sip handling module or the GUI
        reading sip
        > > state still ask for port 5060?) does not honor the
        setting and changed
        > > accordingly. Some where hard coded the port 5060.
        >
        > Changing the local SIP port in SIP Communicator is known
        to work and did
        > not show any problems during our internal tests. This is
        why we'd need
        > to see the logs.
        >
        > > Unfortunately I could not do that because I route all
        5060 to my
        > sipura
        > > link sys device - this is the main telephone we use at
        home. So
        > that bug
        > > prevent me to use sipcommunicator .
        >
        > I am not sure I understand. How would your external device
        have anything
        > to do with the port that SIP Communicator is using on your
        computer?
        >
        > Cheers,
        > Emil
        >
        > >
        > > Please confirmed and if possible fixed the bug. Many thanks.
        > >
        > >
        > >
        > >
        > >
        > > ---------- Forwarded message ----------
        > > From: *Steve Kieu* <msh.computing@gmail.com
        <mailto:msh.computing@gmail.com>
        > <mailto:msh.computing@gmail.com
        <mailto:msh.computing@gmail.com>>
        > > <mailto:msh.computing@gmail.com
        <mailto:msh.computing@gmail.com> <mailto:msh.computing@gmail.com
        <mailto:msh.computing@gmail.com>>>>
        > > Date: Sun, Dec 19, 2010 at 3:40 PM
        > > Subject: Can not call out on Linux
        > > To: dev@sip-communicator.dev.java.net
        <mailto:dev@sip-communicator.dev.java.net>
        > <mailto:dev@sip-communicator.dev.java.net
        <mailto:dev@sip-communicator.dev.java.net>>
        > > <mailto:dev@sip-communicator.dev.java.net
        <mailto:dev@sip-communicator.dev.java.net>
        > <mailto:dev@sip-communicator.dev.java.net
        <mailto:dev@sip-communicator.dev.java.net>>>
        > >
        > >
        > >
        > > Hello,
        > >
        > > I tried sip-communicator to ring a phone number but the call
        > window just
        > > hang at message: Initialize call
        > >
        > > and I have to click hang up after a while and got he
        message in
        > the console
        > >
        > > 15:15:06.776 SEVERE: impl.protocol.sip.
        > > CallPeerSipImpl.hangup().777 Could not determine call
        peer state!
        > >
        > > The strange thing is that it used to work once - then
        not working
        > - and
        > > I suspect sun-java has some problem so I remove it and
        install
        > openjdk-6
        > > - after that it worked again. I exit the program and now
        just tried -
        > > old problem happened.
        > >
        > > This is on Ubuntu Lucid update to date system ; and
        sip-communicator
        > > version : 1.0-alpha6-nightly.build.3174
        > >
        > > I have not tried on window yet or another Linux
        distro yet.
        > >
        > > Many thanks
        > >
        > >
        > > --
        > > Steve Kieu
        > > Ph: +61-7-3367-3241
        > > sip:*01161428@sipbroker.com
        <mailto:01161428@sipbroker.com> <mailto:01161428@sipbroker.com
        <mailto:01161428@sipbroker.com>>
        > <mailto:01161428@sipbroker.com
        <mailto:01161428@sipbroker.com> <mailto:01161428@sipbroker.com
        <mailto:01161428@sipbroker.com>>>
        > >
        > >
        > >
        > >
        > > --
        > > Steve Kieu
        >
        > --
        > Emil Ivov, Ph.D. 67000
        Strasbourg,
        > Project Lead France
        > SIP Communicator
        > emcho@sip-communicator.org
        <mailto:emcho@sip-communicator.org>
        <mailto:emcho@sip-communicator.org
        <mailto:emcho@sip-communicator.org>>
        > PHONE: +33.1.77.62.43.30
        > http://sip-communicator.org FAX:
        +33.1.77.62.47.31
        >
        >
        >
        >
        > --
        > Steve Kieu

        --
        Emil Ivov, Ph.D. 67000 Strasbourg,
        Project Lead France
        SIP Communicator
        emcho@sip-communicator.org <mailto:emcho@sip-communicator.org>
                          PHONE: +33.1.77.62.43.30
        http://sip-communicator.org FAX:
        +33.1.77.62.47.31

    --
    Steve Kieu

--
Steve Kieu
Ph: +61-7-3367-3241
sip:*01161428@sipbroker.com <mailto:01161428@sipbroker.com>

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
SIP Communicator
emcho@sip-communicator.org PHONE: +33.1.77.62.43.30
http://sip-communicator.org FAX: +33.1.77.62.47.31

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#8

Hi,

I was looking at the pcap logs and it seems to me the problem comes
from the big udp packets (1606). Can you make a simple experiment, try
going into Configuration under Audio and swtich off some of the
codecs, maybe disable and the video and try again.

Regards
damencho

···

On Mon, Dec 20, 2010 at 12:39 AM, Emil Ivov <emcho@sip-communicator.org> wrote:

Steve,

На 20.12.10 00:36, Steve Kieu написа:

Hello there,

I will re test it tonight (Australian time) as I am at work now and no
longer access to the home network.

I am still positive that if I change back to 5060 - things work, if
changed to any other port, when calling out, the GUI just waiting and
finally failed.

I already mentioned that we are unable to reproduce this and would need
logs in order to investigate.

Cheers,
Emil

Cheers,

On Mon, Dec 20, 2010 at 7:51 AM, Steve Kieu <msh.computing@gmail.com >> <mailto:msh.computing@gmail.com>> wrote:

    The fact that SIP Communicator listens on port 5060 should have
    absolutely no impact on what port your NAT would map to it\. If
    you&#39;ve
    already setup a static forward from your NAT&#39;s public address to
    your
    SPA, then SIP Communicator would simply be assigned another port
    even if
    it also uses 5060\. This is how NATs work \(although one can never
    count
    on those for being consistent\)\.

You are correct if the modem / firewall does correct port
translation\. I will test tonight if mine does but I doubt it\.

The fact this symptom is still a bug in simp\-communicator somewhere\.

 Cheers,

    Cheers,
    Emil

    &gt; Hope that it is clear to you now\.
    &gt;
    &gt; Please find the log file attached\.
    &gt;
    &gt; Many thanks,
    &gt;
    &gt; Regards,
    &gt;
    &gt;
    &gt; On Sun, Dec 19, 2010 at 11:13 PM, Emil Ivov &gt;&gt;         &lt;emcho@sip\-communicator\.org &lt;mailto:emcho@sip\-communicator\.org&gt; &gt;&gt;         &gt; &lt;mailto:emcho@sip\-communicator\.org &gt;&gt;         &lt;mailto:emcho@sip\-communicator\.org&gt;&gt;&gt; wrote:
    &gt;
    &gt;     Hey Steve,
    &gt;
    &gt;     Could you please enable &quot;Packet Logging&quot; for all protocols
    in SIP
    &gt;     Communicator&#39;s advanced settings and then send us the
    content of your
    &gt;     log folder?
    &gt;
    &gt;     \(more inline\)
    &gt;
    &gt;     На 19\.12\.10 09:44, Steve Kieu написа:
    &gt;     &gt; Hi,
    &gt;     &gt;
    &gt;     &gt; I found where the problem is, is someone confirmed then
    file a bug
    &gt;     &gt;
    &gt;     &gt; The problem is that I do not use standard port 5060 for the
    &gt;     client, and
    &gt;     &gt; one of the component \(the sip handling module or the GUI
    reading sip
    &gt;     &gt; state still ask for port 5060?\) does not honor the
    setting and changed
    &gt;     &gt; accordingly\. Some where hard coded the port 5060\.
    &gt;
    &gt;     Changing the local SIP port in SIP Communicator is known
    to work and did
    &gt;     not show any problems during our internal tests\. This is
    why we&#39;d need
    &gt;     to see the logs\.
    &gt;
    &gt;     &gt; Unfortunately I could not do that because I route all
    5060 to my
    &gt;     sipura
    &gt;     &gt; link sys device \- this is the main telephone we use at
    home\. So
    &gt;     that bug
    &gt;     &gt; prevent me to use sipcommunicator \.
    &gt;
    &gt;     I am not sure I understand\. How would your external device
    have anything
    &gt;     to do with the port that SIP Communicator is using on your
    computer?
    &gt;
    &gt;     Cheers,
    &gt;     Emil
    &gt;
    &gt;     &gt;
    &gt;     &gt; Please confirmed and if possible fixed the bug\. Many thanks\.
    &gt;     &gt;
    &gt;     &gt;
    &gt;     &gt;
    &gt;     &gt;
    &gt;     &gt;
    &gt;     &gt; \-\-\-\-\-\-\-\-\-\- Forwarded message \-\-\-\-\-\-\-\-\-\-
    &gt;     &gt; From: \*Steve Kieu\* &lt;msh\.computing@gmail\.com
    &lt;mailto:msh\.computing@gmail\.com&gt;
    &gt;     &lt;mailto:msh\.computing@gmail\.com
    &lt;mailto:msh\.computing@gmail\.com&gt;&gt;
    &gt;     &gt; &lt;mailto:msh\.computing@gmail\.com
    &lt;mailto:msh\.computing@gmail\.com&gt; &lt;mailto:msh\.computing@gmail\.com
    &lt;mailto:msh\.computing@gmail\.com&gt;&gt;&gt;&gt;
    &gt;     &gt; Date: Sun, Dec 19, 2010 at 3:40 PM
    &gt;     &gt; Subject: Can not call out on Linux
    &gt;     &gt; To: dev@sip\-communicator\.dev\.java\.net
    &lt;mailto:dev@sip\-communicator\.dev\.java\.net&gt;
    &gt;     &lt;mailto:dev@sip\-communicator\.dev\.java\.net
    &lt;mailto:dev@sip\-communicator\.dev\.java\.net&gt;&gt;
    &gt;     &gt; &lt;mailto:dev@sip\-communicator\.dev\.java\.net
    &lt;mailto:dev@sip\-communicator\.dev\.java\.net&gt;
    &gt;     &lt;mailto:dev@sip\-communicator\.dev\.java\.net
    &lt;mailto:dev@sip\-communicator\.dev\.java\.net&gt;&gt;&gt;
    &gt;     &gt;
    &gt;     &gt;
    &gt;     &gt;
    &gt;     &gt; Hello,
    &gt;     &gt;
    &gt;     &gt; I tried sip\-communicator to ring a phone number but the call
    &gt;     window just
    &gt;     &gt; hang at message: Initialize call
    &gt;     &gt;
    &gt;     &gt; and I have to click hang up after a while and got he
    message in
    &gt;     the console
    &gt;     &gt;
    &gt;     &gt; 15:15:06\.776 SEVERE: impl\.protocol\.sip\.
    &gt;     &gt; CallPeerSipImpl\.hangup\(\)\.777 Could not determine call
    peer state\!
    &gt;     &gt;
    &gt;     &gt; The strange thing is that it used to work once \- then
    not working
    &gt;     \- and
    &gt;     &gt; I suspect sun\-java has some problem so I remove it and
    install
    &gt;     openjdk\-6
    &gt;     &gt; \- after that it worked again\. I exit the program and now
    just tried \-
    &gt;     &gt; old problem happened\.
    &gt;     &gt;
    &gt;     &gt; This is on Ubuntu Lucid update to date system ; and
    sip\-communicator
    &gt;     &gt; version :  1\.0\-alpha6\-nightly\.build\.3174
    &gt;     &gt;
    &gt;     &gt; I have not tried on window yet  or another   Linux
    distro yet\.
    &gt;     &gt;
    &gt;     &gt; Many thanks
    &gt;     &gt;
    &gt;     &gt;
    &gt;     &gt; \-\-
    &gt;     &gt; Steve Kieu
    &gt;     &gt; Ph: \+61\-7\-3367\-3241
    &gt;     &gt; sip:\*01161428@sipbroker\.com
    &lt;mailto:01161428@sipbroker\.com&gt; &lt;mailto:01161428@sipbroker\.com
    &lt;mailto:01161428@sipbroker\.com&gt;&gt;
    &gt;     &lt;mailto:01161428@sipbroker\.com
    &lt;mailto:01161428@sipbroker\.com&gt; &lt;mailto:01161428@sipbroker\.com
    &lt;mailto:01161428@sipbroker\.com&gt;&gt;&gt;
    &gt;     &gt;
    &gt;     &gt;
    &gt;     &gt;
    &gt;     &gt;
    &gt;     &gt; \-\-
    &gt;     &gt; Steve Kieu
    &gt;
    &gt;     \-\-
    &gt;     Emil Ivov, Ph\.D\.                               67000
    Strasbourg,
    &gt;     Project Lead                                   France
    &gt;     SIP Communicator
    &gt;     emcho@sip\-communicator\.org
    &lt;mailto:emcho@sip\-communicator\.org&gt;
    &lt;mailto:emcho@sip\-communicator\.org
    &lt;mailto:emcho@sip\-communicator\.org&gt;&gt;
    &gt;                   PHONE: \+33\.1\.77\.62\.43\.30
    &gt;     http://sip-communicator.org                    FAX:
    \+33\.1\.77\.62\.47\.31
    &gt;
    &gt;
    &gt;
    &gt;
    &gt; \-\-
    &gt; Steve Kieu

    \-\-
    Emil Ivov, Ph\.D\.                               67000 Strasbourg,
    Project Lead                                   France
    SIP Communicator
    emcho@sip\-communicator\.org &lt;mailto:emcho@sip\-communicator\.org&gt;
                      PHONE: \+33\.1\.77\.62\.43\.30
    http://sip-communicator.org                    FAX:
    \+33\.1\.77\.62\.47\.31

\-\-
Steve Kieu

--
Steve Kieu
Ph: +61-7-3367-3241
sip:*01161428@sipbroker.com <mailto:01161428@sipbroker.com>

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
SIP Communicator
emcho@sip-communicator.org PHONE: +33.1.77.62.43.30
http://sip-communicator.org FAX: +33.1.77.62.47.31

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#9

I was looking at the pcap logs and it seems to me the problem comes

from the big udp packets (1606). Can you make a simple experiment, try
going into Configuration under Audio and swtich off some of the
codecs, maybe disable and the video and try again.

That *makes* difference.

I disabled all except g728/800 g722/16000 g723, pcmu ilbc, gsm and
telephone-event - Video before is alrady off.

I can make out call - even with sip client port set to 5065 and secure sip
port 5066. I will leave it for an hour and then continue another test to see
if it still works.

Thanks very much

···

Regards
damencho

On Mon, Dec 20, 2010 at 12:39 AM, Emil Ivov <emcho@sip-communicator.org> > wrote:
> Steve,
>
> На 20.12.10 00:36, Steve Kieu написа:
>> Hello there,
>>
>> I will re test it tonight (Australian time) as I am at work now and no
>> longer access to the home network.
>>
>> I am still positive that if I change back to 5060 - things work, if
>> changed to any other port, when calling out, the GUI just waiting and
>> finally failed.
>
> I already mentioned that we are unable to reproduce this and would need
> logs in order to investigate.
>
> Cheers,
> Emil
>
>> Cheers,
>>
>>
>>
>> On Mon, Dec 20, 2010 at 7:51 AM, Steve Kieu <msh.computing@gmail.com > >> <mailto:msh.computing@gmail.com>> wrote:
>>
>>
>> The fact that SIP Communicator listens on port 5060 should have
>> absolutely no impact on what port your NAT would map to it. If
>> you've
>> already setup a static forward from your NAT's public address to
>> your
>> SPA, then SIP Communicator would simply be assigned another port
>> even if
>> it also uses 5060. This is how NATs work (although one can never
>> count
>> on those for being consistent).
>>
>>
>>
>> You are correct if the modem / firewall does correct port
>> translation. I will test tonight if mine does but I doubt it.
>>
>> The fact this symptom is still a bug in simp-communicator somewhere.
>>
>> Cheers,
>>
>>
>>
>>
>> Cheers,
>> Emil
>>
>> > Hope that it is clear to you now.
>> >
>> > Please find the log file attached.
>> >
>> > Many thanks,
>> >
>> > Regards,
>> >
>> >
>> > On Sun, Dec 19, 2010 at 11:13 PM, Emil Ivov > >> <emcho@sip-communicator.org <mailto:emcho@sip-communicator.org> > >> > <mailto:emcho@sip-communicator.org > >> <mailto:emcho@sip-communicator.org>>> wrote:
>> >
>> > Hey Steve,
>> >
>> > Could you please enable "Packet Logging" for all protocols
>> in SIP
>> > Communicator's advanced settings and then send us the
>> content of your
>> > log folder?
>> >
>> > (more inline)
>> >
>> > На 19.12.10 09:44, Steve Kieu написа:
>> > > Hi,
>> > >
>> > > I found where the problem is, is someone confirmed then
>> file a bug
>> > >
>> > > The problem is that I do not use standard port 5060 for
the
>> > client, and
>> > > one of the component (the sip handling module or the GUI
>> reading sip
>> > > state still ask for port 5060?) does not honor the
>> setting and changed
>> > > accordingly. Some where hard coded the port 5060.
>> >
>> > Changing the local SIP port in SIP Communicator is known
>> to work and did
>> > not show any problems during our internal tests. This is
>> why we'd need
>> > to see the logs.
>> >
>> > > Unfortunately I could not do that because I route all
>> 5060 to my
>> > sipura
>> > > link sys device - this is the main telephone we use at
>> home. So
>> > that bug
>> > > prevent me to use sipcommunicator .
>> >
>> > I am not sure I understand. How would your external device
>> have anything
>> > to do with the port that SIP Communicator is using on your
>> computer?
>> >
>> > Cheers,
>> > Emil
>> >
>> > >
>> > > Please confirmed and if possible fixed the bug. Many
thanks.
>> > >
>> > >
>> > >
>> > >
>> > >
>> > > ---------- Forwarded message ----------
>> > > From: *Steve Kieu* <msh.computing@gmail.com
>> <mailto:msh.computing@gmail.com>
>> > <mailto:msh.computing@gmail.com
>> <mailto:msh.computing@gmail.com>>
>> > > <mailto:msh.computing@gmail.com
>> <mailto:msh.computing@gmail.com> <mailto:
msh.computing@gmail.com
>> <mailto:msh.computing@gmail.com>>>>
>> > > Date: Sun, Dec 19, 2010 at 3:40 PM
>> > > Subject: Can not call out on Linux
>> > > To: dev@sip-communicator.dev.java.net
>> <mailto:dev@sip-communicator.dev.java.net>
>> > <mailto:dev@sip-communicator.dev.java.net
>> <mailto:dev@sip-communicator.dev.java.net>>
>> > > <mailto:dev@sip-communicator.dev.java.net
>> <mailto:dev@sip-communicator.dev.java.net>
>> > <mailto:dev@sip-communicator.dev.java.net
>> <mailto:dev@sip-communicator.dev.java.net>>>
>> > >
>> > >
>> > >
>> > > Hello,
>> > >
>> > > I tried sip-communicator to ring a phone number but the
call
>> > window just
>> > > hang at message: Initialize call
>> > >
>> > > and I have to click hang up after a while and got he
>> message in
>> > the console
>> > >
>> > > 15:15:06.776 SEVERE: impl.protocol.sip.
>> > > CallPeerSipImpl.hangup().777 Could not determine call
>> peer state!
>> > >
>> > > The strange thing is that it used to work once - then
>> not working
>> > - and
>> > > I suspect sun-java has some problem so I remove it and
>> install
>> > openjdk-6
>> > > - after that it worked again. I exit the program and now
>> just tried -
>> > > old problem happened.
>> > >
>> > > This is on Ubuntu Lucid update to date system ; and
>> sip-communicator
>> > > version : 1.0-alpha6-nightly.build.3174
>> > >
>> > > I have not tried on window yet or another Linux
>> distro yet.
>> > >
>> > > Many thanks
>> > >
>> > >
>> > > --
>> > > Steve Kieu
>> > > Ph: +61-7-3367-3241
>> > > sip:*01161428@sipbroker.com
>> <mailto:01161428@sipbroker.com> <mailto:01161428@sipbroker.com
>> <mailto:01161428@sipbroker.com>>
>> > <mailto:01161428@sipbroker.com
>> <mailto:01161428@sipbroker.com> <mailto:01161428@sipbroker.com
>> <mailto:01161428@sipbroker.com>>>
>> > >
>> > >
>> > >
>> > >
>> > > --
>> > > Steve Kieu
>> >
>> > --
>> > Emil Ivov, Ph.D. 67000
>> Strasbourg,
>> > Project Lead France
>> > SIP Communicator
>> > emcho@sip-communicator.org
>> <mailto:emcho@sip-communicator.org>
>> <mailto:emcho@sip-communicator.org
>> <mailto:emcho@sip-communicator.org>>
>> > PHONE: +33.1.77.62.43.30
>> > http://sip-communicator.org FAX:
>> +33.1.77.62.47.31
>> >
>> >
>> >
>> >
>> > --
>> > Steve Kieu
>>
>> --
>> Emil Ivov, Ph.D. 67000 Strasbourg,
>> Project Lead France
>> SIP Communicator
>> emcho@sip-communicator.org <mailto:emcho@sip-communicator.org>
>> PHONE: +33.1.77.62.43.30
>> http://sip-communicator.org FAX:
>> +33.1.77.62.47.31
>>
>>
>>
>>
>> --
>> Steve Kieu
>>
>>
>>
>>
>> --
>> Steve Kieu
>> Ph: +61-7-3367-3241
>> sip:*01161428@sipbroker.com <mailto:01161428@sipbroker.com>
>>
>
> --
> Emil Ivov, Ph.D. 67000 Strasbourg,
> Project Lead France
> SIP Communicator
> emcho@sip-communicator.org PHONE: +33.1.77.62.43.30
> http://sip-communicator.org FAX: +33.1.77.62.47.31
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
> For additional commands, e-mail: dev-help@sip-communicator.dev.java.net
>
>

--
Steve Kieu