[sip-comm-dev] audio not working in sip-comunicator


#1

Dear All,

I have downloaded sip-communicator from svn and installed on 2 linux x-86
machine running fedora core 8 release.

i have registered 2 accounts for sip from iptel.org.

i am able to chat between 2 accounts but when i try to call, the ringtone is
coming and when the other user attends the call, he is not able to hear the
audio speech.

i have no firewall. i checked with telnet,

telnet iptel.org 5060 and telnet session opens.

is audio packets being dropped some where.

guys help me sort out this issue.

HarishKumar.V


#2

Hello HarishKumar,

You should have try to have a look on the RTP traffic with wireshark and
determine whether media goes both ways. You could also try inspecting
your logs and eventually send them this list in case any errors were
reported there.

Cheers
Emil

P.S. There's no need to post such questions to both our dev and users
list. Sending them here is more than enough.

Harishkumar V wrote:

···

Dear All,

I have downloaded sip-communicator from svn and installed on 2 linux
x-86 machine running fedora core 8 release.

i have registered 2 accounts for sip from iptel.org <http://iptel.org>.

i am able to chat between 2 accounts but when i try to call, the
ringtone is coming and when the other user attends the call, he is not
able to hear the audio speech.

i have no firewall. i checked with telnet,

telnet iptel.org <http://iptel.org> 5060 and telnet session opens.

is audio packets being dropped some where.

guys help me sort out this issue.

HarishKumar.V

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#3

Hi HarishKumar,

you might also try audio testing using only your router/network switch by using
registerless mode form LAN IP to LAN IP. Then try registerless mode using
WAN IP address of your router. This may help you to find the problem.

Regards, Earl

Emil Ivov wrote:

···

Hello HarishKumar,

You should have try to have a look on the RTP traffic with wireshark and
determine whether media goes both ways. You could also try inspecting
your logs and eventually send them this list in case any errors were
reported there.

Cheers
Emil

P.S. There's no need to post such questions to both our dev and users
list. Sending them here is more than enough.

Harishkumar V wrote:
  

Dear All,

I have downloaded sip-communicator from svn and installed on 2 linux
x-86 machine running fedora core 8 release.

i have registered 2 accounts for sip from iptel.org <http://iptel.org>.

i am able to chat between 2 accounts but when i try to call, the
ringtone is coming and when the other user attends the call, he is not
able to hear the audio speech.

i have no firewall. i checked with telnet,

telnet iptel.org <http://iptel.org> 5060 and telnet session opens.

is audio packets being dropped some where.

guys help me sort out this issue.

HarishKumar.V

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net