[sip-comm] Debian repository


#1

Hello Debian users of the SIP Communicator,

we have created a Debian repository for the project which can be used by adding the following line in your /etc/apt/sources.list file:

"deb http://download.java.net/communications/sip-communicator/debian binary/"

Then you can install the package named sip-communicator after updating your cache files with "apt-get update && install sip-communicator".

This package is now build nightly and archived at http://download.java.net/communications/sip-communicator/nightly/debian/

However you should know that the naming of the nightly package may change once we have a release. Typically we will have 2 packages after the release: sip-communicator and sip-communicator-cvs. Until now, please install sip-communicator.

Stay tuned,
Martin

···

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net


#2

Once again great news! Thanks Martin!

I am already using the repository :). Feels nice to get the upgrade with apt-get upgrade we're getting very close to the alpha1 release!

Cheers
Emil

Martin Andr� wrote:

···

Hello Debian users of the SIP Communicator,

we have created a Debian repository for the project which can be used by adding the following line in your /etc/apt/sources.list file:

"deb http://download.java.net/communications/sip-communicator/debian binary/"

Then you can install the package named sip-communicator after updating your cache files with "apt-get update && install sip-communicator".

This package is now build nightly and archived at http://download.java.net/communications/sip-communicator/nightly/debian/

However you should know that the naming of the nightly package may change once we have a release. Typically we will have 2 packages after the release: sip-communicator and sip-communicator-cvs. Until now, please install sip-communicator.

Stay tuned,
Martin

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#3

Hi Martin,

I was wondering what must be done so that we have and "amd64" repository not only i386 ?
I tried and if I change in resources/install/debian/control.tmpl :
-Architecture: i386
+Architecture: amd64
The package installs and runs ok. So what have to be done to build both of those packages?
The only difference will be the jdic native libs, which I have successfully compiled and run on that platform.
Without them sip-communicator is unusable on this platform.

Thanks
damencho

Emil Ivov wrote:

···

Once again great news! Thanks Martin!

I am already using the repository :). Feels nice to get the upgrade with apt-get upgrade we're getting very close to the alpha1 release!

Cheers
Emil

Martin Andr� wrote:

Hello Debian users of the SIP Communicator,

we have created a Debian repository for the project which can be used by adding the following line in your /etc/apt/sources.list file:

"deb http://download.java.net/communications/sip-communicator/debian binary/"

Then you can install the package named sip-communicator after updating your cache files with "apt-get update && install sip-communicator".

This package is now build nightly and archived at http://download.java.net/communications/sip-communicator/nightly/debian/

However you should know that the naming of the nightly package may change once we have a release. Typically we will have 2 packages after the release: sip-communicator and sip-communicator-cvs. Until now, please install sip-communicator.

Stay tuned,
Martin

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#4

Hey Damien,

I thought that SC wouldn't run on amd64 because of jmf. It's good to know. Would you commit your jdict libs for amd64, I'll take care of the rest. This needs to be made automatically in the build.xml and might also need a slight modification in the layout of the debian repository.
I wanted make some modification anyway to sign those repositories.

Cheers,
Martin

Damian Minkov wrote:

···

Hi Martin,

I was wondering what must be done so that we have and "amd64" repository not only i386 ?
I tried and if I change in resources/install/debian/control.tmpl :
-Architecture: i386
+Architecture: amd64
The package installs and runs ok. So what have to be done to build both of those packages?
The only difference will be the jdic native libs, which I have successfully compiled and run on that platform.
Without them sip-communicator is unusable on this platform.

Thanks
damencho

Emil Ivov wrote:

Once again great news! Thanks Martin!

I am already using the repository :). Feels nice to get the upgrade with apt-get upgrade we're getting very close to the alpha1 release!

Cheers
Emil

Martin Andr� wrote:

Hello Debian users of the SIP Communicator,

we have created a Debian repository for the project which can be used by adding the following line in your /etc/apt/sources.list file:

"deb http://download.java.net/communications/sip-communicator/debian binary/"

Then you can install the package named sip-communicator after updating your cache files with "apt-get update && install sip-communicator".

This package is now build nightly and archived at http://download.java.net/communications/sip-communicator/nightly/debian/

However you should know that the naming of the nightly package may change once we have a release. Typically we will have 2 packages after the release: sip-communicator and sip-communicator-cvs. Until now, please install sip-communicator.

Stay tuned,
Martin

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#5

Hi,

yes you are right about jmf it doesn't run there, so you cannot use the media service. When we move to fmj this will be fixed :wink:
But without jdic libs you cannot start sip-communicator, actually its started but without the systray service and so if you close it once
you cannot open it no more. Maybe and this must be fixed in the source.
But also if you add the debian repository to your apt list you cannot install sip-communicator
cause there is only i386 pakage.
I've committed the libs in lib/native/linux-64.
I've compiled them on my machine and they are working I hope someone can test them and confirm that they are
working OK on other machines :slight_smile:

Thanks
damencho

Martin Andr� wrote:

···

Hey Damien,

I thought that SC wouldn't run on amd64 because of jmf. It's good to know. Would you commit your jdict libs for amd64, I'll take care of the rest. This needs to be made automatically in the build.xml and might also need a slight modification in the layout of the debian repository.
I wanted make some modification anyway to sign those repositories.

Cheers,
Martin

Damian Minkov wrote:

Hi Martin,

I was wondering what must be done so that we have and "amd64" repository not only i386 ?
I tried and if I change in resources/install/debian/control.tmpl :
-Architecture: i386
+Architecture: amd64
The package installs and runs ok. So what have to be done to build both of those packages?
The only difference will be the jdic native libs, which I have successfully compiled and run on that platform.
Without them sip-communicator is unusable on this platform.

Thanks
damencho

Emil Ivov wrote:

Once again great news! Thanks Martin!

I am already using the repository :). Feels nice to get the upgrade with apt-get upgrade we're getting very close to the alpha1 release!

Cheers
Emil

Martin Andr� wrote:

Hello Debian users of the SIP Communicator,

we have created a Debian repository for the project which can be used by adding the following line in your /etc/apt/sources.list file:

"deb http://download.java.net/communications/sip-communicator/debian binary/"

Then you can install the package named sip-communicator after updating your cache files with "apt-get update && install sip-communicator".

This package is now build nightly and archived at http://download.java.net/communications/sip-communicator/nightly/debian/

However you should know that the naming of the nightly package may change once we have a release. Typically we will have 2 packages after the release: sip-communicator and sip-communicator-cvs. Until now, please install sip-communicator.

Stay tuned,
Martin

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#6

Hi Damian,

I've commited earlier today a modification that builds the amd64 package in addition to the i386 one invoking "ant deb". I've not enabled it in the "deb-rel" ant task however, meaning that the amd64 package is not yet in the repository. Could you review the change and test the package?
I'll make the necessary changes to the repository if the package works as expected.

Cheers,
Martin

Damian Minkov wrote:

···

Hi,

yes you are right about jmf it doesn't run there, so you cannot use the media service. When we move to fmj this will be fixed :wink:
But without jdic libs you cannot start sip-communicator, actually its started but without the systray service and so if you close it once
you cannot open it no more. Maybe and this must be fixed in the source.
But also if you add the debian repository to your apt list you cannot install sip-communicator
cause there is only i386 pakage.
I've committed the libs in lib/native/linux-64.
I've compiled them on my machine and they are working I hope someone can test them and confirm that they are
working OK on other machines :slight_smile:

Thanks
damencho

Martin Andr� wrote:

Hey Damien,

I thought that SC wouldn't run on amd64 because of jmf. It's good to know. Would you commit your jdict libs for amd64, I'll take care of the rest. This needs to be made automatically in the build.xml and might also need a slight modification in the layout of the debian repository.
I wanted make some modification anyway to sign those repositories.

Cheers,
Martin

Damian Minkov wrote:

Hi Martin,

I was wondering what must be done so that we have and "amd64" repository not only i386 ?
I tried and if I change in resources/install/debian/control.tmpl :
-Architecture: i386
+Architecture: amd64
The package installs and runs ok. So what have to be done to build both of those packages?
The only difference will be the jdic native libs, which I have successfully compiled and run on that platform.
Without them sip-communicator is unusable on this platform.

Thanks
damencho

Emil Ivov wrote:

Once again great news! Thanks Martin!

I am already using the repository :). Feels nice to get the upgrade with apt-get upgrade we're getting very close to the alpha1 release!

Cheers
Emil

Martin Andr� wrote:

Hello Debian users of the SIP Communicator,

we have created a Debian repository for the project which can be used by adding the following line in your /etc/apt/sources.list file:

"deb http://download.java.net/communications/sip-communicator/debian binary/"

Then you can install the package named sip-communicator after updating your cache files with "apt-get update && install sip-communicator".

This package is now build nightly and archived at http://download.java.net/communications/sip-communicator/nightly/debian/

However you should know that the naming of the nightly package may change once we have a release. Typically we will have 2 packages after the release: sip-communicator and sip-communicator-cvs. Until now, please install sip-communicator.

Stay tuned,
Martin

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#7

Hi,

I've tested it and it works for me :slight_smile:

Thanks
damencho

Martin Andr� wrote:

···

Hi Damian,

I've commited earlier today a modification that builds the amd64 package in addition to the i386 one invoking "ant deb". I've not enabled it in the "deb-rel" ant task however, meaning that the amd64 package is not yet in the repository. Could you review the change and test the package?
I'll make the necessary changes to the repository if the package works as expected.

Cheers,
Martin

Damian Minkov wrote:

Hi,

yes you are right about jmf it doesn't run there, so you cannot use the media service. When we move to fmj this will be fixed :wink:
But without jdic libs you cannot start sip-communicator, actually its started but without the systray service and so if you close it once
you cannot open it no more. Maybe and this must be fixed in the source.
But also if you add the debian repository to your apt list you cannot install sip-communicator
cause there is only i386 pakage.
I've committed the libs in lib/native/linux-64.
I've compiled them on my machine and they are working I hope someone can test them and confirm that they are
working OK on other machines :slight_smile:

Thanks
damencho

Martin Andr� wrote:

Hey Damien,

I thought that SC wouldn't run on amd64 because of jmf. It's good to know. Would you commit your jdict libs for amd64, I'll take care of the rest. This needs to be made automatically in the build.xml and might also need a slight modification in the layout of the debian repository.
I wanted make some modification anyway to sign those repositories.

Cheers,
Martin

Damian Minkov wrote:

Hi Martin,

I was wondering what must be done so that we have and "amd64" repository not only i386 ?
I tried and if I change in resources/install/debian/control.tmpl :
-Architecture: i386
+Architecture: amd64
The package installs and runs ok. So what have to be done to build both of those packages?
The only difference will be the jdic native libs, which I have successfully compiled and run on that platform.
Without them sip-communicator is unusable on this platform.

Thanks
damencho

Emil Ivov wrote:

Once again great news! Thanks Martin!

I am already using the repository :). Feels nice to get the upgrade with apt-get upgrade we're getting very close to the alpha1 release!

Cheers
Emil

Martin Andr� wrote:

Hello Debian users of the SIP Communicator,

we have created a Debian repository for the project which can be used by adding the following line in your /etc/apt/sources.list file:

"deb http://download.java.net/communications/sip-communicator/debian binary/"

Then you can install the package named sip-communicator after updating your cache files with "apt-get update && install sip-communicator".

This package is now build nightly and archived at http://download.java.net/communications/sip-communicator/nightly/debian/

However you should know that the naming of the nightly package may change once we have a release. Typically we will have 2 packages after the release: sip-communicator and sip-communicator-cvs. Until now, please install sip-communicator.

Stay tuned,
Martin

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net