[sip-comm] Custom audio source instead of mic is chunked


#1

Hello,

I'm currently trying to use sip-communicator to send audio from an application to a phone.
I made a custom PullBufferDataSource and PullBufferStream receiving audio packets from network.
It's playing just fine when I pass the data source to a Player.

But then when I give my data source to the MediaManager instead of the audio from the microphone, the audio is chunked every second by a noise (half a second).
I tried to handle my data source first to a Processor to give it the same format as the original mic (AudioFormat.LINEAR, 44100, 16, 1), but the problem remains the same...

Do you know why this is happening ?
Could this be a problem of buffer size (my read method returns Buffers of 2048 bytes)?
Is it the RTP Processor ?
Is sip-communicator doing some other processing on this audio before sending it ?

Thanks for any help !

Julien

···

___________________________________________________________________________Appel audio GRATUIT partout dans le monde avec le nouveau Yahoo! MessengerT�l�chargez cette version sur http://fr.messenger.yahoo.com

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net


#2

Hello Julien,

I personally don't have the time to get deep into the problem but wanted to reply to that:

Is sip-communicator doing some other processing on this audio before sending it ?

No. All media processing is done by JMF so the problem should be somewhere there.

Good luck!
Emil

···

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net