[sip-comm] Bug: groups disappear in SIP account after closing preferences


#1

I write here to get a confirmation before opening tickets.

I'm using alpha3 on ubuntu 8.04.

1.

I have only a sip account. I create a group (and contacts, but it doesn't
matter, same behavior), then I go to settings and when I close them (push
ok, not cancel), the group and the contacts are not shown or not clickable
(like if they are deleted but still visible).

When I reopen the client, they are gone.

2.

When I select Override server default options, it's not saved the next time
I restart the application or open preferences (actually it could be totally
ignored in the first place).

3.

Sometimes pressing the tray icon no menu appears (or just flickers for a
moment and disappears immediately)

4.

Using presence the client send a lot of continuous SUBSCRIBE until they
interleave in the wrong way with some NOTIFY and I receive a 500 Request out
of order. Then it stops to send SUBSCRIBES.

I am using it from only few hours, so expect other bug reports. J

Cheers


#2

Hello Diego,

I'm wondering if the write permissions on your ~/.sip-communicator directory are enabled ?

Cheers,
Ben

Diego Costantini a �crit :

···

I write here to get a confirmation before opening tickets.

I�m using alpha3 on ubuntu 8.04.

1.

I have only a sip account. I create a group (and contacts, but it doesn�t matter, same behavior), then I go to settings and when I close them (push ok, not cancel), the group and the contacts are not shown or not clickable (like if they are deleted but still visible).

When I reopen the client, they are gone.

2.

When I select Override server default options, it�s not saved the next time I restart the application or open preferences (actually it could be totally ignored in the first place).

3.

Sometimes pressing the tray icon no menu appears (or just flickers for a moment and disappears immediately)

4.

Using presence the client send a lot of continuous SUBSCRIBE until they interleave in the wrong way with some NOTIFY and I receive a 500 Request out of order. Then it stops to send SUBSCRIBES.

I am using it from only few hours, so expect other bug reports. J

Cheers

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net


#3

I thought the same, and actually i reproduced a problem to load the application just forbidding write permissions to that file or filling up the hard disk (makes sense), but the rest of the time the permissions should have been correct, i also installed it from repository, thus i expected correct ones by default.

I'll try again as soon as possible.

Thanks

Benoit Pradelle wrote:

···

Hello Diego,

I'm wondering if the write permissions on your ~/.sip-communicator directory are enabled ?

Cheers,
Ben

Diego Costantini a �crit :

I write here to get a confirmation before opening tickets.

I�m using alpha3 on ubuntu 8.04.

1.

I have only a sip account. I create a group (and contacts, but it doesn�t matter, same behavior), then I go to settings and when I close them (push ok, not cancel), the group and the contacts are not shown or not clickable (like if they are deleted but still visible).

When I reopen the client, they are gone.

2.

When I select Override server default options, it�s not saved the next time I restart the application or open preferences (actually it could be totally ignored in the first place).

3.

Sometimes pressing the tray icon no menu appears (or just flickers for a moment and disappears immediately)

4.

Using presence the client send a lot of continuous SUBSCRIBE until they interleave in the wrong way with some NOTIFY and I receive a 500 Request out of order. Then it stops to send SUBSCRIBES.

I am using it from only few hours, so expect other bug reports. J

Cheers

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net