SIP Call ongoing but no audio

Jitsi/Jigasi are installed on a Debian 4.19.37.
Jitsi Meet web interface allows to add a phone number, initiate the call, the phone rings et the call starts but there is no audio.

The installed versions are the following:

  • Jigasi 1.0-244
  • Jitsi 1.0.3936-1
  • Jitsi-videobridge 1124-1
  • jicofo 1.0-481-1
  • jitsi-meet-web 1.0.3577-1
  • jitsi-meet-web-config 1.0.3577-1
  • jitsi-meet-prosody 1.0.3577-1

When jigasi is started, jicofo logs the 2 following lines
Jicofo 2019-10-27 10:02:30.498 INFO: [104] org.jitsi.jicofo.ComponentsDiscovery.log() New component discovered: callcontrol., null
Jicofo 2019-10-27 10:02:30.498 INFO: [104] org.jitsi.jicofo.JitsiMeetServices.log() Discovered SIP gateway: callcontrol.

When the phone is added to the conference and the call is ongoing, jigasi logs the following lines:
2019-10-21 21:52:40.255 INFO: [123] org.jitsi.jigasi.SipGatewaySession.handleCallState().937 SIP call format used: rtpmap:8 PCMA/8000
2019-10-21 21:52:40.255 INFO: [123] org.jitsi.jigasi.SipGatewaySession.peerStateChanged().1007 116dc821@callcontrol. SIP peer state: Connecting*
2019-10-21 21:52:40.256 INFO: [123] Starting
2019-10-21 21:52:40.313 INFO: [123] Send NAT hole punch packets
2019-10-21 21:52:40.396 SEVERE: [166] Unable to handle format: LINEAR, 48000.0 Hz, 16-bit, Mono, LittleEndian, Signed
2019-10-21 21:52:40.398 SEVERE: [166] Failed to prefetch:
2019-10-21 21:52:40.400 SEVERE: [163] Error: Unable to prefetch

What could prevent the audio to be ok when adding a phone number?
Are these SEVERE logs linked to the issue?

Thank you

Is your sip provider handling nats and latching? This is the common problem. What you can do is install Jitsi Desktop, configure it and make sure it works with it, then you can adjust same settings and for jigasi …

Hi Damian,

My sip provider is I will try out Jitsi Desktop.

Thank you

I tried many encodings. The last one I tried GSM/8000 is working ok with Jitsi Desktop but I am still not getting no audio using Jigasi.

Jigasi keeps complaining about an audio format:
Unable to handle format: LINEAR, 48000.0 Hz, 16-bit, Mono, LittleEndian, Signed

Would it be coming from a missing component on my debian installation?

Can you post your jigasi config, ippi should be finewe had been using them a lot.

Here is the content:
#Sample config with one XMPP and one SIP account configured
# Replace {sip-pass-hash} with SIP user password hash
# as well as other account properties

# Name of default JVB room that will be joined if no special header is included
# in SIP invite

# Should be enabled when using translator mode["AudioSilenceCaptureDevice:noTransferData"]

# Adjust opus encoder complexity

# Disables packet logging\:<ippi login><ippi password><ippi login>

# If an authenticated (hidden) domain is used to connect to a conference,
# PREVENT_AUTH_LOGIN will prevent the SIP participant from being seen as a
# hidden participant in the conference

# Used when incoming calls are used in multidomain environment, used to detect subdomains
# used for constructing callResource and eventually contacting jicofo<jitsi meet host name>

# the pattern to be used as bosh url when using bosh in multidomain environment{host}{subdomain}/http-bind?room={roomName}

# can be enabled to disable audio mixing and use translator, jigasi will act as jvb, just forward every ssrc stream it receives.

# We can use the prefix org.jitsi.jigasi.xmpp.acc to override any of the
# properties that will be used for creating xmpp account for communication.

# The following two props assume we are using jigasi on the same machine as
# the xmpp server.
# Or you can use bosh for the connection establishment by specifing the URL to use.
# org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN={roomName}

#Used when outgoing calls are used in multidomain environment, used to detect subdomains
#org.jitsi.jigasi.xmpp.acc.DOMAIN_BASE=<jitsi meet host name>

# can be enabled to disable audio mixing and use translator, jigasi will act as jvb, just forward every ssrc stream it receives.

# If you want jigasi to perform authenticated login instead of anonymous login
# to the XMPP server, you can set the following properties.
# org.jitsi.jigasi.xmpp.acc.USER_ID=SOME_USER@SOME_DOMAIN
# org.jitsi.jigasi.xmpp.acc.PASS=SOME_PASS
# org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=false

# If you want to use the SIP user part of the incoming/outgoing call SIP URI
# you can set the following property to true.
# org.jitsi.jigasi.USE_SIP_USER_AS_XMPP_RESOURCE=true

# Activate this property if you are using self-signed certificates or other
# type of non-trusted certicates. In this mode your service trust in the
# remote certificates always.

# Enable this property to be able to shutdown gracefully jigasi using
# a rest command
# org.jitsi.jigasi.ENABLE_REST_SHUTDOWN=true

# Options regarding Transcription. Read the README for a detailed description
# about each property


# whether to use the more expensive, but better performing
# "video" model when doing transcription
# org.jitsi.jigasi.transcription.USE_VIDEO_MODEL = false

# delivering final transcript
# org.jitsi.jigasi.transcription.DIRECTORY=/var/lib/jigasi/transcripts
# org.jitsi.jigasi.transcription.BASE_URL=http://localhost/
# org.jitsi.jigasi.transcription.jetty.port=-1
# org.jitsi.jigasi.transcription.ADVERTISE_URL=false

# save formats
# org.jitsi.jigasi.transcription.SAVE_JSON=false
# org.jitsi.jigasi.transcription.SAVE_TXT=true

# send formats
# org.jitsi.jigasi.transcription.SEND_JSON=true
# org.jitsi.jigasi.transcription.SEND_TXT=false

# translation
# org.jitsi.jigasi.transcription.ENABLE_TRANSLATION=false

# record audio. Currently only wav format is supported
# org.jitsi.jigasi.transcription.RECORD_AUDIO=false
# org.jitsi.jigasi.transcription.RECORD_AUDIO_FORMAT=wav

# execute one or more scripts when a transcript or recording is saved
# org.jitsi.jigasi.transcription.EXECUTE_SCRIPTS=true
# org.jitsi.jigasi.transcription.SCRIPTS_TO_EXECUTE_LIST_SEPARATOR=","
# org.jitsi.jigasi.transcription.SCRIPTS_TO_EXECUTE_LIST=script/

# properties for optionally sending statistics to a DataDog server

# sip health checking
# Enables sip health checking by specifying a number/uri to call
# the target just needs to auto-connect the call play some audio,
# the call must be established for less than 10 seconds
# org.jitsi.jigasi.HEALTH_CHECK_SIP_URI=healthcheck
# The interval between healthcheck calls, by default is 5 minutes
# org.jitsi.jigasi.HEALTH_CHECK_INTERVAL=300000
# The timeout of healthcheck, if there was no successful health check for
# 10 minutes (default value) we consider jigasi unhealthy
# org.jitsi.jigasi.HEALTH_CHECK_TIMEOUT=600000

If you open 3 tabs in the browser using your deployment, is audio and video fine?

No it’s not ok with 3 tabs. 2 tabs are almost ok except the echo.
What is the link with Jigasi? Does Jigasi act as 2 clients?

So the problem is your deployment, not jigasi. With two tabs you hear cause you are in p2p mode and both communicate directly without the need to communicate with the videobridge. And as your videobridge cannot be accessed by the clients, it cannot be used and jigasi does not support p2p so you don’t hear it as it needs to be able to send to the videobridge.
Check the quick install guide and the advanced section, you need to make sure some ports are forwarded or open on the firewall and that the videobridge knows the public and private address if NAT is used.
Test it with 3 tabs, when it starts working, test it with jigasi.

Thanks for your support! Port 10000 was not forwarded on the NAT, now the 3 tabs test is ok and audio works ok with a regular phone