Simulcast vs default?

When I have more than 10 users connected in a room, the webcam of most of the users turns off and on, the server can handle that many users (huge instance with huge bandwidth). All my users are reporting that they see only a few users at a time… SO I was reading about configuring something call Simulcast or something like that, so my question is what do I need to tweak to keep all the webcam on all the time and instead of turning off the video feed just lower the quality?

Thanks

This can happen when users do not have enough bandwidth to handle all incoming streams and the bridge will start switching off streams.
Simulcast helps in this situation, as it will send HD layer only for the participant on stage and the small resolution for the rest, or if in tile view will send the needed resolution for all thumbs.
Simulcast is turned on by default.
What version of jitsi-meet do you use? Have you checked bandwidth and loss on participant side when this happens?

As always thank you so much for taking the time to help. Here’s my conf (would love if you have a any suggestion (quality, stop webcam off etc). My users have all good internet connection and located not far from our cloud instance.

    // Sets the preferred resolution (height) for local video. Defaults to 720.
    resolution: 720,

    constraints: {
         video: {
             aspectRatio: 16 / 9,
             height: {
                 ideal: 900,
                 max: 1080,
                 min: 480
             }
         }
     },

    // Enable / disable simulcast support.
    // disableSimulcast: false,

    // Enable / disable layer suspension.  If enabled, endpoints whose HD layers are not >
    // (no longer sent) until they are requested again. This is enabled by default. This >
    // sharing to work as expected on Chrome. Disabling this might result in low resoluti>
    // by the client.
    enableLayerSuspension: true,

Jitsi version installed:

dpkg -l | grep jitsi
ii  jitsi-meet                         2.0.7210-1                         all          WebRTC JavaScript video conferences
ii  jitsi-meet-prosody                 1.0.6091-1                         all          Prosody configuration for Jitsi Meet
ii  jitsi-meet-turnserver              1.0.6091-1                         all          Configures coturn to be used with Jitsi Meet
ii  jitsi-meet-web                     1.0.6091-1                         all          WebRTC JavaScript video conferences
ii  jitsi-meet-web-config              1.0.6091-1                         all          Configuration for web serving of Jitsi Meet
ii  jitsi-videobridge2                 2.1-665-g3a90ccdc-1                all          WebRTC compatible Selective Forwarding Unit (SFU)

Thanks in advance!

If you do the same call with same participants on meet.jit.si, do you see a difference?

The ideal value is strange, maybe you want that to be 720?

Do you see videos turned off when you are in grid mode or when you are in stage mode with one participant on stage?

When the video that goes off, then you see the ninja icon for it, right?

Indeed, I think I tried many combo, I wanted to have good quality, I will switch back to 720, but would love to see all my users at 1080!

Videos turn off in grid mode yes and lots of ninja icon sadly (also newer version of jitsi doesn’t show if the participant turned off his/her camera (no webcam off icon?)).

Thanks

You can do a iperf test using udp while having such conference to see the quality of the connection on the server side. But this sounds like server bandwidth/quality issue to me …

I can throw a 32 CPU, 128 GB of RAM and 100 Gbps Network Bandwidth instance and see if the problem is still present. I will report back next week. Usually we are ±30 participants.

Its not resources, but quality of network.

Noted, but bumping the network bandwitdh is also bumping the CPU and RAM. We’ll see. In the meantime, do you think it would help to lower the min resolution:

    constraints: {
         video: {
             aspectRatio: 16 / 9,
             height: {
                 ideal: 720,
                 max: 1080,
                 min: 144
             }
         }
     },

I would like to see my participants in full HD (1080), so does it make sense to try this:

    constraints: {
         video: {
             aspectRatio: 16 / 9,
             height: {
                 ideal: 1080,
                 max: 1080,
                 min: 144
             }
         }
     },

?

I would recommend sticking to the default with up to 720p, having a stable experience there, and then switching to 1080p.

@damencho you are absolutely right, it was a bandwidth issue with the server, for 20 users the server is something like this:

The instance was too small (limiting the bandwidth). Now that’s easy to fix! But I have another problem with the quality of the feed, now that I have a 24 CPU, 128GB of RAM and 10Gbps of bandwidth I want to have good quality feeds, but Jitsi is limiting the resolution for an unknown reason:

(send max 360p)

I want my users to be able to share screen but also have the best video feed possible. I read that you need to disable Simulcast for this, is that true, what is the price to pay (maybe share screen will not be as good as before)? Would be happy to have your input on this one.

I read that switching to VP9 fix this issue?

Thanks in advance!

Are you talking about mobile app? Or in what case do you see that tile view, stage view? If it is in tile view that is normal the resolution matches the space occupied by the video.

Switching simulcast is not a good idea.

This minimizes the bandwidth that is used, and in some case can help.

We’re on desktop. Yes tile view, so now I understand why it’s limiting the resolution. Final step to have jitsi running at his best quality, all I need to do is put 1080 in ideal?

    constraints: {
         video: {
             aspectRatio: 16 / 9,
             height: {
                 ideal: 1080,
                 max: 1080,
                 min: 144
             }
         }
     },

And maybe switch to VP9?

:+1: