Shared audio from another tab plays with very low quality or heavily processed

I want to share audio from another browser tab. However the quality of the music being played is getting very low or as if its beeping heavily processed or suppressed by an effect like noise canceling or sort. Is there a way to fix this?

I’m guessing you’re not hosting your own server, in which case, you can use URL params to disable sound processing. So, something like this as your meeting URL:

https://meet.jit.si/roomname#config.disableAP=true&config.disableAEC=true&config.disableNS=true&config.disableAGC=true&config.disableHPF=true

You can adjust those vales from “true” to “false” depending on your need.

Of course, if you host your own server, you can just set this globally in config.js

No I am not hosting. I am using meet.jit.si. I just tied your settings but no difference. The quality is still very bad. As if its not being directly played

I am using this music file if you want to try: music bazi mafia 2.mp3 - Google Drive

Did you try that from the start of did you add it at the end of the URL in an ongoing meeting?

I created a new room.

I should probably test this myself to be certain it has an impact one way or the other, but RED is now enabled on meet.jit.si, so I wonder if that’s affecting the ability to adjust sound processing (like it does when you enable HD audio with RED). :thinking:

Yes please test it. I sent a link with the exact file that I used, in case you want to replicate the situation. So here is what I did:
1- created a room + #config.disableAP=true&config.disableAEC=true&config.disableNS=true&config.disableAGC=true&config.disableHPF=true

then I opened the music file in another tab. Then via meeting selected : share audio and then selected the tab in browser when file was open and played it. Then connected with my phone to the meeting and heard it with headphone.

Even if you remove all audio processing it will be mono and won’t sound great I think. Try this: jitsi-meet/config.js at f0ff6a9f1cf5cd1c716e5ae676689482c89af12c · jitsi/jitsi-meet · GitHub Set stereo to true and bump the opus bitrate. Hopefully that does it.

As I said, I do not host the meeting on my own server to set the config file like that and was using meet.jit.si. Can I use what you said with meet.jit.si directly?

Yes, use the same config override syntax as before: #config.section.parameter=value

Ok I used this:

  • #config.audioQuality.stereo=true&config.audioQuality.opusMaxAverageBitrate=320000

it creates a meeting and I start sharing audio. The moment I connect to the meeting from my phone, the browser meeting’s (playing the audio) tab crashes. Tried it both on brave and edge browsers.

update: brought down bitrate to 120000 and it did not crash. however the result is the same. The issue still exists

Also tried this and no success: #config.audioQuality.stereo=true&config.audioQuality.opusMaxAverageBitrate=120000&config.disableAP=true&config.disableAEC=true&config.disableNS=true&config.disableAGC=true&config.disableHPF=true

Finally got a chance to test this. It appears that if I join with the mobile browser, audio processing continues to be enforced. But I then checked with the Mobile app and that seemed to work as expected - it seemed like the sound remained at the same level throughout. Perhaps try with the app and see if you notice a difference too.

What mobile browser were you using? I didn’t get that you where.

I tested with android native app on the phone though.

By the way have you listened with headphone? because it might be difficult to notice the effect if you listen from phone speakers. If you listen with headphone you notice the difference

I tested using Mobile Chrome and Firefox, then tested with the app.
Yes, I used a headset. I thought the volume remained consistent using the app, but I could be wrong…

I think we are getting things mixed up here.

The config overrides I mentioned are meant to be applied on the browser sharing the tab, not the receiver.

Tab audio is mixed with local audio, which by default has processing enabled.

Upping that topic, sorry, but I cannot seem to create high quality or even stereo using jitsi:

which should be the proper url to set up on first joiner side, but whatever I do I get mono and low quality on the other side.
Connecting from Firefox/Monterey, should I try another browser or something else ?

Thanks !

(post deleted by author)

Is anyone able to send high audio quality from macOS Monterey, whatever the browser used ?
Mostly tested under Firefox, I can’t seem to find how channels are managed by it, apart from authorization to use inputs and selecting which one to use…
And Chrome tab is crashing when joining sessions.
Here is part of the log in firefox:
2022-07-01T14:07:20.058Z [features/base/config] <5051/Qn/<>: Extending config with: {“audioQuality”:{“stereo”:true,“opusMaxAverageBitrate”:320000,“enableOpusRed”:false},“disableAEC”:true,“disableAGC”:true,“disableAP”:true,“disableHPF”:true,“disableNS”:true,“p2p”:{“enabled”:false}}