Share dial in info not displaying

I have read a few guides on this subject and I am not sure what I have missed.
I cannot get the conference dial in with pin to show up in the rooms.
I have my php file with the json file built and I can hit it and it works fine.
I have this placed in my /etc/jitsi/meet/meet.dutil.com-config.js

// To enable sending statistics to callstats.io you must provide the
// Application ID and Secret.
// callStatsID: '',
// callStatsSecret: '',
dialInNumbersUrl: 'https://mm.dutil.com/number.php',
dialInConfCodeUrl: 'https://jitsi-api.jitsi.net/conferenceMapper',
// enables sending participants display name to callstats
// enableDisplayNameInStats: false

2020-04-01 22_30_10
But nothing displays in the room. Any help is MUCH appreciated. Thank you.

I decided to point my config at jitsi’s setup and it worked… so I don’t know yet. I than replicated jitsi’s setup more by doing a default index.php https://mm.dutil.com/phoneNumberList/ and even copied their json file into mine. It looks fine but still does not work. But Jitsi’s does… Not sure what I am missing yet. Going to try a different host and domain. Will update when finished.

Well, I feel dumb. I knew evilcreamsicle said to enable Cross Origin Scripting (CORS) support but I didn’t think it was necessary in NGINX. I was wrong. Ha.

I added this to the http server block in /etc/nginx/nginx.conf and it started working fine.
I hope this info helps someone else.

    #CORS
    add_header Access-Control-Allow-Origin "*";

It helped a lot. Thank you

Hi,

I’m not sure I understand, it’s possible to use the dial and pin system of jitsi on our own servers , for free?
Thanks

When enabling CORS, specify the domains that require access when possible.

Wild card usage below opens doors for exploits as you’re effectively allowing access to the entire world.

Header set Access-Control-Allow-Origin "*"

Use this instead (replace with your jitsi meet domain):

Header set Access-Control-Allow-Origin "https://my.domain.com"
1 Like