SEVERE: org.openqa.selenium.WebDriverException, "live streaming has stopped", docker jibri 4384

I’m trying to stream on youtube (rtmp://a.rtmp.youtube.com/live2) using latest (4384) jitsi-docker jibri (with 4101-2 docker for web, prosody, jicofo, jvb).
As soon as I click Live streaming and enter the streaming key, it shows an orange message and stops.

Looking at <config>/jibri/logs/log.0.txt
I see a SEVERE error:
2020-04-13 14:43:16.643 SEVERE: [149] org.jitsi.jibri.selenium.JibriSelenium.run() An error occurred while joining the call: org.openqa.selenium.WebDriverException: : Failed to read the ‘localStorage’ property from ‘Window’: Access is denied for this document.

Well, at first I thought it was because I was using Chromium (ubuntu 19.10 is client and host of containers) and changed third-party settings according to https://www.chromium.org/for-testers/bug-reporting-guidelines/uncaught-securityerror-failed-to-read-the-localstorage-property-from-window-access-is-denied-for-this-document

But it didn’t fix it, so I tried with Firefox and still get the same error.
I added consider_bosh_secure = true in both prosody and jitsi-meet.cfg.lua and restared all containers then jibri then jicofo containers to prevent errors, restarted browser and meeting (1 user), entered moderator u/p (plain_internal auth, no jwt).
Maybe my settings need more work and order of starting containers?

This error message is so specific to Chrome/Chromium, does some Chromium library is used for streaming to work?
@Urbanovits, @bbaldino I read you on [Solved partially]Jibri recording stucked with recording has stopped , then busy and wonder if this error is related to settings within an updated jibri component.
Your toughts are welcome!

There are lots of instances of this on the forum, I think it’s related to certificates. I’d search around.

Thanks @bbaldino.
LetsEncrypt SSL certificates?
I issued it weeks ago and everything is working fine with everyone on the internet.

Please note, my error is “Failed to read the ‘localStorage’”, not the same as [Solved partially]Jibri recording stucked with recording has stopped , then busy taht I cite in my post.

1 Like

I’m getting the same issue. Have you found a solution?

Thanks, Nav

Nope, not yet.

Cloudflare went down too (https://community.cloudflare.com/t/cant-generate-origin-certificate/164914), that’s just too much for the day.

Need some rest.

I’m in Europe, so the day is gone already.

Please, please let me know if you find a way.

I tried the suggestion in this comment and it started working - https://github.com/jitsi/docker-jitsi-meet/issues/240#issuecomment-605530354

In short, change all the meet.jitsi references in the .env file to your domain name

Thanks! will see you tomorrow