Setting up Multiple Domains in one Jitsi Instance in Docker

Hi, Can somebody please help how we can setup two DNSs for the same Jitsi instance. When we were using single DNS, i was not having any issue because i have added PUBLIC_URL=mydomain1.com in .env file. Since there is a need to use 2 services for the same Jitsi instance…i have removed the PUBLIC_URL and followed multiple threads in jitsi.org looking for a proper solution.

But unfortunately nothing worked!! I have added another virtualhost for the second domain too. And we have valid certificates as well for both the domains.

Both URLs are working fine. But the issue whenever i open a new meeting from both the URLs, its always showing “You have been disconnected” error.

Please somebody help on my issue. I have done the jitsi setup on docker and frontend is apache.

Hi Team, Can somebody please help on my query??

Hi @Freddie @damencho

Could you please help me on my above issue?

I really required this setup for our Organization.

Did you add XMPP_CROSS_DOMAIN=true on prosody?

Hi @congthang,

I have tried this in our test environment and it worked as expected with two public URLs.

I am going to apply the same on customer environment and update you.

Hopefully it will work!! :slightly_smiling_face:

Thanks a lot for your response.

Hi @congthang

Its not working in cust environment. I have enabled XMPP_CROSS_DOMAIN=true in .env file under docker-jitsi directory. And added two DNS with comma sepearated as below in the same .env file.

PUBLIC_URL=https://xyz-jitsi.com,https://123-jitsi.com

The above worked in test environement.

May i know there is any other file i need to enable for XMPP_CROSS_DOMAIN=true inside prosody docker image .

Please suggest.

PUBLIC_URL should be one of them not two