Setting Up Jitsi Can't Use it After Setting Up Users

I setup Jitsi following. It works until I try and setup users. However, when I go to use it it doesn’t prompt me for a user. Looking at the logs the issue seems to be user related but I could be mis-reading it as this is new to me. Any help is appreciated.

root@foundry-vtt:~# tail -f /var/log/jitsi/jicofo.log
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$700(XMPPTCPConnection.java:913)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:936)
	at java.base/java.lang.Thread.run(Thread.java:833)
Jicofo 2022-01-07 03:05:23.810 SEVERE: [55] [xmpp_connection=client] XmppProviderImpl$XmppConnectionListener.connectionClosedOnError#397: XMPP connection closed on error: connection-timeout You can read more about the meaning of this stream error at http://xmpp.org/rfcs/rfc6120.html#streams-error-conditions
<stream:error><connection-timeout xmlns='urn:ietf:params:xml:ns:xmpp-streams'/></stream:error>
Jicofo 2022-01-07 03:05:24.811 INFO: [56] [xmpp_connection=client] XmppProviderImpl$XmppReConnectionListener.reconnectingIn#417: XMPP reconnecting in: 2
Jicofo 2022-01-07 03:05:25.812 INFO: [56] [xmpp_connection=client] XmppProviderImpl$XmppReConnectionListener.reconnectingIn#417: XMPP reconnecting in: 1
Jicofo 2022-01-07 03:05:26.813 INFO: [56] [xmpp_connection=client] XmppProviderImpl$XmppReConnectionListener.reconnectingIn#417: XMPP reconnecting in: 0
Jicofo 2022-01-07 03:05:26.814 INFO: [56] [xmpp_connection=client] XmppProviderImpl$XmppReConnectionListener.reconnectingIn#417: XMPP reconnecting in: 0
Jicofo 2022-01-07 03:05:26.884 SEVERE: [56] [xmpp_connection=client] XmppProviderImpl$XmppReConnectionListener.reconnectionFailed#423: XMPP reconnection failed: SASLError using SCRAM-SHA-1: not-authorized
Jicofo 2022-01-07 03:10:26.830 WARNING: [60] org.jivesoftware.smack.AbstractXMPPConnection.callConnectionClosedOnErrorListener: Connection XMPPTCPConnection[focus@auth.meet.clarkeverson.com/focus] (0) closed with error
org.jivesoftware.smack.XMPPException$StreamErrorException: connection-timeout You can read more about the meaning of this stream error at http://xmpp.org/rfcs/rfc6120.html#streams-error-conditions
<stream:error><connection-timeout xmlns='urn:ietf:params:xml:ns:xmpp-streams'/></stream:error>
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:981)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$700(XMPPTCPConnection.java:913)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:936)
	at java.base/java.lang.Thread.run(Thread.java:833)
Jicofo 2022-01-07 03:10:26.838 SEVERE: [60] [xmpp_connection=client] XmppProviderImpl$XmppConnectionListener.connectionClosedOnError#397: XMPP connection closed on error: connection-timeout You can read more about the meaning of this stream error at http://xmpp.org/rfcs/rfc6120.html#streams-error-conditions
<stream:error><connection-timeout xmlns='urn:ietf:params:xml:ns:xmpp-streams'/></stream:error>
Jicofo 2022-01-07 03:10:27.838 INFO: [61] [xmpp_connection=client] XmppProviderImpl$XmppReConnectionListener.reconnectingIn#417: XMPP reconnecting in: 2
Jicofo 2022-01-07 03:10:28.839 INFO: [61] [xmpp_connection=client] XmppProviderImpl$XmppReConnectionListener.reconnectingIn#417: XMPP reconnecting in: 1
Jicofo 2022-01-07 03:10:29.841 INFO: [61] [xmpp_connection=client] XmppProviderImpl$XmppReConnectionListener.reconnectingIn#417: XMPP reconnecting in: 0
Jicofo 2022-01-07 03:10:29.841 INFO: [61] [xmpp_connection=client] XmppProviderImpl$XmppReConnectionListener.reconnectingIn#417: XMPP reconnecting in: 0
Jicofo 2022-01-07 03:10:29.954 SEVERE: [61] [xmpp_connection=client] XmppProviderImpl$XmppReConnectionListener.reconnectionFailed#423: XMPP reconnection failed: SASLError using SCRAM-SHA-1: not-authorized
^C
root@foundry-vtt:~# tail -f /var/log/jitsi/jvb.log
JVB 2022-01-07 03:12:08.695 INFO: [21] [hostname=localhost id=shard] MucClient.lambda$getConnectAndLoginCallable$7#624: Logging in.
JVB 2022-01-07 03:12:08.698 WARNING: [21] [hostname=localhost id=shard] MucClient.lambda$getConnectAndLoginCallable$7#638: Failed to login. Disconnecting to trigger a re-connect.
JVB 2022-01-07 03:12:08.700 INFO: [21] [hostname=localhost id=shard] MucClient$2.connectionClosed#313: Closed.
JVB 2022-01-07 03:12:12.152 WARNING: [28] [hostname=localhost id=shard] MucClient.setPresenceExtensions#445: Cannot set presence extension: not connected.
JVB 2022-01-07 03:12:13.721 INFO: [21] [hostname=localhost id=shard] MucClient$2.connected#301: Connected.
JVB 2022-01-07 03:12:13.721 INFO: [21] [hostname=localhost id=shard] MucClient.lambda$getConnectAndLoginCallable$7#624: Logging in.
JVB 2022-01-07 03:12:13.722 WARNING: [21] [hostname=localhost id=shard] MucClient.lambda$getConnectAndLoginCallable$7#638: Failed to login. Disconnecting to trigger a re-connect.
JVB 2022-01-07 03:12:13.724 INFO: [21] [hostname=localhost id=shard] MucClient$2.connectionClosed#313: Closed.
JVB 2022-01-07 03:12:17.132 INFO: [26] HealthChecker.run#171: Performed a successful health check in PT0.000030056S. Sticky failure: false
JVB 2022-01-07 03:12:17.152 WARNING: [28] [hostname=localhost id=shard] MucClient.setPresenceExtensions#445: Cannot set presence extension: not connected.
JVB 2022-01-07 03:12:18.741 INFO: [21] [hostname=localhost id=shard] MucClient$2.connected#301: Connected.
JVB 2022-01-07 03:12:18.742 INFO: [21] [hostname=localhost id=shard] MucClient.lambda$getConnectAndLoginCallable$7#624: Logging in.
JVB 2022-01-07 03:12:18.743 WARNING: [21] [hostname=localhost id=shard] MucClient.lambda$getConnectAndLoginCallable$7#638: Failed to login. Disconnecting to trigger a re-connect.
JVB 2022-01-07 03:12:18.744 INFO: [21] [hostname=localhost id=shard] MucClient$2.connectionClosed#313: Closed.
JVB 2022-01-07 03:12:22.151 WARNING: [28] [hostname=localhost id=shard] MucClient.setPresenceExtensions#445: Cannot set presence extension: not connected.
JVB 2022-01-07 03:12:23.767 INFO: [21] [hostname=localhost id=shard] MucClient$2.connected#301: Connected.
JVB 2022-01-07 03:12:23.767 INFO: [21] [hostname=localhost id=shard] MucClient.lambda$getConnectAndLoginCallable$7#624: Logging in.
JVB 2022-01-07 03:12:23.769 WARNING: [21] [hostname=localhost id=shard] MucClient.lambda$getConnectAndLoginCallable$7#638: Failed to login. Disconnecting to trigger a re-connect.
JVB 2022-01-07 03:12:23.771 INFO: [21] [hostname=localhost id=shard] MucClient$2.connectionClosed#313: Closed.
JVB 2022-01-07 03:12:27.132 INFO: [26] HealthChecker.run#171: Performed a successful health check in PT0.000026344S. Sticky failure: false
JVB 2022-01-07 03:12:27.152 WARNING: [28] [hostname=localhost id=shard] MucClient.setPresenceExtensions#445: Cannot set presence extension: not connected.
JVB 2022-01-07 03:12:28.792 INFO: [21] [hostname=localhost id=shard] MucClient$2.connected#301: Connected.
JVB 2022-01-07 03:12:28.792 INFO: [21] [hostname=localhost id=shard] MucClient.lambda$getConnectAndLoginCallable$7#624: Logging in.
JVB 2022-01-07 03:12:28.794 WARNING: [21] [hostname=localhost id=shard] MucClient.lambda$getConnectAndLoginCallable$7#638: Failed to login. Disconnecting to trigger a re-connect.
JVB 2022-01-07 03:12:28.795 INFO: [21] [hostname=localhost id=shard] MucClient$2.connectionClosed#313: Closed.
^C

Share your jicofo.conf

 Jicofo HOCON configuration. See reference.conf in /usr/share/jicofo/jicofo.jar for
#available options, syntax, and default values.
jicofo {
  xmpp: {
    client: {
      client-proxy: focus.meet.clarkeverson.com
    }
    trusted-domains: [ "recorder.meet.clarkeverson.com" ]
  }
  bridge: {
    brewery-jid: "JvbBrewery@internal.auth.meet.clarkeverson.com"
  }
}

You need an authentication block. Try this:

 Jicofo HOCON configuration. See reference.conf in /usr/share/jicofo/jicofo.jar for
#available options, syntax, and default values.
jicofo {
  xmpp: {
    client: {
      client-proxy: focus.meet.clarkeverson.com
    }
    trusted-domains: [ "recorder.meet.clarkeverson.com" ]
  }
  bridge: {
    brewery-jid: "JvbBrewery@internal.auth.meet.clarkeverson.com"
  }
authentication: {
    enabled: true
    type: XMPP
    login-url: meet.clarkeverson.com
  }

}

That looked promising! Alas, still not working. I restart jitsi, jicofo and prosody as well

root@foundry-vtt:/etc/jitsi/jicofo# tail -f /var/log/jitsi/jicofo.log
	at org.jivesoftware.smack.AbstractXMPPConnection.lambda$new$2(AbstractXMPPConnection.java:407)
	at org.jivesoftware.smack.NonzaCallback$ClassAndConsumer.accept(NonzaCallback.java:177)
	at org.jivesoftware.smack.NonzaCallback$ClassAndConsumer.access$200(NonzaCallback.java:166)
	at org.jivesoftware.smack.NonzaCallback.onNonzaReceived(NonzaCallback.java:46)
	at org.jivesoftware.smack.AbstractXMPPConnection.parseAndProcessNonza(AbstractXMPPConnection.java:1447)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection.access$1700(XMPPTCPConnection.java:130)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1007)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$700(XMPPTCPConnection.java:913)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:936)
	at java.base/java.lang.Thread.run(Thread.java:833)
Jicofo 2022-01-07 03:55:35.871 INFO: [47] [xmpp_connection=client] XmppProviderImpl.doConnect#206: Connected, JID=null
Jicofo 2022-01-07 03:55:35.874 SEVERE: [47] [xmpp_connection=client] XmppProviderImpl.doConnect#225: Failed to connect/login: SASLError using SCRAM-SHA-1: not-authorized
org.jivesoftware.smack.sasl.SASLErrorException: SASLError using SCRAM-SHA-1: not-authorized
	at org.jivesoftware.smack.SASLAuthentication.authenticationFailed(SASLAuthentication.java:286)
	at org.jivesoftware.smack.AbstractXMPPConnection.lambda$new$2(AbstractXMPPConnection.java:407)
	at org.jivesoftware.smack.NonzaCallback$ClassAndConsumer.accept(NonzaCallback.java:177)
	at org.jivesoftware.smack.NonzaCallback$ClassAndConsumer.access$200(NonzaCallback.java:166)
	at org.jivesoftware.smack.NonzaCallback.onNonzaReceived(NonzaCallback.java:46)
	at org.jivesoftware.smack.AbstractXMPPConnection.parseAndProcessNonza(AbstractXMPPConnection.java:1447)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection.access$1700(XMPPTCPConnection.java:130)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1007)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$700(XMPPTCPConnection.java:913)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:936)
	at java.base/java.lang.Thread.run(Thread.java:833)
^C
root@foundry-vtt:/etc/jitsi/jicofo# tail -f /var/log/jitsi/jvb.log
JVB 2022-01-07 03:55:51.242 WARNING: [27] [hostname=localhost id=shard] MucClient.setPresenceExtensions#445: Cannot set presence extension: not connected.
JVB 2022-01-07 03:55:52.606 INFO: [21] [hostname=localhost id=shard] MucClient$2.connected#301: Connected.
JVB 2022-01-07 03:55:52.607 INFO: [21] [hostname=localhost id=shard] MucClient.lambda$getConnectAndLoginCallable$7#624: Logging in.
JVB 2022-01-07 03:55:52.610 WARNING: [21] [hostname=localhost id=shard] MucClient.lambda$getConnectAndLoginCallable$7#638: Failed to login. Disconnecting to trigger a re-connect.
JVB 2022-01-07 03:55:52.613 INFO: [21] [hostname=localhost id=shard] MucClient$2.connectionClosed#313: Closed.
JVB 2022-01-07 03:55:56.244 WARNING: [27] [hostname=localhost id=shard] MucClient.setPresenceExtensions#445: Cannot set presence extension: not connected.
JVB 2022-01-07 03:55:57.649 INFO: [21] [hostname=localhost id=shard] MucClient$2.connected#301: Connected.
JVB 2022-01-07 03:55:57.649 INFO: [21] [hostname=localhost id=shard] MucClient.lambda$getConnectAndLoginCallable$7#624: Logging in.
JVB 2022-01-07 03:55:57.651 WARNING: [21] [hostname=localhost id=shard] MucClient.lambda$getConnectAndLoginCallable$7#638: Failed to login. Disconnecting to trigger a re-connect.
JVB 2022-01-07 03:55:57.653 INFO: [21] [hostname=localhost id=shard] MucClient$2.connectionClosed#313: Closed.
JVB 2022-01-07 03:56:01.197 INFO: [25] HealthChecker.run#171: Performed a successful health check in PT0.000025526S. Sticky failure: false
JVB 2022-01-07 03:56:01.243 WARNING: [27] [hostname=localhost id=shard] MucClient.setPresenceExtensions#445: Cannot set presence extension: not connected.
JVB 2022-01-07 03:56:02.684 INFO: [21] [hostname=localhost id=shard] MucClient$2.connected#301: Connected.
JVB 2022-01-07 03:56:02.685 INFO: [21] [hostname=localhost id=shard] MucClient.lambda$getConnectAndLoginCallable$7#624: Logging in.
JVB 2022-01-07 03:56:02.688 WARNING: [21] [hostname=localhost id=shard] MucClient.lambda$getConnectAndLoginCallable$7#638: Failed to login. Disconnecting to trigger a re-connect.
JVB 2022-01-07 03:56:02.699 INFO: [21] [hostname=localhost id=shard] MucClient$2.connectionClosed#313: Closed.

You have a wrong password/secret.

It’s not prompting me to enter one when I start a video, nor can I find an option to enter it. Unless you’re referring to in the server itself. But no Auth window pops up when I start a meeting

Looks like it’s between Jicofo and Prosody. What guide did you follow to setup Secure Domain?

I followed this for the whole thing: Virtual Tabletop Assets (VTTA) | Articles | Installing a self-hosted Jitsi Server for Foundry VTT

Okay, this is a custom script, not managed by Jitsi. I took a cursory look through and it looks like they’re moving Jicofo secret around (which is likely where the error you’re facing was introduced). You might want to reach out to the person/team that wrote the script for assistance. It’s best to use the official Jitsi guide for these things; makes it easier to debug when there are issues.

1 Like

Okay I will take a look at it tomorrow. Interesting these scripts worked last year when I used them. I will see if I can find the creator and if not see if I understand the guide or I maybe back with questions. Thanks for the help!
Doing a quick read through I should use XMPP not JWT for the auth file correct?

Yeah, a lot has changed since early last year. If you don’t have anything else on your droplet and you’re just looking to install Jitsi on it, I’d recommend starting over and using the official guides. Only takes a few minutes and will save you a ton of headaches in the long run.

Try that and if you run into issues, feel free to create a thread, we’ll be glad to help.

P.S: You might want to consider Ubuntu 20.04 on your droplet, instead of 18.04 as recommended by your initial guide.

1 Like