Setting up Jigasi for transcription only giving


#1

Hello
I am trying to run jigasi for transcription using google api. I managed to run and connect it to jicofo (thanks Damian!) but there are some erros when I run APP.conference._room.dial (“jitsi_meet_transcribe”)

In the jigasi readme at Gibthub there is a not at the end telling that a valid XMPP account is necessary, is it related to the error I am having? I dont remember setting up anything like that elsewhere in the program

I am sending my logs for jigasi and the sip-communication.properties attached.

jigasi-log.txt (12.7 KB)

sip-communicator.txt (7.9 KB)

thanks in advance


#2

Try enabling net.java.sip.communicator.service.gui.ALWAYS_TRUST_MODE_ENABLED=true in jigasi config.


#3

It worked by changing this configuration, thanks.

Btw, is there any risk leaving it open for everyone? If so, is there any recommended settings to do as a workaround?


#4

What do you mean by open for everyone?


#5

I mean, does it make much of a difference if I allow any certificate to connect to my service?


#6

Its the other way around, so when jigasi connects to prosody, prosody uses a certificate to encrypt the connection and jigasi checks whether that certificate matches the host name it connects and whether that certificate is valid. Not checking the certificate there is a risk of men in the middle, if you are running prosody and jigasi in controlled environment there is no risk. The other option is to transfer that certificate on the jigasi machine and make it trusted (something like https://github.com/jitsi/jicofo#certificates).