Setting up a subdomain for my jitsi server

I set up a sub domain for my Jitsi installation to make it easier for less tech savvy people in my organization to set up meetings: meet.SmushUSA.org.

When I go to http://meet.smushusa.org, i get the welcome to nginx message. When I go to https://meet.smushusa.org, it brings up Jitsi, but meetings don’t work. I suspect that this is because it is looking for config and other files but its not finding them because of the new domain name. the domain name I have from the linode server on which it is hosted works for the time being.

https is also not working for the subdomain --which might also be affecting the service
The logs won’t show any information from the subdomain when I try it.
F12 is showing an SSL certificate error as well

How can I fix this?
Does anybody have a step-by-step method in which to make this work?

There is no whois record for this domain. Is this the real FQDN?

no that is an alias

The site address and the setup address must be the same

read about domain here:

I changed everything to match and it still didn’t work. https WILL go to the server, but I can’t start meetings because of the ssl issue (I think). The sub domain is going to the ip address. What if I pointed the subdomain to the other domain on linode?

is your server on the Internet ?

yes

then you need to find a registrar and get a regular domain for your site. The only other possibility is to use only PC (not phones) and install your self-signed certificate on all computers that will use your server (and it will be more and more a pain to make modern browsers to accept them - and if you want to use Jitsi-meet you have to use recent browsers).

Or maybe just continue to use the Linode address its been using?

It will work

What will work?

I don’t use this hoster, but quite a few hosters are offering registrar services so maybe you got a domain for free with your Linode hosting and you now you want to use another server with another hoster that don’t provide registry service ? I can only speculate on your rather strange problem…

I use the linode address (li200-235.members…) and it works.

Its when I go to the IP address or the subdomain that I have an SSL error that prevents Jitsi from working properly.

Is there a step by step process to fixing this type of issue?

I think to understand that this address is living under a general linode domain for which a valid certificate exists. So you use an existing domain and as stated in the first link I gave to you, a valid certificate is a condition for WebRTC (and media use in Jitsi-meet)

Nobody can’t give you a step by step because it depends on your hosting. In my case I have a server at OVH, I have a registrar elsewhere hence I have 2 contracts for this server, one with Ovh for the hardware and the IP address, one with the registrar for the DNS name for which I have a yearly fee.
Exact steps can vary depending on your particular situation, I know nothing on your new server particularities…

What if I point the sub domain to the linode domain?

I have no idea of what you are meaning by that.

conference..com can point to li200-235.members.

do you mean a CNAME ?

Yes.