Setting that determens maxium number of users in a room?

Is there a Setting that determens maxium number of users in a room?

If so where is this set in witch file?

You can enable this module: https://github.com/jitsi/jitsi-meet/blob/master/resources/prosody-plugins/mod_muc_max_occupants.lua
The setting needs to be always +1. If you set a value 3 this is for 2 participants max (1 extra is jicofo and whitelisted are jibri, transcribers … ).

1 Like

Hi @damencho.
Sorry for bother with this, but I can’t find how to enable a module.
I followed all the guides and now I’ve my own instance working. But I can’t restrict the number of users in a room.
I found the mod_muc_max_occupants.lua, I found the line that I should change, but I don’t know how to enable this module.

Thanks for all your patience with us, new users.

Hi, i have the same troubles as esturniolo.
Standard jitsi installation (debian packages)

i enabled the module in /etc/prosody/conf.d/meet.mydomain.at.cfg.lua

Component "conference.meet.mydomain.at" "muc"
storage = "none"
muc_max_occupants = 3
modules_enabled = {
"muc_meeting_id";
"muc_domain_mapper";
-- "token_verification";
"muc_max_occupants";
}

my plugin path is

plugin_paths = { "/usr/share/jitsi-meet/prosody-plugins/" }

and the plugin is here:

file exists: /usr/share/jitsi-meet/prosody-plugins/mod_muc_max_occupants.lua

restartet prosody + jitsi-videobridge2 + jicofo

for testing i set “muc_max_occupants = 3”, but it i can connect with 5 clients without any problems.

any ideas whats wrong or where begin to start debugging?

When you added the module and restarted prosody, did you check the prosody logs?