Setting enableThumbnailReordering to false breaks screenshare in grid view?

Ever since we enabled multi-stream, our users have complained that when they share screen they can see their own screenshare in the filmstrip but it shows up as just black in grid view. Other participants can see the screenshare just fine in all views.

When this was not resolved with latest stable, I started digging and discovered that if I removed testing.enableThumbnailReordering: false from my config.js then the problem disappears.

This smells like a bug. Can anyone confirm?

Repro steps:

  1. set testing.enableThumbnailReordering: false in config.js
  2. Join and share screen.
    • You should see your own video and your screenshare just fine in filmstrip.
  3. Switch to grid view
    • You can see your video stream, but only a black box in place of the screenshare stream

Edit: Managed to repro on too using config override #config.testing.enableThumbnailReordering=false


@Hristo_Terezov @jallamsetty @robertpin

Please be advised that disabling enableThumbnailReordering is not supported anymore. The config was only added so that we can test it on our deployments (as is the case with all settings under the testing section) before we enable it by default. Thumbnail re-ordering has been enabled by default for a while now and we will be removing the option to disable it soon. We do not intent to support the other mode.

Thanks for the heads-up @jallamsetty

1 Like

Hi @jallamsetty! I’m curious about the logic behind removing the ability to disable this feature. Reordering tiles was staunchly rejected by our users as they found the jumping tiles distracting (and confusing). Can you share a bit on the reasoning behind making this the default behavior?

Hi @Freddie, reordering is very useful for large conferences where everyone is not visible, it brings the dominant speakers and screensharing participants to the top so that they are always visible. Also its easier to find a particular participant if the tiles in the filmstrip are all alphabetically sorted. A lot of improvements have been since the first iteration to not reorder the tile if everyone is already visible. So there should be no impact on smaller conferences. Please give it a try and report any issues with re-ordering and we will be happy to fix it. Unfortunately, we do not have the bandwidth to keep supporting a mode that we don’t use on any of our deployments. Thanks for understanding.


Thanks for the explanation, @jallamsetty. This makes sense. I definitely agree on the need and usefulness for the filmstrip, it’s the shifting tiles that’s a problem. Will this behavior respect the constraint specified on the number of visible tiles in config.js? So, let’s say I change the default to 30, will the tiles still not be reordered in that case?

@Freddie, what constraint are you referring to? The tiles will be never re-ordered if there is no scroll on the filmstrip.

This one in config.js:

numberOfVisibleTiles: 25,

I started to say “perfect!” and then I read this again: you said “filmstrip”. :thinking: The filmstrip only shows about 8 or so visible thumbnails before requiring scrolling, if I’m not mistaken. So will reordering kick in once there are more than 8 (or 9 - not sure of the exact number, without testing) people in a room?

My concern is actually in Tile view when the config has the tiles jumping around. In an active meeting where you have people engaging, it causes a lot of jumping (and in the past, even seemed to trigger the “video has been turned off to save bandwidth” warning). If the feature doesn’t come on automatically so long as one within the limit set for the number of visible tiles in tile view (not the filmstrip), then this would be great.

Yes, the client will still respect this setting from config.js.

Yes, even in tile view, participants will be re-ordered only if scroll is visible. It shouldn’t affect conferences less than 25 users with numberOfVisibleTiles: 25 setting. That is the expected behavior. Please let us know if you see any bugs.

1 Like

@jallamsetty YAAAASSSSSSSSS!!! Thank you, mama! :man_dancing:t5::man_dancing:t5::man_dancing:t5:

1 Like