Set Env coding on Window 10


#1

Hi team,
I truy to set Env for coding jitsi-meet on Window 10.
I try to install npm but alway meet some error below:

  1. Miss file css/all.css in code project

npm ERR! peer dep missing: react@^15.3.2, required by @atlaskit/flag@6.1.0
npm ERR! peer dep missing: react@15.6.0 - 16.2.0, required by @atlaskit/inline-dialog@5.3.0
npm ERR! peer dep missing: react@16.6.0-alpha.8af6728, required by react-native@0.57.4
npm ERR! peer dep missing: react-dom@15.6.0 - 16.2.0, required by @atlaskit/inline-dialog@5.3.0
npm ERR! missing: react-native-fast-image@github:jitsi/react-native-fast-image#1f8c93a5584869848d75cc9b946beb9688efe285, required by jitsi-meet@0.0.0
npm ERR! peer dep missing: webpack@^4.0.0, required by webpack-dev-server@3.1.10
npm ERR! peer dep missing: react@^15.3.2, required by @atlaskit/icon@7.1.0
npm ERR! peer dep missing: react@15.6.0 - 16.2.0, required by @atlaskit/theme@2.4.1
npm ERR! peer dep missing: react@^0.14.0 || ^15.0.0-0, required by styled-components@1.4.6
npm ERR! peer dep missing: react@15.6.0 - 16.2.0, required by @atlaskit/theme@2.4.1
npm ERR! peer dep missing: react@^0.14.0 || ^15.0.0-0, required by styled-components@1.4.6
npm ERR! peer dep missing: react@^0.14.0 || ^15.0.0-0, required by styled-components@1.4.6
npm ERR! peer dep missing: react@^0.14.0 || ^15.0.0-0, required by styled-components@1.4.6
npm ERR! peer dep missing: react@^0.14.0 || ^15.0.0-0, required by styled-components@1.4.6
npm ERR! peer dep missing: react@15.6.0 - 16.2.0, required by @atlaskit/layer@2.9.1
npm ERR! peer dep missing: react@15.6.0 - 16.2.0, required by @atlaskit/theme@2.4.1
npm ERR! peer dep missing: webpack@^4.0.0, required by webpack-dev-middleware@3.4.0
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! jitsi-meet@0.0.0 validate: npm ls
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the jitsi-meet@0.0.0 validate script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:

Pls help me fix it,
Thanks,