Server Setup

I have had working server for over a year and it just stopped working the last couple of days. Something weird going on with DNS but not sure as I have not made any changes in some time. So I then build out some different one click servers using Linode and although the sites have come up I cant get the video or audio to work for nothing. I can see my camera and microphones and select them and allow them but I can not turn them on. Is anyone else having this issue? Does anyone have any thoughts on the matter?

I appreciate any help in this matter.

Thanks!

Try incognito mode in your browser.

I connect to the Jitsi (Jit.si) server with no issues and I already tried that with no difference.

What does this mean - some kind of Jitsi auto-installation on Linode?

Yea Linode has a docker image or something that you can quickly create a server. My server I built manually ran for over a year but suddenly stopped working the other day. Something weird going on there.

Ah, ok… that makes it a bit tougher to debug. You might want to check with their support to see if they can help.

I also followed the steps to build one manually and got the same result.

What do you see in your browser’s js console when you try to start a meeting?

Everything comes up and I open a room but I can not enable camera or audio.

image

No, I got that. I meant the information/log in your browser’s js console. In Chrome, you can get there by navigating through: View → Developer - > JavaScript Console. Share what you see there while trying to start the meeting.

It wont let me share the entire console because Im too new and there are more than 2 links.

There are some errors though.

Is there a keyword you want me to look for to show you?

Can you take a screenshot of the errors?

Sure - I think I got most of it that way except for a piece that got cut off on the bottom.

I really appreciate you taking the time to help me on this!

systemctl status prosody

I got this error:

portmanager: Error binding encrypted port for https: No certificate present in SSL/TLS configuration for https port 5281

I had it setup with an SSL cert though.

I wonder if I should do Lets Encrypt?

This error message is not a problem.
It seems that Nginx cannot get a response from prosody. What is the full output?

I have no idea about Dockerized setup but “Gateway timout” message means that Nginx cannot get a response from the backend (prosody in your case) while prosody seems healthy