Semi-private, moderated Jitsi Meet site

Hello!

There are probably forum threads concerning parts of my thread, but what I’m trying to do, please tell me if it’s even possible without much re-developing Jitsi Meet.

  1. I’d like only administrators to be able to create new rooms. Protected with password or some other way of simple authentication;

  2. Created rooms last until some period (7 days for example), until some date/time reaches (05.04.2020 15:00) or administrator pushes “delete” button in a room. When room does not exist, visitors cannot join it anymore;

  3. When the room is empty, then one can gain moderator rights only with password or some other way of authentication;

Are those options achievable with few coding, configuration?

Thanks in advance!

  1. I’d like only administrators to be able to create new rooms. Protected with password or some other way of simple authentication;

Yes. That’s the “secure domain” config:

  1. Created rooms last until some period (7 days for example), until some date/time reaches (05.04.2020 15:00) or administrator pushes “delete” button in a room. When room does not exist, visitors cannot join it anymore;

Quite complicated config needed, I think, to make that happen. With “secure domain” config in place:

a.) only a privileged user can open a room
b.) once open, anyone can join unless someone adds a password
c.) when everyone has left, the room is automatically closed (and so requires a privileged user to open it.
d.) if you wanted a room to be persistent, even if no-one is in it, that’s not default behaviour.

  1. When the room is empty, then one can gain moderator rights only with password or some other way of authentication;

This is “secure domain” config.

Thank you for such fast reply!

The thing is, I’d like to send out meeting information beforehand it’s happening, therefore I need meeting URL/room to be created maybe even a week before the meeting takes place.

I’ll check out secure domain configuration - thank you!

You can send out the name of the conference as early as you like in the form meet.jit.si/conferencename
It will open as soon as you (or anyone) goes to that URL.
Your only problem is if someone has also chosen the same name for their conference - so you need to choose a conference name that is not likely to be used by anyone else

There’s nothing to “create”. Just generate your chosen URL/room name, and send it out. When people go there on the day/time in question, the server will create the room at that time.

I’ll try to make myself more clear.

I can create the meeting room beforehand with simple URL - understood.
Now what I’d like to restrict is that NOBODY ELSE, BUT ME can actually create the room and join it before me.
When room is created by me, then anyone else can join it.

But I’ll check out secure domain - it’s quite weird for me that Jitsi-Meet is “public to all” by default settings…
Is it really what most of the users want?

I can’t seem to get secure domain to work with as few as configuration as possible.

I created Jitsi Meet installation on my test environment with domain:
test.example.com

I followed instructions here:

  1. I edited prosody test.example.com.cfg.lua file.
    Changed to:
    VirtualHost “test.example.com

    authentication = “internal_plain”

Added:
VirtualHost “guest.test.example.com
authentication = “anonymous”
c2s_require_encryption = false

  1. Edited jitsi/meet/test.example.com-config.js
    Added line (yes, checked triple times that comma is existing in the end):
    anonymousdomain: ‘guest.test.example.com’,

  2. Added a line to /etc/jitsi/jicofo/sip-communicator.properties file:
    org.jitsi.jicofo.auth.URL=XMPP:test.example.com

  3. Created a new user:
    prosodyctl register testuser test.example.com testpassword

Saved all the config files, restarted services first, but then restarted whole system.

Jitsi Meet does NOT ask for password for creating new rooms.

Anyone care to help a bit?

EDIT: Nevermind… I had ONE typo and now it works great :slight_smile:

Thank you for helping me!

Good stuff :slight_smile: Glad you got it working.