[self-hosting] Not able to join an existing conf: it always create a new one where the user is alone

Good afternoon,

After installing Jitsi Meet on a Debian 10 server, I can create a new conf using a browser pointing to jitsi.myserver.com . I see the welcome page, then I enter a name or use a random one, then I am in a conf room. It asks authorization to use the camera and microphone, I accept.
But now, the microphone and camera icons are crossed and I can’t activate either of them. The permissions appear to be ok for the browser (tested with Firefox and Chrome). If I click on the microphone icon I can see the input volume move when I speak, and the speakers test works, I hear a ringing tone.If I click on the camera icon I can see a preview of my camera, with my face, it seems to work. But it stays disabled in the conf room, which stays black.
Furthermore, if I connect from another computer to the same room (I think, at least I used the same URL as given when clicking on “Invite more people” ), it seems to open a new room : “you are the only one in the meeting”, and same in the original room.

The only log that I can see change is /var/log/jitsi/jvb.log
Even when no room is supposedly opened, every 10 seconds I see:

2020-10-26 13:48:55.531 INFO: [25] Videobridge.createConference#260: create_conf, id=b60a2cc3137c29f4 gid=-1 logging=false
2020-10-26 13:48:55.537 INFO: [25] HealthChecker.run#169: Performed a successful health check in PT0.005625S. Sticky failure: false

The create_conf id is each time different. I checked via netstat, there is no other connection but mine on this server.
This is a bit strange, I’m not sure how to investigate this. Any help would be appreciated.

Did you allow to the UDP/10000 access?
Are the installation address and the web address same?

Yes, for now iptables is empty (and with policy ACCEPT), firewalld is not enabled.
I think I installed using the same address, yes. I followed the tutorial made by Matthew Hodgson in the Matrix. org blog: https://matrix.org/blog/2020/04/06/running-your-own-secure-communication-service-with-matrix-and-jitsi . Although in this tutorial the address entered when installing the deb package was myserver .com , and I use then jitsi.myserver .com

Is there any other firewall in front of the server? Something like AWS firewall…

This is OK

There shouldn’t, no. This is a VPS, without any firewall that I know of.

Is the prosody service OK

systemctl status prosody.service

It is, yes :

● prosody.service - Prosody XMPP Server
   Loaded: loaded (/lib/systemd/system/prosody.service; enabled; vendor preset: enabled)
   Active: active (running) since Sat 2020-10-03 09:14:33 UTC; 3 weeks 2 days ago
     Docs: https://prosody.im/doc
  Process: 4494 ExecReload=/bin/kill -HUP $MAINPID (code=exited, status=0/SUCCESS)
 Main PID: 11722 (lua5.2)
    Tasks: 1 (limit: 2318)
   Memory: 20.4M
   CGroup: /system.slice/prosody.service
           └─11722 lua5.2 /usr/bin/prosody

Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.

Maybe I misunderstood this part. Is the address when connecting to the server the same as the following

egrep server_name /etc/nginx/sites-enabled/*.conf

Yes, it is :

server_names_hash_bucket_size 64;
    server_name jitsi.myserver.com;
    server_name jitsi.myserver.com;

Is the client side behind a corporate firewall? Can it connect to UDP/10000?

Yes, connexion works, from client I did :

# nc -vz -u jitsi.myserver.com 10000
Ncat: Version 7.70 ( https://nmap.org/ncat )
Ncat: Connected to YYY.YYY.YYY.YYY:10000.
Ncat: UDP packet sent successfully
Ncat: 1 bytes sent, 0 bytes received in 2.03 seconds.

While doing a tcpdump on server:

# tcpdump -ni eth0 port 10000
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth0, link-type EN10MB (Ethernet), capture size 262144 bytes
17:17:32.207365 IP XXX.XXX.XXX.XXX.34095 > YYY.YYY.YYY.YYY.10000: UDP, length 1

is your domain accessed with https ? Are your mic and cam working on https://test.webrtc.org ? (never mind the other tests)

My mic and cam are working, according to the tests from a Windows Desktop. My cam pass the 320*240 and 640*480 test, but not the 1280*720 test.
All the other tests were ok except:

  • ipV6 (I disabled it)
  • Reflexive connectivity :
    [ WARN ] Could not connect using reflexive candidates, likely due to the network environment/configuration.
    I don’t know what this is.
  • Video bandwidth :
    [ FAILED ] Frame rate mean is 0, cannot test bandwidth without a working camera.
    But Data throughput tests are ok.

Note: I did the Jitsi connexion tests from a Linux laptop using Firefox, and from this Windows desktop using Firefox and Chrome. It’s the same situation for both computers.

I think I’ll get a dedicated small VPS to test Jitsi alone, without having Matrix.org and Element installed on the same server. It might not be relevant, but on the current VPS I only have 1vCPU (1.1% currently used) and 2Go of RAM (of which about 500Mo is currently used).

I don’t know about that but if you don’t have default nginx Jitsi setup, it’s obviously more difficult to setup it right. If may be a good idea to check first with a dedicated computer to see how it works and then you will have an easier task to adapt it to work with other software

it’s not relevant because Jitsi don’t work at all for now, but it’s a small configuration.

It works now that I installed it on a dedicated server.
I guess I messed up something on the previous one.
Thank you all for your help

1 Like