Self-Hosted Documentation -- Broken Links

I’ve been looking at DevOps Guide (scalable setup) · Jitsi Meet Handbook, and there are some references to sample configs (e.g. https://github.com/jitsi/jitsi-meet/tree/master/doc/example-config-files/scalable), but those links no longer work. Have they been moved or does anyone know where I can find them? I have a config issue and I’ll be the sample will guide me in the right direction.

Thanks!

Those were removed as duplicate and not up to date.

The easiest thing to do is create a standalone install of jitsi-meet on a VM and get the configs from there.
Or you can check out the templates used for the debian packages, you can find them here: jitsi-meet/doc/debian at master · jitsi/jitsi-meet · GitHub

Thanks for your quick response!

The vanilla meet server with video bridge on the same host works great. I’m looking for the specific setup changes alluded to in the scalable setup document that need to change to support video bridges on a separate host.

Everything is working as expected with the exception of screen sharing by users who are on a separate video bridge (their video works fine). I’ve found a number of discussion threads here, but none of the proposed solutions worked, so I was hoping to find more documentation.

The configs are the same, just need to point jvb to the correct ip-address instead of localhost.

This is a problem with websockets. That you need to handle in nginx.

Again it proxies the connection to the localhost jvb.

Oh! I think you lit a light bulb for me!

In my stand alone JVB, I have this (specifically the server id jvb1):

videobridge {
    http-servers {
        public {
            port = 9090
        }
    }
    websockets {
        enabled = true
        domain = "example.com:443"
        tls = true
        server-id = "jvb1"
    }
    http-servers {
      private {
        host = 0.0.0.0
      }
      public {
          host = 0.0.0.0
          port = 9090
      }
    }
}

And in the nginx conf, I reference it, but have localhost – I think you’re saying the proxy should go back to the IP of the second bridge on 9090, not on localhost. Is that right?

    # colibri (JVB) websockets for jvb1
    location ~ ^/colibri-ws/default-id/(.*) {
        proxy_pass http://127.0.0.1:9090/colibri-ws/default-id/$1$is_args$args;
        proxy_http_version 1.1;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection "upgrade";
        tcp_nodelay on;
    }

    location ~ ^/colibri-ws/jvb1/(.*) {
        proxy_pass http://<ip-of-remote-bridge-here?>:9090/colibri-ws/jvb1/$1$is_args$args;
        proxy_http_version 1.1;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection "upgrade";
        tcp_nodelay on;
    }

If you say jvb1 is your standalone one.

Then location ~ ^/colibri-ws/jvb1/(.*) { should go to localhost.

And you should adjust IP and server-id of the remote one in the other rule.

Excellent! That was the issue. Thanks so you much for your assistance!