Self Centering video stream

So we have been users of jitsi for over a year now and just recently a few of our participants webcams will try to center their video. it’s not every user but like right now we have 5 in the chat and 3 keep auto centering. two are using a desktop computer and one is a laptop. it doesn’t seem do it on mobile though.

is this a beta setting or something new?? can it be turned off???

If you;re hosting your own server, in config.js:

    faceLandmarks: {
       enableFaceCentering: false,
 },

we are not hosting our own server. we just use the meet.jitsi

Hi @saghul,

Remote video is not showing when participant count is 2 in Android mobile.

You can disable the feature using URL params. Add this to your meeting link:

#config.faceLandmarks.enableFaceCentering=false

@Sysmind_Tech do not hijack someone else’s thread, particularly when it has nothing to do with the issue you’re reporting. Create a new thread.

Also, refrain from tagging people in your requests for help, unless they’re already helping you with the issue at hand.

Thanks ill try it this wednesday on our next chat and let you know!

I have also been having a lot of difficulties since last week with this “face centering” feature. The camera seems sporadic at times and is a real detriment to my meetings. I tried your suggestion of adding that URL param. It didn’t work but I am not sure I included it correctly. I thought it was to be added when I invite someone to the meet but it would not let me add it to the url because it had symbols included that it would not except. So I then tried just adding it to my screen url after I had started but I still had the camera moving during the mtg. Could you share with me when/where I include the: #config.faceLandmarks.enableFaceCentering=false ?

Thank you!

To use the param, add it right after the room-name. So:

https://subdomain.domain.tld#config.faceLandmarks.enableFaceCentering=false

Example:

https://meet.jit.si/myinstance#config.faceLandmarks.enableFaceCentering=false

Once you’re in the meeting, you won’t see the config parameter in the URL, but it’s been applied.

Thank you for your help.
So I added it right after my room name and it seemed that my camera was staying centered for about half an hour. Though the others in the meeting kept being bounced around by their camera the whole time. Which is was distracting!
( I think it might have started again for me when someone left and the tiles all reconfigured but I am not sure.). Then at times I was not sure they were seeing all of me because it not only shifted but sometimes it zoomed in and I’d see just half of me. This is a huge problem!!
I need an option to disable this feature.

If you use the config params in the URL to customise your UI experience (e.g. to disable face centering), then that applies only to you since that is a client side customisation.

To influence everyone else’s experience, here are some options:

  1. Have them all use the same URL with the config override params when joining the meeting. For a quick way to create these links, try Jitsi URL Generator.
  2. Create your own landing page using the IFrame API that all your users will use for the meeting, and you can inject config overrides that way.
  3. Deploy your own Jitsi server and customise the config on the server side. That will affect the defaul experience off all participants.

Ok thank you I will try these and see if any help.

Oh… maybe I misunderstood. Did you meant other users in the call are seeing videos on their screen bouncing around but looks OK for you, or that their video on your screen is bouncing about?

I previously assumed the former. But if it is the latter, then it might be that you have not successfully disabled face centering on your end.

The feature does not really affect the actual video streams and only how your client handles cropping when it needs to.